Jump to content

E5470: Audio line-in not working on Big Sur (ALC293 with Layout ID = 11)


PMD
 Share

Recommended Posts

@Hervé Can I put CodecCommander in EFI/OC/Kexts? I don't want to interfere with L/E.

Besides, what is the best value for csr-active-config if I just need to install and use 3rd party apps without affecting the system and features like Software Update

Link to comment
Share on other sites

  • Administrators

Please consult our FAQ section re: SIP. There's a dedicated thread to describe it and the values that may be used.

 

By all means, do try and inject CodecCommander from that folder, but if it does not load, you'll have to cache it from /L/E; this will have to be done manually through Terminal and after enabling Gatekeeper:

sudo spctl --master-enable

Reboot then copy the kext to /L/E

sudo cp -R <path>/CodecCommander.kext /L*/E*/

Authorise the kext through Security & Privacy PrefPane and reboot again.

 

You may then disable Gatekeeper again if you wish:

sudo spctl --master-disable

 

  • Like 1
Link to comment
Share on other sites

Hi, I think something is wrong. I see 2 ports showing green dot in Hackintool and they are functioning properly. Meanwhile, the remaining port that is not working is Line In, which is not showing green dot. Mine is ALC293, I am using AppleALC with layout_id=11. Below is my ioreg file. In addition, I tried CodecCommander but it's still the same

MBP.ioreg

image.png.e5ade80c4497f3abc0bd9fcc62ce805f.png

image.png.b74d199fa34c09d0b92d8f54040c77a1.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...