Jump to content

Monterey on Dell precision 5520 - success but...


mpotturi
 Share

Recommended Posts

Hey Jacob... Thank you for your guide 

I took your EFI and upgraded it to OC 0.7.5 and installed Monterey on my precision 5520 i7 laptop. My audio doesn't work, reboot, shut down doesn't work. Reboot & shutdown basically freezes the machine. Tried different layout-ids for audio but no joy. Can you please help me? What do I need to attach here? EFI for sure. Anything else?

 

Thank you in advance,

Mohan

 

Link to comment
Share on other sites

Jacob... I have uploaded the items you have asked for. Please take a look. First I thought my machine was freezing just on reboot/shutdown commands but I realized it happens just about randomly. Today it happened quite frequently. Like within 5 minutes of logging in. Hopefully you will find something I messed up. Thank you.

Link to comment
Share on other sites

Here are the items after disabling BluetoothInjector kext. Originally I had a dell wireless card DW1820. But it never worked for me either in Big Sur or Catalina. Since it did not work in Monterey also, I just replaced it with a card that has built-in support. If dell card can be made operational under Monterey, it would be an added bonus I guess.

 

Link to comment
Share on other sites

  • Moderators

DW1820A is supported, NOT DW1820, they are not the same card. DW1560 and DW1830 remains working but not Bluetooth.

You don't have graphics acceleration, let's try to get that work. 

The freezing is also contributed by FakePCIID*, just disable them all. Seems it's not longer need for HDMI audio.

Link to comment
Share on other sites

Unfortunately my card is DW1820 not 1820A. So I will have to live with the other card. But the problem is that other card doesn't have windows driver and I use this laptop for both windows and osx. Anyway, I will disable those FakePCIID* kexts and report back. Thanks Jake.

Link to comment
Share on other sites

Thank you Jake. I have further trimmed down my EFI removing the kexts relating to wireless (Airport*, Brcm*), FakePCIID* and made a change to ig-platform-id 00001F19 -> 00001F59. Now my audio is working with layout-id of 72 and graphics acceleration seem to be just fine. Random freezing also stopped. Restart/Shutdown commands now do not trigger freeze. Sleep/wake is also working just fine. I will however try your refined EFI attached in the above post. I have questions about CPUFriend*, Sinetek-rtsx & verb-stub kexts. What are they actually supposed to do and are they really doing anything good for me right now? The wireless card I aam using now as replacement for dell 1820 is: BCM94352Z. It gives me both wifi and bluetooth. Looks like it is natively supported in osx. Here are the EFI & IOReg status currently.

EFI.zip Mohan’s MacBook Pro.ioreg

Link to comment
Share on other sites

  • Moderators

 CPUFriend*= For optimizing performance. You can't use the one I have since it's make for the specific CPU

Sinetek-rtsx= SD Card reader, my new pack uses a new kext by FireWolf, better performance

verb-stub= For combo jack, need to be combine with the script included in my guide

 

Looks like you'll need to change the smbios as well to MBP14,3

When you do that you'll also need to update the USBPorts_5510 kext info.plist to MBP14,3 as well otherwise the kext won't work since it's hardcoded to MBP13,3

I had made all those changes in my bootpack above, FYI

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...