Jump to content

Latitude 7280 sleep/wake issue


4farrell
 Share

Recommended Posts

Hi friends:

    I have a latitude 7280 and yesterday, I finally get a macOS Monterey successfully installed.

    But I'm facing a new problem with sleep/wake. After I click  -- sleep, the screen will become black, and light up after a few sec at the login screen. Or if I close the lid, same situation, after a few sec, the fan start up and it won't sleep.

    I tried to use Lorys EFI to install, it won't work, and so I found one in this site and it works. 

    After installation, I followed Lorys guide, already set the CFG lock disabled and modified DVMT to MAX.

   Please have a look at my EFI and thank you so much.

   Specs: i5-7300u

   Memory: 16G 2133 DDR4

   SSD: WD SN550

   BIOS Version: 1.23.0

  The Kext folder is so big it can't be uploaded here. So here's the pic of this folder

 

Xnip2021-12-20_23-20-04.jpg.c6eea3707c7b0afc2d08919781e9e397.jpg

ioreg.ioreg EFI.zip

Link to comment
Share on other sites

Hi Jake:

 

I tried to disable Hibernation as the result looks like this:

 

Xnip2021-12-22_18-20-53.jpg.7289ec72bdd8aa9e5e63dced8159b207.jpg

 

And then I unplug all usb device even the AC adapter, reboot, and then try to sleep. The screen will become black, but the LED of  keyboard and power button still on, after 6 - 7 seconds, the screen lights up and shows the login screen :P :P :P  

I teseted for  times, reboot -- login -- sleep, all the same result.

 

Link to comment
Share on other sites

  • Administrators

Have you considered opting for a more traditional set of ACPI patched tables such as those provided in the Dortania documentation rather than your single unified SSDT which may not be entirely adequate? Also bear in mind that you may have to inject power settings for your USB controller/ports to obtain proper sleep. I'm thinking about tables such as this one:

SSDT-XHC.aml.zip

 

You may also find it useful to check your power assertions which may provide hints as to why sleep isn't working. Use the following Terminal commands:

pmset -g assertions
pmset -g assertionslogs

 

Link to comment
Share on other sites

Thanks Hervé. I tried the command to view the assertionslog, saw tons of fatal error created by bluetool. So I disabled the BCM bluetooth kexts in config.plist. seems solved this problem. After close the lid, the system will goes to sleep. And wake with no issues. By clicking the sleep button still the same, but it works for me. I can take that hah, thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...