Jump to content

Latitude 7480 (Kaby Lake): OpenCore and Clover packs for Big Sur, Monterey and Ventura beta


Recommended Posts

So, I managed to boot to Monterey now and I did installed Mojave on another partition on the same SSD. Weirdly, after I put the EFI folder into it's place, opencore can boot just fine but it doesn't seems to read my Mojave partition. Only the one that I Installed Monterey on is listed. 


I used apfs in both. The only way I can boot into Mojave is by using my opencore USB installer.. does that mean that the dual booting osx should be done using different disks?


Thanks. It turns out that I just need to add  no restriction on apfs setting on opencore. Now it shows all the partitions. 

Link to comment
Share on other sites

On 8/2/2022 at 10:37 AM, Baio77 said:

Hackintoshes with CPUs equal to or higher than Skylake it is possible to disable HPET with specific SSDT, this also allows you to eliminate the HPET rename in config, so this is a nice optimization. I say this because in the ioreg you have both HPET and XPET and this is anomalous.

  Reveal hidden contents

DefinitionBlock ("", "SSDT", 2, "OCLT", "HRTfix", 0x00000000)
    External (HPTE, IntObj)

    Scope (\)
        If (_OSI ("Darwin"))
            HPTE = Zero



For the trackpad you should try to change the settings in System Settings \ Trackpad 
https://github.com/Baio1977/DELL_VOSTRO_5501-ICE-LAKE/blob/main/Screenshot/Touchpad Ventura.png

Thank you! Those were very helpful suggestions.

On 8/3/2022 at 7:16 AM, Hecatomb said:

Sure. You can use settings to loading only some kexts for each macOS version. You only need to set the kernels.

MinKernel -> lowest kernel version your kext will be injected into, see below table for possible values. Ex. 12.00.00 for OS X 10.8

MaxKernel -> highest kernel version your kext will be injected into, see below table for possible values. Ex. 11.99.99 for OS X 10.7



Thank you! I used these suggestions for matching the AirportItlwm to version.

Thanks to baio77 for suggesting disabling HPET and duplicate XPET injected.
Thanks to Herve for suggesting MinDate/MinVersion == -1 for older systems
Thanks to Hecatomb for suggesting MinKernel/MaxKernel for selecting Kext by range of kernel versions

Please refer to contents of attached 'oc83-7480-current.zip' to understand what I write next.

Big problem:  Ventura beta 4 downloads 1.2GB beta 5, but freezes at the 25 minute mark.

Update: Problem was averted by booting from Clover.  See updated attachments and build notes in the first page of this topic.


Update 23-Aug-2022:  When OS upgrade to Monterey failed, I reviewed the OpenCore config settings and made changes.  The OS upgrades now work without changing bootloaders.  The first page in this topic has updated Clover and OpenCore packs.


Edited by trifle
Problem solved, refer to updated attachments
Link to comment
Share on other sites

Tried to use this EFI on a 7480 with 7300U (latest BIOS 1.30), Monterey 12.6 install. Stuck at this screen (screen shot), with the last line message:

"AppleKeyStore:863:0: oy vey

using 16384 buffer headers and 10240 cluster IO buffer headers"


Did NVRAM reset. Enabled NVMeFix (Note: the screen shot was taken when booting from Monterey USB install, while I still had the Windows SSD drive in). But made no difference. Any idea what went wrong/missing? 




Link to comment
Share on other sites

I had Western Digital SN730 512GB in there when I encountered this issue. When I took the screen shot,  I had the original SSD back (Samsung PM991, non macOS compatible, I believe, with Windows installed).

The real issue, as I updated my post above, was apparently related to the latest BIOS.


UPDATE (3/17):

It turned out that I have to disable this BIOS setting - "Enable Legacy Option ROMs" (under General->Advanced Boot Options). Now, this EFI worked fine even with latest BIOS.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...