Jump to content

Latitude 7480: couple of issues under Monterey


Recommended Posts

Hi, I have a fully working 7480 i7 Skylake running Monterey 12.6 for now. Currently have 2 issues;


1. USB-C / Thunderbolt 3 breaks after sleep - (only power mode /charging via USB-C remains)

2. Keyboard Trackpoint & mouse buttons works fine after reboot/restart but breaks after waking up from sleep.


I can live with Issue #1 as there is no real solution for that now but #2 keyboard trackpoint & mouse button annoys me. Already tried all kexts available but the problem still not solved yet. Do you guys have the same issue? If not, do you guys mind sharing the solution or tricks in order to fix the keyboard trackpoint issue?

My trackpad works fine though - 1/2 fingers tap, multitouch/gestures works fine.


Here is my current EFI folder;


(anyone feel free to use my EFI but generate your own smbios & serial etc.)


Link to comment
Share on other sites

Turn out that I'm missing SSDT-ALC256.aml in my ACPI folder. Setting "layout-id" to 21 & "boot-arg" to alcid=21 does the job. My audiojack now works fine.


On 10/18/2022 at 1:23 PM, Baio77 said:

For TB3 ports, sleep and Wake are mangy, on my Lenovo T14 I tested ACPI stuff that fix Hot Plug problem, I need ioreg of your Hack and original DSDT after we can do tests if you want.

I'll upload them here asap sir. A bit busy this week.

Link to comment
Share on other sites

  • Create New...