Jump to content

[Solved] Dell Latitude 5591: Ethernet & keyboard issues


cryochase
 Share

Recommended Posts

Hi all,


It's first time that happened to me after several installations of macOS on non apple devices soo..
Running macOS Monterey with the latest OC specs below.

 

Spoiler

i7-8850H
UHD 630
MX130 (disabled via boot-arg)
i219-LM

Wireless-AC 9560


1) Ethernet issue; tried everything I'd say and it's still not working, several kexts such as mausi, smalltree. Tried newer/older versions of kexts and still nothing. Wi-Fi/Bluetooth works like a charm without any issues.
2) Keyboard bug? After a while of using T/Y/Backspace stops working, it gets back on working after restarting the whole machine.

EFI is too big to be uploaded; see here.
IOReg extract below:

Daniels-MacBook-Pro.ioreg

Link to comment
Share on other sites

  • Moderators

There's no indication that there's a built-in ethernet according to the IOReg file. Check your BIOS, make sure it's enabled.

Remove IntelMausiEthernet and replace it with latest IntelMausi

Remove ACPIBatteryManager, you already have SMCBatteryManager.kext

Lastly, you have an issue with the truncated SMBIOS

To fix it, enable 

CustomSMBIOSGuid

Change UpdateSMBIOSMode to Custom

in the config file

  • Thanks 1
Link to comment
Share on other sites

  • Administrators

All Dell Latitude have a BIOS section about LAN & Wireless devices. Please look this up in your BIOS settings. If in doubt, look up the documentation for your Latitude model on Dell's site (support section).

 

NB: As per our published rules, please refrain from quoting entire posts to reply; forum provides a Reply box at the bottom of each page so use that instead.

Link to comment
Share on other sites

Sorry Herve, thanks boys I’ll give a go now! ♥️

Alright boys, ethernet working! Keyboard, we will see after a while of using.
Now all I need is get HDMI/Docking station running hopefully it won't be that painful!
If any tips give me a shout lol

Thanks again! ❤️

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...