Jump to content

[Solved] E7440: Problematic Trackpad & right click


gelomon
 Share

Go to solution Solved by gelomon,

Recommended Posts

I am having a problematic right click. I have been using the bootpack from @Jake Lo and was running smoothly with Monterey. This is my only problem. Right click on the button does not work, right click with 2 fingers work but buggy (repetitive clicks back and forth). Scrolling also triggers right click. Also the touchpad was not recognized as touchpad

 

What I have tried:

  • VoodooPS2Controller & VoodooPS2Controller-ALPS on bootpack - buggy right click, seems like right click and 2 finger scroll is mixed. when scrolling is disabled, I can trigger right click with 3 consecutive touchpad clicks
  • VoodooPS2Controller (Latest from acid) - Not working
  • Touchpad is working smoothly without issue on windows 11 (22H2) 

 

I attached the sample screen recording of what's happening. I also attached the IOReg if that will help.

 

My hack details:

  • e7440 i5
  • 12GB RAM
  • Alps v3 (as per boot logs but I'm not really sure)
  • Bios: A28
  • Monterey 12.6

 

Regards,

John

 

Screen Recording 2022-11-25 at 9.42.53 AM.mov.zip John’s MacBook Pro.ioreg.zip

Link to comment
Share on other sites

  • Solution

I will mark this issue now as solved. I have compiled the VoodoPS2 from source of Acidanthera putting back some codes that were removed and added some fixes for v3_v5 inputs. Now my touchpad is working great and is usable upto 3 fingers. No back scrolling, no Jittering, no Jumping. Only problem was the right click on the right button, it is not working but the 2 finger tap is working but not that responsive even the other 2 finger taps were removed. This is solved by disabling 2finger tap on preferences and I used better touchtool to set 2 finger tap as right click and it works fantastic.

 

 

Link to comment
Share on other sites

I type alot ( I work as a dev and I type alot). I always accidentally move the mouse which is annoying. Typing timeout does not apply to trackstick, it works even when I'm typing. lol

USB Mouse is working fine without any issues even without VoodooPS2Mouse Kext on my laptop

Edited by gelomon
grammar
Link to comment
Share on other sites

  • Moderators

Just got around to using it.

 

My E7440 is also V3 Rushmore.

Touchpad works pretty well

Swiping and zooming works

Right click also work without any modification

Slow scrolling is a bit jittery if you don't pick your fingers off the touchpad.

 

Issue I have is that I do use the track stick a lot more than I would the touchpad

With this version, scrolling with the middle mouse doesn't work

I can't highlight with the left mouse of the track stick. Right click also works on the track stick.

If you could add those 2 feature, that would be awesome!

Link to comment
Share on other sites

I would try to implement this if I got free time, but the main problem is I might have a faulty touchpad on my e7440 to begin with. My trackstick left / right /middle is not working just the trackstick itself. my right button on trackpad does not also work. smh

If there will be any progress or development on the future, I will surely let you know 

Scrolling slowly is due to finger detection. yup a bit jittery lol

 

You can also try the original version from acidanthera if there are any difference you can experience. I just made the changes I done (maybe to cope up with faulty touchpad) but If you report that it's much better that Acid's version then I might request a PR on the repo for the Rushmore

Link to comment
Share on other sites

  • Moderators

acidanthera's kext has portings from skyrilHD's code to support Alps. I didn't know it supports v3 Rushmore since I've never tested it on the E7440.

So it's works almost the same as yours. 

No scrolling with the middle mouse with the trackstick. The left mouse can click but can't drag, same as yours. But if I use the trackstick left mouse, I could drag it with the touchpad, just not with the trackstick. Also can't highlight text.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...