Jump to content

Precision 5510: unable to install Ventura


Justin Wallis
 Share

Recommended Posts

Computer: Precision 5510 I7, Touchscreen edition, 32GB Ram

 

I followed these Precision 7x10 BIOS settings (i didn't see anything for 5510 and & installer says use other DELL related BIOS settings).

The EFI is used from @Jake Lo's Precision 5510 guide (the only thing i did with the EFI is change the name to EFI)

 

I tried it with and without the Intel 8260NGW wifi Card installed and I also tried a USB stick with Ventura 13.1 & 13.01 (with same exact results).

 

It sticks here:

IMG_9737_HEIC.jpeg.96964da85f40c139be94161707aa23f5.jpeg

 

2nd, 3rd, 4th, 5th....20'th +  try, is just looks like this at the end:

IMG_9735_heic.jpeg.931562eea76ffe439841768c12bebd06.jpeg

 

I've had success for years, using same EFI's from Jake Lo. But, this is the first time trying Ventura ones. The USB was formatted in GUID, Journaled.

 

A Video of hang/errors when trying to boot Ventura Installer shows lots of "Failed bootstrap...":

https://imgur.com/dR1IOXB

 

I'm all outta guesses. Can't be the BIOS, the new one (recommended) just came out in July 2022. I have the last recommended one v1.7.0. I might try updating to the new BIOS update after i get the Installer figured out. Since it's so new. I am interested if anyone else has success with the newest BIOS before i try that.

 

Maybe i should try a totally different USB?

Should i try Ventura 13.0?

Maybe i should take the Wifi card out, then reset NVRam and try it? I forgot to reset the NVRam after i took it out last time.

 

It's the TouchScreen model of Precision 5510, that shouldn't make a difference right? I've had it disabled in BIOS settings the whole time. I have the BIOS settings EXACTLY as mentioned in the above article, i've checked them several times.

 

Does anyone have any recommendations? Or am i missing something? TY!

 

Link to comment
Share on other sites

The display resolution is 61-Inch 3840 x 2160) Maybe because it's a 4k Touchscreen or something. I don't really know why.  

 

I used OCC v2.62.1.0 to add the -igfxvesa boot arg. At first i replaced -igfxmpc, but added it back later. I'm guessing I should keep -igfxmpc also? Maybe i should try another install with both flags?

 

So, Ventura ended up Installing, but i had to force restart like 3 times during installation. Either because it was stuck or kernel panic. When it actually booted into MacOS Ventura, the Graphic Acceleration and Wi-fi wasn't working. :( (It's super laggy when loading Launchpad, etc). The Touchscreen works though!! Wasn't expecting that! 

IMG_9754.heic-1.thumb.jpeg.6e2b317d4b9a8af079bbaae45f6017a1.jpeg

 

I had to turn the display down from 2160 as the default! wowza, everything was so small.

IMG_9755_HEIC.thumb.jpeg.c3f7beebfeb30491095364316f570863.jpeg

 

Also, tried doing all the Post-Install stuff, and during the ComboJack Install, the last step, when typing "sudo ./install.sh" it said "unknown command". I even switched the terminal to bash from zsh. I was pointing to the install file (was in the folder on terminal), so i'm not sure why that didn't work. 

719684484_ScreenShot2022-12-19at12_00_07AM.thumb.png.7b4a6efcc9a9b328e594071ad54a63ea.png

 

And i also have to wait to use genSMBIOS for when i get internet, and i don't have an usb-c ethernet dongle yet. Was going to do that part when i get wifi working.

 

How do you suppose i can fix the wifi and graphic acceleration issue?  Maybe try the install again? I was under impression Intel wifi cards work out of box now.  Thank you!

 

Screen Shot 2022-12-18 at 11.20.58 PM.png

Link to comment
Share on other sites

  • Moderators

No, don't know where you get that impression. You'll need the alpha version for Ventura Airportitlwm.kext and IntelBluetoothFirmware,kext + IntelBTPatcher + BlueToolFixup for Bluetooth.

As for the 4k display, you'll need to find the right patches for it. Read up on Whatevergreen

Link to comment
Share on other sites

  • Administrators

There's no official support for SKL HD5x0 graphics in Ventura. See our posted documentation in the hardware info section. You must use SMBIOS MBP14,1 + latest version of Lilu + Whatevergreen + inject the correct KBL graphics parameters. You may also consult my E7270 Ventura guide for pointers.

 

See the Whatevergreen Github page + User Manual.

Link to comment
Share on other sites

Okay. So at the FAQIntelHD: https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.en.md 

It's telling me i can try the boot-arg igfxframe= then try all these (the mobile ones in the next picture), and one of them should fix the Graphics Acceleration?

 

 My boot arguments looks like this specifically:

Only thing added from original precision 5510 EFI was adding the -igfxframe=xxxxxxxx

Example: debug=0x100 agdpmod=vit9696 -igfxmpc -igfxframe=0x193B0005 -igfxdarkwake=1 alcdelay=500 alcid=72 -v

 

I took out the "-igfxvesa" for testing because it disables intel graphics (and that was only used for getting through to the installer i'm guessing). That is correct, right? Doesn't look like i need any other flags. In the "Spoiler: SKL Connectors" Dropdown Area the only spot that uses 530 is igfxframe=191B0006, but I get the same spot it hangs at.

 

Spot it hangs at, after what seems like the end of the loader, after it flickers (which is i guess the graphics acceleration not loading properly):

IMG_9798.thumb.jpg.5109504105cc7e7a34a54152bc09c807.jpg

Link to comment
Share on other sites

I tried the 14 mobile and 4 desktop skylake framebuffer boot args with no success.  ( igfxframe=191B0006 and so on, all of them listed on the above image) 

Shoot. It says i need to try the Kaby Lake ones instead for macos 13 Lol, woops, trying these!!:

 

So, boot arg needs to be:  igfxframe=591B0000  without the dash ( - ) in front of it?  Starting over...   What does the dash even do, why do some boot args have it and some don't?

Link to comment
Share on other sites

Thank You SOOOOO Much!!!!!  It worked!!!  Graphics Accelerated!!!!  You're the mannn!!!   

 

IMG_9803.thumb.jpg.dd01a057d14037ead068ec85dfaa7c90.jpg

 

I was dying trying to configure myself. But, i feel like i learned a little bit along the way, and i'm grateful!

 

Now, i will try to get: "alpha version for Ventura Airportitlwm.kext and IntelBluetoothFirmware,kext + IntelBTPatcher + BlueToolFixup for Bluetooth" working.

https://openintelwireless.github.io/IntelBluetoothFirmware/FAQ.html#what-additional-steps-should-i-do-to-make-bluetooth-work-on-macos-monterey-and-newer

826286101_ScreenShot2022-12-24at9_44_55AM.png.8c4f3432b7a5290ff6fb1396cf73e797.png

 

Which is: I think this one:

https://github.com/OpenIntelWireless/itlwm

1697088871_ScreenShot2022-12-24at9_34_55AM.png.fbbefc564d3f84f616f1f33e93b6e231.png

And these:

https://github.com/OpenIntelWireless/IntelBluetoothFirmware

https://github.com/acidanthera/BrcmPatchRAM

 

Will post pics when Wifi / Bluetooth works!!!!   Yaaayyyy!!!

Link to comment
Share on other sites

I didn't replace BluetoolFixup.kext, because there is a newer version of BluetoolFixup.kext in the kext folder already. 

(Newer than the one downloaded from https://github.com/acidanthera/BrcmPatchRAM

 

But, when i add these to my Kexts folder:

1937978647_ScreenShot2022-12-24at11_06_02AM.png.1d402792fa70054bacae75a6e3e9a50e.png

 

Then press "scan/browse" inside of Kernel, then click save (inside of the same OCC V2.62.1.0), I get a KP:

IMG_9804.thumb.jpg.d435a6d7c56962199301b9e744a32d40.jpg

 

My Working EFI Folder (With No Intel Wifi/BT): *Was too big (35mb .zip) to upload via this website.

https://www.mediafire.com/file/nel372cabdm7rc5/Precision_5510_4k_0C_0.8.5_-_Ventura.zip/file

(This is just Jake's precision 5510 EFI folder, with his above .plst file for 4K. But, with the above mentioned kexts (for intel wifi/BT) added to the kext folder, but not added to .plst file)

 

I updated to 13.1 successfully tho :)

 

 

Also: I did notice i still get black screen after either sleep or poss screensaver. Is there an easy fix for that also? Thanks!!! :)

 

Is there anything that i need to do before adding the Intel Airport/BT kexts that is causing this conflict/kp?

Do i need to disable the brcm wifi kexts first or something?   ***( I eventually didn't get this intel wifi/bt kext error/kp when i dragged the kexts from the efi/kexts folder to OCC, instead of dragging from different folder to occ to for some reason ) ***

 

Thank You!!

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...