Jump to content

e6430


engsmart
 Share

Recommended Posts

that works, can boot with usb...no trackpad working and nothing else really

try to use the myhack with generic and can boot only in safe mode :-(

 

anyhow... I just wish that I'd received from the university a mac instead even if I could pay the <>

 

I hate ruindows :-(

 

Dear eng,

Did you try to install chameleon using myhack?

Cheers.

Link to comment
Share on other sites

I have been struggling with a similar E6430 with slightly different specs.

Display is my biggest problem. It is HD+ (1600x900) and therefore not regonized by the existing DSDT's.

There are also different processors that can be in these units. Mine is an i5 3320.

 

I've extracted the acpi tables via SystemRescue CD but dont have the expertise to create a working DSDT.aml file for my unit.

 

For the OP try booting with the following flags:

-v -f -x DSDT=Null

I've been able to do this and get safe mode running, complete initial Mac setup and even do some updates.

 

I did use a usb mouse in safe mode but was able to install using onboard touchpad and mouse by having myHack integrate the E6430 pack on the key.

 

Can anyone recommend next steps for getting some additional DSDT's?

Thanks for making it much easier!

V.

Link to comment
Share on other sites

This is a very tricky laptop to get to work perfectly. I've done about 10 D and E series latitudes but this one turned out to be the toughest, The fact that it ships with various processor types and graphics doesn't help things. I strongly suggest that you create a time machine partition when you install ML and take snapshots each time you make progress. This way if something gets screwed up along the way, you can always go back instead of restarting from scratch.

 

Mine is an i5 3320 with HD4000 and so far, this has been the toughest one to get os x working smoothly on. I had everything from a hw perspective working 95% perfectly last week but managed to hose it up addressing some software issues. Once this thing is working 100%, I'll post my files.

 

The external USB mouse is finicky, the built-in display prefers to turn off and go to the external monitors, etc. But I did have it working at some point.

Link to comment
Share on other sites

I tried the install link but it uses the 1366x768 screen that doesn't need the Dual Link patch to the DSDT.

If I use the device properties method, OR the DSDT, when entering graphics mode, the screen starts black and turns ugly white with dark edges and corners... I'm sure this is not good for the LCD.

 

Can I take the E6430HD4000.zip DSDT and add the Dual Link patch?

Could someone tell me where in the DSDT I need to place the code or even a approximate line number?

One place in the E6430HD4000 DSDT already has the Dual Link Code,  (I'll double check to make sure it is identical)

 

I'm getting very close. 

Still starting with -v -s DSDT=null

I changed resolution in org.chameleon.Boot.plist to 1600x900x32 and I have a very nice screen in Safe Mode.

Onboard Keyboard & TouchPad also working in Safe Mode (Yay!)

eBay Broadcom works fine but displays as Third-Party Wireless Card (who cares as long as it connects via WPA-2)

 

Thanks all for the suggestions.

Veritae

Link to comment
Share on other sites

Veritae,

 

You and I must have identical devices because we are experiencing similar problems. The DSDT included in the zip does not like 1600x900 screen resolution which is what I have. I also have the i5-3320 processor and I believe the DSDT is built around the i7. I can see why you say you are very close because I feel the same way. I'm working on creating a DSDT for this model from a vanilla DSDT and patching from other sources. I had to do something similar for an e6520 that I have. But yes, DSDT=NULL (or renaming/removing it from Extra) is a must until we can get past this hurdle.

Link to comment
Share on other sites

post-3635-0-93757400-1367038781_thumb.pngAnd then there was hope! For the first time I am able to run 1600x900 on the HD4000 built-in display. This is a work in progress where I am snipping things from different sources. This was the result of DSDT code from Jake Lo's DSDT and the DSDT for the e6430's that have the NVS 5200 graphic chip. The memory is detected as 384MB instead of 512MB but that should be easy to fix. I'll post some files once I can confirm that I can build this thing 2 or 3 times without any issues using the files I am currently using. 

 

 

Link to comment
Share on other sites

I made some more progress...

By changing the version byte in the E6430HD4000 DSDT from 03 to 09 (see below) I was able to avoid the "ugly screen" and noted that the screen went totaly black.  As though the output was shifted to another port.

 

Sure enough, when I hooked it up to my HD TV, I had a glorious 1920x1080 screen.  I was unable to get a screen shot because the keys seemed wonky.

 

I'm going to start calling this one E6430HDp4000 since the screen is HD Plus (check the F2 System Setup info)

 

The Graphics/Displays section from the system report.

 

Intel HD Graphics 4000:

 

  Chipset Model:     Intel HD Graphics 4000

  Type:                    GPU

  Bus:                      Built-In

  VRAM (Total):      512 MB

  Vendor:                 Intel (0x8086)

  Device ID:            0x0166

  Revision ID:          0x0009

  Displays:

SHARP HDMI:

  Resolution:         1920 x 1080 @ 60 Hz

  Pixel Depth:       32-Bit Color (ARGB8888)

  Main Display:     Yes

  Mirror:                Off

  Online:               Yes

  Rotation:            Supported

  Television:          Yes

 

Now I'm going to check into what resolved the "internal/external" display problem mentioned elsewhere here.

            Method (_DSM, 4, NotSerialized)
            {
                Store (Package (0x08)
                    {
                        "AAPL,DualLink", 
                        Buffer (0x04)
                        {
                             0x01, 0x00, 0x00, 0x00
                        }, 
                        "AAPL,ig-platform-id", 
                        Buffer (0x04)
                        {
                             0x09, 0x00, 0x66, 0x01
                        }, 
                        "hda-gfx", 
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }, 
                        "model", 
                        Buffer (0x17)
                        {
                            "Intel HD Graphics 4000"
                        }
                    }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }

Update:

I now have Quartz (translucent menu bar) running with the DSDT from the E6430HD4000.zip modified as above.  HD Kext is loaded.  Really just the massive list of VoodooSDHC errors now.

 

To get the output to display on the LCD, I had to use a modified AppleIntelFrameBufferCapri kext from another site (not sure which 10.8.x version it is though).

 

http://iFail.me/forum/viewtopic.php?f=77&t=23300

 

Sound is working working, including auto detection of headphones, Mic working.  Shutdown does a restart and sleep looks to be broken.  I'll work on researching USB issues also.  I think the 2.0 3.0 issues are related to rate matching internal hubs.

 

I've also seem to have lost the ability to autosave screen captures to the desktop.  Maybe having quartz active did something?

 

Veritae

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...