Jump to content

HP Pavilion dv7: no wake from sleep and no restart


Nero_sc
 Share

Recommended Posts

I got this old HP DV7 from my sister, it's like new because she almost never used it. I bought an SSD and thought about installing Windows or Linux to use for light tasks only. It worked great and so I decided to try installing OSX. After a lot of reading and work I was able to install Catalina, Big Sur and Monterey with almost everything working. I've set up proper USB mapping, cpu and gpu power management are working, wifi/bluetooth, almost perfect.

 

I would like to continue using it but I need help with the wake from sleep and restart problem. After putting my system to sleep, attempts to wake it will result in a reboot. And when I put it to restart, the process starts, the screen goes off and it stays on without restarting. I haven't been able to figure out what's causing this issue.

 

I'm unsure what to do next. Any ideas or similar experiences?

This is my OC EFI folder https://drive.google.com/file/d/1jfQ-5LtTfGhGPDLJs8DxKRVYm1pyywCs/view?usp=share_link  (can't attach here because of the size)

 

I've attached other files to help. Thank you.

IOReg.ioreg.zip Others files-logs.zip

Link to comment
Share on other sites

Hi Hervé, thanks for reply. It's a laptop and these are the specs:

  • Intel Core2Duo P8700 2.53 GHz
  • 4GB RAM
  • NVIDIA GeForce 9600M GT 512MB (10de:0649)
  • 17.0" WXGA+ 1680x1050 built-in LCD
  • 250GB SATA SSD + 500GB SATA HDD
  • MATSHITA UJ8B0AW CD/DVD RW drive

  • IDT 92HD71B7X High Definition Audio (Codec 111d:76b2)
  • Realtek RTL8111/8139 10/100/1000 Gigabit Ethernet (10ec:8168)
  • Intel WiFi Link 5100AGN Wireless (8086:4237)
  • Broadcom BCM2045 Bluetooth 2.0 (03f0:171d)
  • JMicron IEEE1394 controller (197b:2380)

 

External Ports

  • 5-in-1 Card Reader
  • 4 x USB 2.0 (4th port shared with eSATA)
  • 1 VGA
  • 1 HDMI
  • 1 RJ45
  • 2 headphone-out
  • 1 microphone-in
  • 1 notebook expansion port 3
  • 1 IEEE 1394 Firewire (4-pin)
  • 1 InfraRed

 

I know, it's an old laptop but it's not my main laptop, I have another one. It is working very well with OSX, not for heavy tasks of course. I just want to try using it as an option for a while longer.

 

I believe I did a good job editing the DSDT and I also think the config.plist is correct. I think sleep is working because when he turns off the power led is blinking indicating that he is in sleep state. I can put it to sleep by selecting it from the Apple menu and closing the lid. It also goes to sleep when not in use. So I can get out of sleep by pressing the power button or opening the lid. But then it just restarts. I'm not sure but maybe it's some problem with memory space allocation.

 

And sorry my english, I'm from Brazil ;)

Link to comment
Share on other sites

  • Administrators

Thanks for posting the specs; a very old laptop indeed. You should be using SMBIOS of MacBookPro7,1 rather than MBP6,2 which was a 1st gen Arrandale platform.

Also note that OpenCore does not properly care for CPU power management of pre-SandyBridge systems. As such you may want to consider switching to Clover (r5150 or later for instance).

 

Re: wake issue, did you disable hibernation? It's enabled by default and certainly needed to be disabled on most platforms in the past and still today. You may lookup our dedicated thread on the matter in our FAQ section.

Re: DSDT, don't hesitate to list the various patches you applied/implemented; this is not something we'll be able to guess.

 

One final comment about your OC config and the graphics properties you inject, I'm not sure you got that right. The IO location you specified looks erroneous to me; but it sure does not prevent you to gain graphics acceleration according to your IOReg. For your info, your nVidia dGPU is PCI0.PVGA.GFX0 so the correct device location is "PciRoot (0x0)/Pci(0x1, 0x0)/Pci(0x0,0x0)".

HP_DV7_GFX0_IOReg.jpg

 

You should therefore adjust your config to remove what I believe to be a typo of some sort in your config:

nVidia_dGPU_location.jpg

Link to comment
Share on other sites

About the smbios.

- MacBookPro6,2 (Arrandale ) I have power management, GPU Acceleration and UHCI (usb ports) working with Big Sur and Monterey

- MacBookPro7,1 (Penryn) I have power management, GPU Acceleration and UHCI working with Big Sur but I lose UHCI (usb ports) with Monterey.

- MacBookPro8,1 (Sandy Bridge) I have power management, GPU Acceleration and UHCI (usb ports) working with Big Sur and Monterey

I was using MacBookPro6,2 thinking about upgrading to Monterey later but I have no problem just using Big Sur if I can get sleep to work. Which smbios do you think is more suitable to use? Using 7,1 now.

 

About Clover, I tried to use Clover several times but I always had problems with the boot. Clover always gives me an error on boot. I was only able to boot once using version 5131 but not with newer versions of Clover. I have read on other forums that newer versions of Clover have issues with legacy boot. That's why I switched to Opencore. But I believe the power is working very well because I can see the four frequencies of this cpu 798, 1.60, 2.53 and 2.66 GHz and also for the GPU.

 

About Wake, yes hibernation is disable. You can look the “other files” zip with alll logs and settings for this laptop.

 

About DSDT, I attached a txt file with all the dsdt patches I used

 

About graphics properties injected, thanks for showing me the error. I don't know how that "- 2" appeared, probably a typo that I accidentally made but it's already corrected.

DV7-1183cl - dsdt patches.txt.zip

Do you believe that using Clover the sleep will work? I can try if you can help with Clover settings

Link to comment
Share on other sites

  • Administrators

You should delete the sleepimage file in /var/vm -it often leads to trouble at wake- and ensure Power Management settings point to null device for the hibernate file. Basically, I suggest you follow the recommendations posted in our FAQ topic.

 

MBP7,1 should be the ideal target SMBIOS site you have a Penny C2D platform but if you feel your laptop works better with a different one, then use whatever suits you.

 

Re: USB ports, sounds like you need to do or redo the mappings when you switch SMBIOS. Also remember that:

  • OHCI = USB1.x
  • UHCI = USB1.x
  • EHCI = USB2.0
  • XHCI = USB3.x

With Big Sur, Apple started to drop some older USB technologies so Big Sur and later versions require what is called the USB HID fix to circumvent the USB-related issue. This is mostly applicable to older systems like C2D/C2Q platforms but I found it also applicable to more recent platforms like, say, Skylake when fitted with hardware accessories based on  older USB technology (eg: touchscreens).

 

You've made no mention of it but I can only assume you use the OCLP app to patch your unsupported platform; latest versions are supposed to somehow address the USB1.1 issues but I've not read about it yet so I don't know how applicable this may be for your old laptop.

Link to comment
Share on other sites

I applied these commands and restarted:

 

sudo pmset -a hibernatemode 0

sudo rm -f /var/vm/sleepimage

sudo pmset -a hibernatefile /dev/null

sudo pmset -a standby 0

sudo pmset -a powernap 0

sudo pmset -a autopoweroff 0

 

Unfortunately it remains the same. Laptop goes to sleep but when wake up it restart. It's really frustrating to get so close to having the laptop fully working and not being able to solve this wake from sleep problem.

I'm sending the pmset assertions log after going to sleep, could you check plese?

assertions_log.zip

Link to comment
Share on other sites

  • Administrators

I'd advise to set hibernatefile before you remove the sleep image file; to ensure it stays gone if nothing else.

 

You probably ought to revisit your DSDT patches. You've injected quite a lot of patches for USB but did you try things out without any of those?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...