Jump to content

Latitude 7400: Troubleshooting Thunderbolt3


Recommended Posts

On 2/27/2023 at 2:39 AM, Jazzoo said:

Here's the OpenCore EFI for my Dell Latitude 7400. Everything works great. macOS Monterey 12.6.3 configured for Intel WiFi/BT:

Dell 7400 OC 0.8.9 Monterey IntelWiFi


If you have BCM card remove the kexts Airportitlwm, IntelBluetoothFirmware and BlueToolFixup. Ventura tested and not working well with Intel 9560NGW, if you have Intel 8260/8265 it will work flawlessly. Enjoy!


My specs are:

  • Whiskey Lake i7-8665U CPU
  • Intel UHD 620 graphics
  • 14" FHD IPS touchscreen
  • 16GB DDR4
  • Realtek ALC295 Audio
  • Intel 9560NGW wireless

If you want to try this EFI I fixed some things, from ioreg I see there is to fix the TB3 if this EFI starts ioreg and then I fix the TB3.


EFI OS ventura



Here in this repository is the example for patch TB3 , it works hotplug and sleep\wake. Obviously SSDT-TB3 must be adapted to the TB3 in use.



  • Like 1
Link to comment
Share on other sites

@Baio77 Tried your TB3 EFI above with Monterey 12.6 (used Monterey version of AirportItlwm.kext). TB/USB-C port only works if connected during boot. Sleep/Wake appeared working, but I only tested with USB3 stick + USB-C adapter. I've attached my IOReg report, if it helps for you to come up with a patch.


Also, the USBPorts.kext is missing a few ports (easy to fix):

1. HS03 (port: 0300000)  - This is USB-2 personality on the left USB3 connector.

2. HS06 (Port: 0600000) - This is the internal USB for WEB Cam
3. HS08 (Port: 0800000) - This is for internal USB devices (smartCard reader, etc) via an internal hub


Thank you!



  • Like 1
Link to comment
Share on other sites

"Thunderbolt Boot Support" Disable.


Open ioreg search for RP05 (here you find your TB3) See that in these 2 Ioregs you have the patch active. So SSDT-TB3 works, I just need to modify it. I leave the modified EFI to test.




EFI for Monterey.


Try this, ioreg if start, you need to save ioreg after connect type-c hub and TB3 dock. Thank you.

  • Like 1
Link to comment
Share on other sites

I tested the following configurations, none of them see USB3 device in TB/USB-C port. 


With "Thunderbolt Boot Support" disabled in BIOS:


TEST 3:  No device connected USB-C on boot.

TEST 4: USB3 stick connected on boot.


With "Thunderbolt Boot Support" enabled  in BIOS:


TEST 5:  No device connected USB-C on boot.

TEST 6: USB3 stick connected on boot.


RP05 showed the device, but failed to detect anything connected to it, either on boot, or hot plug in.


BTW, with your earlier EFI (Jan 30 post), with "TB Boot Support" enabled, it hot-plug detects USB3 fine (Haven't tried TB device yet). UPDATE: It actually only worked intermitted.


Again, really appreciates your help here!

IOReg-TEST3-TBBootDisabled-NotCOnnectedOnBoot.zip IOReg-TEST4-TBBootDisabled-ConnectedOnBoot.zip IOReg-TEST5-TBBootEnabled-NotConnectedOnBoot.zip IOReg-TEST6-TBBootEnabled-ConnectedOnBoot.zip

  • Like 1
Link to comment
Share on other sites

@Baio77  I re-did the test and it WORKED this time!  Both the USB-C and the TB functions worked (TB tested with a DELL TB16 docker), with "TB Boot Support" disabled in BIOS.


This time, I placed the EFI folder to the NVME boot drive, instead of booting from an USB stick. Not sure if this was the reason it failed previously.


There is still a reliability issue to the TB/USB-C port activation. Sometime, I had to leave a USB3 stick in when booting, or the port does not come on alive (RP05 device is empty). Sometimes, I have reboot a couple of times.


Thank you again for your work!



  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...