Jump to content

Mountain Lion on D630


sept771
 Share

Recommended Posts

I successfully installed Mountain Lion on my D630 and operational. The only issue I have was touchpad and video not working correctly. So, I applied EDP as instruction for Intel (1280x800). After EDP applied and system reboot with the following error.

 

"Can't Find"

"Press a key to continue"

 

I can't get pass this error. The only way I can get it to boot into ML is using the Extra before the EDP. Any ideas anyone?

 

John

Link to comment
Share on other sites

  • Administrators

D630 Intel LoRes = Crestline X3100 with 1280x800 LCD (WXGA)

D630 Intel HiRes = Crestline X3100 with 1440x900 LCD (WXGA+)

 

Unfortunately, those models cannot really run Mountain Lion because, from that OS X version, Apple dropped support for older Intel graphics chipsets such as GMA950 and X3100. ML will install, sure, but without graphics acceleration and that will render system performance pretty poor.

 

EDP does not incorporate support for the D630 X3100 under ML, so you're bound to meet trouble after applying EDP on that model after ML installation.

 

One other thing: the DSDT table for laptop with Intel Graphics chipset differs between the 2 LCD resolutions, so you can't really use one instead of the other. I know from experience that you cannot use the LoRes DSDT table on a HiRes D630 and I'd expect the same for the reverse although I've never tried this (I could test this of course, but that never occured to me). As such, I would not recommend using the HiRes bootpack on a LoRes laptop or install kexts for the HiRes on a LoRes laptop as that includes copying/overwriting the DSDT table in the /Extra folder.

 

It's probably not what you wanted to hear but forget ML and stick to Lion at best. There's hardly any difference for the average/regular user.

Link to comment
Share on other sites

I actually installed ML to my D630 with the Lo-Res Intel Graphics and I used the 10.7 Kext for it. Works pretty good considering. It does have some Video Acceleration, I just need to figure out the sound issue. Have not updated to 10.8.2 yet cause I wanna make sure it's a safe upgrade. Let me find the link I had to a posting here that helped me get it installed.

 

https://osxlatitude.com/index.php?/topic/1643-dell-d630-mountain-lion-install-guide-new/

 

There you go. Follow that guide and add in the kext from the 10.7 Intel pack. That worked for me at least. Now, to fix the sound issue...

Link to comment
Share on other sites

 Share

×
×
  • Create New...