Jump to content
EMlyDinEsH

ELAN, FocalTech and Synaptics (Smart Touchpad) Driver (Mac OS X)

Recommended Posts

i finished install mojave all things work ,but when move pointer by tarkpad or mouse
i see not sensitivity and inexactness and Deviation in motion

 

i am used app cursersence for make mouse and tarckpad better 
my mose is better now 
but i cant found tarckpad in list devices in app to change setting for it 
plz help me

1.png

Screen Shot 2019-02-01 at 9.36.02 AM.png

Screen Shot 2019-01-29 at 7.51.54 PM.png

Screen Shot 2019-01-26 at 8.50.14 PM.png

Share this post


Link to post
Share on other sites

Im a find a way to fix two_fingers scrolling trackpad was very slow, and now is super fast....

Im change info.plist from VoodooPS2Trackpad.kext

 

 

Im modified VoodooPS2Controller.kext

Im remove this ApplePS2Smartouchpad.kext that cause conflict with Voodoo...

Who knows about the future will get in better...

Im get 3 buttons on trackpad and everything is fine now!!!

 

VoodooPS2Controller.kext MOD MAX WORKS SROLL.zip

Share this post


Link to post
Share on other sites

Not works for me, im lost buttons and trackpoint and scrolling still slow...my Voodoo is better choice...thanks for your Job rakhadiputra!! 

Share this post


Link to post
Share on other sites

I'm sorry for that, my settings don't work on your machine, or you can try edit 2FScrollAccelMode and ScrollSmoothSamples values yourself

located at IOKitPersonalities-> Smart-Pad-> Preferences-> Scrolling on the info.plist.

  • Like 1

Share this post


Link to post
Share on other sites

I use this kext for HP EliteBook 850 G5 because my Synaptics touchpad don’t work with Voodoo kext. Touchpad works almost great expect two finger scrolling or other gestures.

I have problem with keyboard. I’m used to have Czech ISO layout with \| key next to left shift, but with this kext I have here <> key. I tried to set ISO layout in Info.plist, but key has still same behaviour.

It’s possible to set czech ISO layout and also get to work two finger scrolling?

Share this post


Link to post
Share on other sites

Hi! I'm having some trouble getting the three physical buttons above my touchpad to work.

I tried using ioio to find out what's happening while pressing the buttons.

Console.log only writes out "Ignored ext buttons".

 

Is there some way to enable them?

Can provide more information/logs, if needed.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...