Jump to content
EMlyDinEsH

Fix for no Audio issue after Sleep in Realtek codecs

Recommended Posts

thanks 

this my applehda.kext

 

Hey,

 

  Sorry I was away for two weeks becoz of some personal work so I couldn't reply you back. I will look into your file and see if I can do anything then let you know.

  • Like 1

Share this post


Link to post
Share on other sites
Hey,

 

  Sorry I was away for two weeks becoz of some personal work so I couldn't reply you back. I will look into your file and see if I can do anything then let you know.

 

In two days I let you know, I promise and sorry for the delay but I can't sure for a working solution becoz I have already looked once but it seems to need some experiments to understand it.

Share this post


Link to post
Share on other sites
thanks for your replay

this is dump from linux 

 

 

thanks 

this my applehda.kext

 

Hello,

 I've looked into your files and seems strange that your codec dump and AppleHDA codec verbs are different. So, I need to talk about this. Let me know in PM as quickly as possible and Sorry for the delay to respond.

Share this post


Link to post
Share on other sites

Hi EMlyDinEsH, I have been looking to fix this issue again for my G74SX (I had already patched in Lion). I patch my AppleHDA for have all working but after sleep I lose my Speakers.

 

Can you Help me? my G74SX have Speaker at node 1B, so I tried your ioaudiofamily kext for this node but after sleep I still lose Speakers. Can you please check it??

 

I leave my codec dump. Do you need something else??

 

P.D. 

 

Since you are an ASUS Hero, I´m trying your Asus FN keys to enable my keyboard back light, but I will post in that thread. Thank YOU!!!!!

 

 

alc269G74SX.txt

Share this post


Link to post
Share on other sites

Hi EMlyDinEsH, I have been looking to fix this issue again for my G74SX (I had already patched in Lion). I patch my AppleHDA for have all working but after sleep I lose my Speakers.

 

Can you Help me? my G74SX have Speaker at node 1B, so I tried your ioaudiofamily kext for this node but after sleep I still lose Speakers. Can you please check it??

 

I leave my codec dump. Do you need something else??

 

P.D. 

 

Since you are an ASUS Hero, I´m trying your Asus FN keys to enable my keyboard back light, but I will post in that thread. Thank YOU!!!!!

 

Will take a look, Send me your patched AppleHDA as well. And did you play any audio after sleep and see if you are getting any log in System log like "EAPD xxx"?

Share this post


Link to post
Share on other sites

Will take a look, Send me your patched AppleHDA as well. And did you play any audio after sleep and see if you are getting any log in System log like "EAPD xxx"?

Thank you, I attatch my AppleHDA I edited and have all working Speakers, Headphones, Internal and external Mic even HDMI.

 

After sleep Speakers are Muted, Headphones are working

 

After sleep in my log I see this

 

 

May 26 12:50:21 MacBook-Pro-de-Agustin-2 kernel[0]: EAPD: Sending Command
May 26 12:50:21 MacBook-Pro-de-Agustin-2 kernel[0]: EAPD: Command Sent Successfully
May 28 11:10:50 MacBook-Pro-de-Agustin-2 kernel[0]: EAPD: Sending Command
May 28 11:10:50 MacBook-Pro-de-Agustin-2 kernel[0]: EAPD: Command Sent Successfully
 
Thanks for all your hard work
 
P.D.
 
I already make a Donation, I post it here because you can´t receive more new messages.
 
Donation Confirmation number: 1FD454861F653113N
 
Good Luck

 

AppleHDA.kext.zip

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...