Jump to content

No disk found Optiplex 745


censor
 Share

Recommended Posts

  • Replies 20
  • Created
  • Last Reply

Top Posters In This Topic

Make sure your hard drives are in AHCI mode in BIOS. Not doing this is a guaranteed way to get this error.

 

If your BIOS doesn't support AHCI, you can find patched IOATAFamily kexts that enable standard IDE disks to be seen in the OS X installer. Just place it in the myHack /Extra folder.

Link to comment
Share on other sites

I had to place the SATA support to legacy in the bios to get it working (with IOATAFamily kext).

Other difference is that I installed 10.7.

which form factor do you have ?

Hi, I just solved this problem with the help of Herve the Administrator.  I have an Optiplex 745 wiht a SATA hard drive.  I used the EDP bootpack for the 745, plus MyHack, to build a USB install using 10.7.5 as the base.  It was not recognizing the hard drive when booting from the USB stick.  Herve suggested adding IOATAFamily.kext.  Just adding it to Extra/Extensions folder is not sufficient, you add it to the bootpack Extra folder (not on the USB stick, somewhere on your hard drive), then you have to run MyHack and run Install Extra, point to the Extra folder on your hard drive that has all the bootpack extensions PLUS the IOATAFamily.kext, then apply to the USB stick.  Just copying the kext into the Extensions folder on the USB stick is not enough, the installer needs to know about it and use it to repalce the Apple kext during install.  That's whay MyHack does when you run Install Extra

 

I got my copy of IOATAFamily.kext from the bootpack for the Latitude D630 (file name Dell_Latitude_D630-intel-lion.zip)

Link to comment
Share on other sites

I have the SFF Optiplex 745 and I can't get it to see the HDD to install, tied myhack Lion and Mavricks, in both cases no HDD visible to install.

 

I also added IOATAFamily.kext, and fixed perms, to E/E still no HDD on installer.

 

Am i missing something ?

Link to comment
Share on other sites

so this is what i'm doing.

 

using myHack to create an 10.7 installer to my USB

when complete i then add "Dell_Optiplex_745-lion" extra's via myHack

i then boot from the USB and i get stuck at the installer as it does not see my internal sata HDD.

if I drop IOATAFamily.kext to E/E the installer kernal panic's and does not startup. (how am i supposed to do this CORRECTLY?)

 

Am i doing something wrong ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...