Jump to content

D620 Lion cannot install chameleon


jadajada
 Share

Recommended Posts

I have successfully installed Lion (almost). But I can not get the bootlader to install. I get no error messages during install, but when I boot I get som gpt boot errors. If I insert my usb install drive, I can boot from it, select my internal drive and boot. 

 

I have tried to reinstall chameleon from MyHack, but I get an error:

 

ERROR: Could not find valid partition table on device /dev/disk0

Unable to flag active partition

 

I then restarted from my install drive and ran myhack from the utilities menu. Same result.

 

I have deleteted the partiton and created it again, both as guid and mbr. Same result.

 

Is my drive broken? Is there some way I can get chameleon to install?

Link to comment
Share on other sites

I had the exact same problem as you did and it drove me crazy for a few days. I did manage to circumvent it by doing lots of extra work, and in the end I got 10.7.5 perfectly running on my D620 with Intel GMA (except for sleep, which I don't care about). Here's my whole story and ordeal and how I got it working in the end.

 

At first, I made the myHack USB boot drive + EDP boot pack for the D620 Intel GMA 1440x900. Booted fine, but during installation I could not get the keyboard and trackpad to work. I plugged in an external keyboard and mouse and that worked fine. Formatted the internal hard disk with GUID partition and installed 10.7 on the drive. The install seem to went fine and there were no hiccups; selected "Yes" to all the myHack prompts to remove incompatible kexts, and selected "Use My Own" for the Extras folder. Upon restarting however, I was greeted to the infamous boot0 error.

 

So I thought perhaps Chameleon didn't install correctly. Booted up with the myHack USB drive again, went to myHack under Utitlies and select to install Chameleon on the internal drive. It installed Chameleon, but I got a message saying:

 

ERROR: Could not find valid partition table on device /dev/disk0

Unable to flag active partition

 

I thought that was strange, so I went to manually flag the partition active within Terminal. Doing that failed, as Terminal kept outputting "cannot execute binary" whenever I used diskutil command.

 

I tried to narrow the problem down to the internal hard drive, but it wasn't the case. Tried installing Chameleon on another freshly formatted external USB hard drive within the myHack USB 10.7 installer and still received the "unable to flag active partition" error.

 

So now I thought the myHack USB 10.7 installer is corrupted somehow. I went and set up the myHack USB boot drive again, reinstalled 10.7 files on it using a different 10.7 install app, but no such luck. I think I went through three different 10.7 install apps and all had the same problem. I even used a different USB thumb drive with the same problem.

 

I tried the myHack USB 10.7 installer on a completely different computer as well (an HP DV2000 laptop) and myHack still couldn't flag the parition active and terminal still kept giving cannot execute binary errors.

 

After all this, I decided to use GParted to manually flag the partition active, as I couldn't do so in the myHack USB 10.7 installer. Even when flagged active, it still would give me boot0 error.

 

I was really out of options at this point and didn't know what else to do. Thinking of complete failure, I installed Snow Leopard back onto my internal hard drive using the old D620SLV1.iso boot CD. Everything went fine as it should and the 10.6 was fully bootable and working again.

 

What I did next did fix the problem fortunately. I booted myHack USB drive again and instead of installing 10.7 to the internal hard disk, I installed 10.7 on the external USB hard drive mentioned earlier. Of course, it would not boot from it and give me boot0 error. However, I booted back into Snow Leopard on my internal hard drive, and ran myHack from there. I then installed Chameleon on the external hard drive. This time, I did not get any errors at all. Restarted and tried to boot from the external hard drive with 10.7 installed, and it booted without the boot0 error!

 

With 10.7 running, I proceeded to install the latest EDP configured for the laptop. All was working pretty much perfect, but I wanted to get 10.7 working on my internal hard drive and not an external USB hard drive. So I decided to clone the external hard drive to the internal hard drive using SuperDuper. After it was done, I ran myHack from within 10.7 and installed Chameleon again to the internal hard drive to make sure everything was perfect.

 

Now 10.7 is running perfect on the internal hard drive, and I updated to the latest 10.7.5 without issues.

 

I just wished the entire installation process was easier and simpler as it had advertised. I'm not sure why I ran into these issues, but I'm sure I'm not the only one.

 

Hope that helped.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...