Jump to content

[GUIDE]: ASUS N55SL (no Wi-Fi with Centrino) - 10.8/10.9 DP


Recommended Posts

hello qwerty12, thank you for this great peace of work, I've successfully installed 10.8.4. I'm experiencing only the wifi centrino issue, but I already purchase a DW1702 on amazon.


I installed OS X on a MBR system with Windows 8 x64 on it, and i had problems to install chameleon on the OS X partition, I choose to create a new partition only for chameleon, and it works perfectly. I See you also have Windows 8 running, did you install only windows after?


I hope you continue a good work.

Link to comment
Share on other sites

Hello, cbmoon, and welcome!


I was already running Windows 8 before I installed OS X. I had no problems installing Chameleon to the OS X partition afterwards -- I just had to write the Chameleon partition bootsector to the HFS partition (the guide should say how to do this, just look for fdisk440).


EDIT: I'm not...

Link to comment
Share on other sites

Hi, i have a question regarding the HD3000 vga output.


I'm using 10.9 DP1 currently, and i did try patching it using the patch provided here but still not working. May i know if you have the patched snbgraphics.kext for me to try out ?


I'm wondering if the problem is because of the CPU I'm using is i5-2450m instead of i7-2670QM

Link to comment
Share on other sites



After plugging in the monitor, are you going to the Display Preferences, holding down the Windows key and hitting Detect Displays? It's been a long time since I've connected a monitor to my N55SL, personally; the last time I tried was in 10.8.4 and it did work for me there.


If you installed the rc.shutdown.local script, then the SNBGraphics kext should already be patched by now, but you can try patching it yourself or I can upload you mine from my 10.9 DP5 install which may or may not work for VGA -- I haven't tested it

Link to comment
Share on other sites

I've attached it, but remember that it's from a later version of 10.9 and it may cause your install not to boot unless you restore the original (keep a backup!)


I recommend patching your current version, instead, by running the following in Terminal:

sudo touch /System/Library/Extensions
sudo kextcache -update-volume /
and then reboot


Link to comment
Share on other sites

I don't know, then. I don't have any monitors anymore that I can test with.


1. No. The only time I saw it when I used to boot without DualLink injected, which I need because my native resolution is 1600x900


2. I doubt it


EDIT: I'd recommend patching your kext yourself following EmlyDinesh's guide. Your VGA port may be connected differently to mine

Link to comment
Share on other sites

Just uploaded a little script to run FaceTime and CameraControl automatically.


Not a big improvement, but it works fine for me.

Thanks for this, much appreciated.


BTW: I can't find a way to use HDMI so far, it's there anyone using it sucessfully?

It might not be working because I suspect it's wired up to the NVIDIA card on this laptop or if that turns out not to matter, it's because I chose the wrong HDMI-out port number (I guessed since I don't have any HDMI cables) when changing the table in the SNB FB kext. You could restore the original table by running the commands I already posted but swapping $OLD_TABLE & $NEW_TABLE and try the next HDMI port designation (I think I chose 203 [smth. like that] the first time but it may be 503 that's needed)
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...