Jump to content
Leon

Install OSX on Lenovo Thinkpad X201s (and maybe x201)

Recommended Posts

Been trying to get OS X going on, at first I tried Mavericks, making a USB with

sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --applicationpath /Applications/Install\ OS\ X\ Mavericks.app

And doing this with Clover:

  • Clover EFI: Clover EFI 64-bits SATA
  • Drivers64UEFI: DataHubDxe-64, EmuVariableUEFI-64, OsxAptioFixDrv-64, PartitionDxe-64
  • Install RC scripts on target volume
  • Optional RC scripts

It booted with quite garbled graphics, but enough for me to get through a couple of steps in the installer. For some reason, in the Time Machine-Install OS X-Get Online Support part, it wouldn't do anything when I pressed Continue.

 

After that, I tried the same with El Capitan, and it actually did install! However, after the first boot when I deleted AppleIntelHD* from S/L/E, where it worked well, I couldn't get it to run again - the screen freezes. I assume the system still boots, but I can't really do much when I can't see a thing.

 

I got some 10.11 kexts from http://www.insanelymac.com/forum/files/download/208-1st-gen-intel-hd-graphics-kexts/- but so far I've been only able to produce two different kinds of glitched screens, depending on which AppleIntelHDGraphicsFB.kext I use, and this slightly amusing effect:

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...