Jump to content

D830-intel needs a doctors appointment... plz help


lcars
 Share

Recommended Posts

Hi,

 

First my background:

I am a System Engineer and work with PC Servers etc. for more then 20 years. Main OS atm is LInux.

As for OSX: I installed Leopard using the Kalyway (spelling?) method about 2 years back. Got it to run but not all devices supported. Only used it shortly then. -> Not much experiance with OSX

 

Second HW/Installation Procedure:

HW: D830 Intel (A14 Bios)

 

Install:

I Installed using the nawcom cd (thanks for that) + a Retail OSX 10.6.3. The nawcom cd has a modified installer so it installed some stuff in addition to Retail OSX (sadly i did not take notes what additional components were installed) My Selection @ OSX install was Standard minus Printer support and most of the additional languages.

 

The Install itself was very slow but worked.

 

After install (in OSX 10.6.3) I installed the EDP 1.8.

Then I read that EDP 1.8 was designed for 10.6.7, so i thought the problems described further down might be caused because of a Version missmatch.

=> Installed Combined Update to 10.6.7 and reinstalled EDP 1.8 (to be on the save site).

- After reboot i did a diskutil repairpermissions ....

 

 

The Problem(s):

 

1. (MOST ANNOYING) The System is EXXXXXXXXXTREM slow. And by slow i mean for example: Opening a Terminal Window and typing "sudo dmesg > dmesg" took almost 10 min. When you type a letter it takes on avarage 10-30s for a latter to appear... if you type to fast it sometimes doest work at all.

(Have not installed AnVAl yet... could not identify the "boot-file". But doubt it makes that much a diffrence)

 

2. Mouse is erratic meaning if you move the mouse in a normal fashion it jumps all over the display. When you move it extra extra slow it works though.

--> First (under 10.6.3) i used the VoodooPS2 from the EDP.

--> When i reinstalled EDP in 10.6.7 i used Appel Standard.

The trackpad works for a short time after reboot but then dont.

==> Wired log messages in system/kernal log.

(Maybe 1 and 2 are even related?)

 

3.) No Network. Though i did not investigate that much, yet. Just under Prefs-> Network I do have an Ethernet Adapter. But (even with cable pluged in) it says cable not pluged in. No Wireless interface at all.

 

4.) Not sure but i seem to remember that the Laptop got a Display resolution of 1400x800... OSX is only allowing me to set 1280x1024

 

 

Attached my Extra'S Folder + all Logfiles i thought might be helpfull

 

PLZ Help!

 

 

P.S.:

 

Additional questions:

1.) If i reinstall EDP (start the pkg again), because i want to try e.g. another PS2 kext... do i first have to delete the old once?? If so where and witch files?? Only Extra folder or does something get installed in SLE?

 

2.) Can BIOS Version A14 be a Problem?? See ppl talking about A15

Extra.zip

logfiles.zip

Link to comment
Share on other sites

  • Administrators

edp will remove old extra folder and generate a new one. on a build. so you can try other options like power pack or no powerpack, trackpad kext's etc... etc.. it seems we are having a little difficulties with some DX30 machines if building does not work with d830 intel then try d630 intel as the build machine and let me know if it makes a difference but leave that as a last resort... they are verry simmilar in terms of hardware. i do not have a d830 on hand to work with.

Link to comment
Share on other sites

Hmm,

 

tryed diffrent combination with EDP 1.8:

1.) D830-intel: slice-ps2 - powerpack - appelbattery -no pcmcia

--> no big improvment... maybe extrem minor speed improvment.

 

2.) D630-intel: Slice-ps2 - no powerpack - appelbattery -no pcmcia

--> Kernel Panic: First i think i saw something about AppelPowermanagment; Second the Broadcom wirelss was somewhat in the kernal dump... then i tried bootoption "CPUS=1 -x" -> You need to reboot Hold down power button; then i tried with "pciroot=1 -v" -> Kernelpanic com.apple.driver.BRCM43224....

 

Ok.. so i booted in SingelUser... but could only find Apple BCM5751Ethernet ?? hmm anyway -> Disable. -> Restart "-f -v"

=> No Kernel panic... but it just got stuck on boot up... last two lines AICPowermanagementClient:ready

Got boot device = IOService:/AppleACPIPlattformExpert/[email protected]/AppleACP

 

then it just sat their...

 

Any suggestions??

Link to comment
Share on other sites

  • Administrators

cpus=1 is for tscsync issues we use a kext for that... -v is for verbose output (black screen that shows booting sequence), -f bypasses catches and loads all kexts, -x is equivelent to "safe mode" also bypasses/ rebuilds mkext and performs a disk/permissions check... loads minimal drivers, -s is single user mode. so -v -x is a good place to start. like example: -v -x PciRoot=1 GeneratePStates=Yes GenerateCStates=Yes all in one line at chameleon prompt

Link to comment
Share on other sites

Well,

 

First:

I was to hasty with assuming that the kernelpanic is gone when i disabled the Apple BCM5751Ethernet in single user mode.

 

Subsequent boots have shown that it still always ends in a Kernelpanic caused by the wireless BRCM43224.

(included a "screenshot" of the kernel panic)

 

But i found that Disableing Wireless Bluetuth etc. in BIOS lets me boot up the system!

 

And it is actually faster. As fast as can be expected on the Laptop i think. So the EXTREM SLOW behavior i had when i used the EDP Dell 830-intel option is gone. Also an external USB Mouse works like it is supposed to (not like before). But no Trackpad (but i consider that a low priority).

 

Still no network (Ethernet) though. Says cable is unplugged when infact it isnt. SystemProfiler says "This computer does not appear to have any PCI Ethernet cards installed"

Display Resolution still 1280x1024.

 

 

So using the Dell 630-intel option will result in a way better system performance and better usb-mouse funtion. Theirfor i have to disable the Wireless and Bluetooth stuff in the BIOS or i will get a KernalPanic.

 

 

I can ofcorse try another rebuild of EDP... but from my "limited" Point of few: The best i can hope for is get the trackpad working... right???

And my biggest Priority at this point would be rather to get a network connectivity. At least with LAN hopefully with wlan.

 

So should i go back to the 830 EDP Pack and search the web for a DSDT file that might work (no clue about write/generateing DSDT myself...).

 

Or what are my options to get at least LAN and WLAN working in adition??

 

Thank you!!!!!!!!

 

 

P.S.: Sorry if this might seem like a dumm newbie question, dont know much about DSDT's but: Might one of the DSDT's you included in the EDP (eigther the 630 or 830) work better with a diffrent BIOS Version??

post-1032-026529200 1303939620_thumb.jpg

Link to comment
Share on other sites

  • Administrators

Hi,

 

I'm heading of to bed now - but i will get back to you in about 10 hours and then we will work this out.. can you please contact me on skype chat or msn ?

Link to comment
Share on other sites

Hi,

 

I'm heading of to bed now - but i will get back to you in about 10 hours and then we will work this out.. can you please contact me on skype chat or msn ?

 

Sure thing.. though it will have to wait until i get of work tomorrow... which will be between 1800 and 1900 gmt+1...

But if the offer still stands... i be happy to contact you... even extra thankfull that you take the time.

Link to comment
Share on other sites

Did you two (2) ever resolve this. I have just ordered a couple of D830s with 2.2Ghz CPU, nVidia GPU and 4 Gb RAM. Would appreciate your input as to how (if you did) you worked through this to have a working OSX86 D830 with everything working.

 

Accordingly, I have the following questions:

 

1. Was a BIOS mod required? If so, is there any information available on it, and where can it be found.

 

2. Is the system running on an x86 or x86_64 kernel?

 

3. What kexts were inserted into /Extra/Extensions?

 

4. What third party apps were necessary, if any?

 

5. Does this require any chameleon boot flags to work?

 

Thanks in advance,

 

nesnfsn in Sunny South Florida

Link to comment
Share on other sites

 Share

×
×
  • Create New...