Jump to content

D430 / 10.6.6 - boots only from USB, not HDD


moonman
 Share

Recommended Posts

I can boot from the USB pen and select the HDD in the Chameleon screen, and it boots okay and everything runs fine in 10.6.6: Airport, Bluetooth, sound, trackpad, etc.

 

But if I try to boot from the HDD, I get this error screen:

 

boot0: GPT

boot0: test

boot0: test

boot0: error_ (flashing cursor).

 

Only option is a forced shutdown.

 

I have installed Snow Leopard on 2 other D430's, no problems.

 

As usual, this time I installed 10.6.0, then on reboot Chameleon r665, EDP 1.8 and selected the Slice trackpad driver, powerpack, Apple battery manager and No pcmcia, as I usually do.

I didn't reboot. I ejected the USB pen, and ran the 10.6.6 combo update from the HDD.

Then restarted. And I always get the above errors.

 

Any help greatly appreciated.

 

P.S. I have a new 120GB in the D430, Samsung model HS12YHA/A which seems to be okay. I have also updated the Bios to A09.

Link to comment
Share on other sites

  • Replies 22
  • Created
  • Last Reply

Top Posters In This Topic

make sure your installing chameleon to the harddrive if not try a newer version. you might be missing the hidden file "boot" from the root of your volume

 

I tried the newer one in the EDP 1.8 package, but no change.

 

The boot file is on the root of the main volume.

 

It's weird, because when I boot from USB and select the HD on the Chameleon startup page, it seems to be a perfect install. No problems with Airport or the trackpad or anything. Everything just works right out of the box. I've never had this problem with any of the other D430s.

 

Should I run the edptool? Or maybe try the more recent EDP 1.9?

Link to comment
Share on other sites

did you ever use some sort of efi bootloader or installer on that drive? there might be a corrupted efi bootloader install in the hidden efi partition. also is it an mbr install or gpt?

 

I did the usual install routine, using my USB pen that I have used for other D430 installs so it should still be good.

Booted from the USB pen, formatted the HDD in GUID (journaled, not case sensitive), installed 10.6.

The rebooted and installed Chameleon and EDP 1.8. And I updated to 10.6.6 using the Combo updater that I copied to the HDD.

I ejected the USB pen, then rebooted.

But I got the errors listed above, so I did a hard shutdown, inserted the USB pen, from F12 I booted from the USB pen, and in the Chameleon screen I selected my HDD and booted from it.

Once booted, the D430 runs great. Everything recognized out of the box, incl. Airport, trackpad, sound is perfect, Bluetooth, etc.

 

The only thing is I can't boot from the HDD itself.

 

Short of doing a new install, what's the best way to proceed? Replace the "boot" file with a new one? Try a different Chameleon bootloader?

Link to comment
Share on other sites

yeah i would start with that or use a chameleon that has an installer and do a repair of the drive with diskutility

 

Thanks. I noticed in your sig that you have Chameleon 2 RC5 r1002, whereas I believe mine is 2 RC5 r665.

So I guess yours is more recent. Should I give it a try? If so, where can I download it?

 

And what about copying the "boot" file from my other D430 which is working perfectly? Could I just copy it to a USB pen and then drag it to this other D430, to replace the current boot file?

Link to comment
Share on other sites

i download it from chameleon source and compile with xcode i think it was up to 1003 as of last night. but i have seen compiled versions in kexts.com if your a member... im not.

 

Reformatted the HDD and reinstalled 10.6, but still getting the same errors when trying to boot from HDD.

Again, booting from USB pen, then selecting HDD in Chameleon screen, works fine.

 

I installed Chameleon v.2.0 RC5 r665 and EDP 1.8, then the 10.6.6 update, but no go.

 

I also installed the Chameleon bootloader that's in EDP 1.8, I believe it's r747, but that didn't help either.

 

Any help much appreciated.

Link to comment
Share on other sites

 Share


×
×
  • Create New...