Jump to content

Samsung NP900X4D... a nightmare to enable QE/CI. Expert help needed.


Recommended Posts

Dear all experts,

For several weeks now I’ve been trying to setup a Samsung NP900X4D-A01ES with dual boot Win7 and ML 10.8.5.

I started as a total newbie, with no previous programming backgroung, and I have learnt a lot through the many posts I have read. Finally I managed to install and run ML 10.8.5 with reasonable success. I got wifi working (I bought an USB realtek wifi dongle) BUT no QE/CI support for the HD4000, no power management, no processor optimization, no Fn keys, no sleep/hibernate, no battery indicator, etc…..


I soon realized the importance of optimising my system and began to investigate on solving the graphics acceleration issue. Being a noob, you can’t imagine the amount of hours I have spent in this process with no success (except for what I have learnt). It has become an obsession to finally conclude that my lack of in depth knowledge is blocking me to make any step forward.


So… I am forced to request the help of the experts here, to whom I am already very grateful for what I have learnt from you.

This is what I have worked up to now. As you know the bios of the NP900 series does not allow to set the graphics memory size so I tested every way and every configuration as shown below.


1- I have tried using the key HD4000PlatformId=[0 to 11] with no luck.


2- Then I tried with injecting the bootloader using the key “device-properties†in org.chameleon.Boot.plist with the EFI string I extracted with the help of gfxutil. No luck.


3- Then I though that the only solution was to patch the dsdt.aml directly. So I extracted my dsdt and ssdt files and used DSDT Editor to add the _DSM method under IGPU device. I have tested “AAPL,ig-platform-id†with every combination from 01660000 to 0166000B (except for those with 0162000y and y=5,6,7). No luck either. (by the way, I replaced GFX0 with IGPU and also added the DTGP method at the beginning of the dsdt file. There seems to be no difference in using GFX0 or IGPU).


4- Then checked the dsdt.aml file include in the EDP bootpack for NP900X4C and I realized that the line “AAPL00,DualLink†was not included in my dsdt. I copied it and retried again testing with different values for “AAPL,ig-platform-idâ€. No luck at all; always black screen except for values ending 0A and 0B (screen with clock stopped). However this time I used screen sharing and I could see that ALWAYS, no matter the value of “AAPL,ig-platform-idâ€:


a) the OS boots perfectly, no matter what you see in the local screen.


B) AppleIntelHD4000Graphics.kext and AppleIntelFramebufferCapri.kext are loaded,


c) System info reports an HD4000; sometimes with a total VRAM=384 Mb, others with VRAM=512 Mb. It depends on the value “AAPL,ig-platform-idâ€.


d) System info reports no display attached


So… what else can I do?

I have read that “in the case of people getting no internal display on some id and ONLY internal display on others, they need to hack an id connector table that contains both the ones displays get detected on.â€


Well… I’ve been digging in the web but I still don’t know how to do this. Will you pls help?


I am attaching my system config files just in case you may need to have a look at them. Any idea that can help me on how to proceed will be very very much appreciated.

Thank’s in advance, Matt.



IORegistry files (from IORegistry Explorer).zip

DSDT - SSDT ACPI (from AIDA64).rar

EDIDViewer Output.rar

Link to comment
Share on other sites

Hi Bronxteck,

Thank's for your answer and for the guide.


Yes, updating the bios was the first thing I did before removing win8.


I had seen that guide some days ago but it was so cryptic to me that I though it was not applicable to solve my problem. I have gone through it again and have read some other posts and...yes, you're right, it may be the only solution. Honestly it was not my preferred one because...

1) my understanding is that the Samsung NP900X4D is quite similar to the NP900X3C and NP900X4C, for which there are bootpacks here. So, if some experts managed to patch the DSDT to make the X3C/X4C run perfectly without modifying AppleIntelFramebufferCapri.kext, I though I could achieve the same result (but in many more hours... :))

2) patching a kext will not allow me to migrate to Maverics as easily as if the solution is implemented via patching the DSDT.


Anyway I will work with AppleIntelFramebufferCapri.kext in the coming days and I will post the results. Hopefully it will also help other guys with a similar system/problem.



Link to comment
Share on other sites

  • Create New...