Jump to content
pokenguyen

[Guide] E7440 with Clover

Recommended Posts

Dell Latitude E7x40 Mavericks/Yosemite Clover UEFI

 
Here is guide for Clover install on E7440 I assumed based on my experience, note that dsdt patch is based on HD4400 only model. If you have nvidia, zip the origin after pressing F4, post it here I will write a patch for them:

1. Prepare a USB with 8GB or more, format by Disk Utility:

- Partition Layout: 2 Partitions
- 1st Partition: Name CLOVER, Format: MS-DOS (FAT), Size: >300MB
- 2nd Partition: Name Untitled, Format: Mac OS Extended (Journaled), Size: >7GB
- Options: Master Boot Record

diskUtil.jpg

 

2. Download Clover.zip, extract then copy EFI folder to CLOVER partition.





- Download Config.zip, extract then select right config.plist and copy to /EFI/Clover/:


3a. For OS X Mavericks

- Download Mavericks Install app from AppStore.
- Launch terminal and run the following script:

sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --nointeraction

- Your Mavericks Installer partition will be renamed "Install OS X Mavericks"


3b. For OS X Yosemite
- Download Yosemite Install app
- Right click to Yosemite Install app > Show Package Contents > Contents > Shared Support, open InstallESD.dmg.
- Open OS X Install ESD partition, open BaseSystem.dmg (hidden file)
- Use Disk Utility to clone OS X Base System to MacUSB partition.
Ub9sEsy.png
- Go to System/Installation of USB and delete the alias “Packages”, then go to “OS X Install ESD” partition, copy the “Packages” to the folder System/Installation of your USB
- Copy BaseSystem.dmg and BaseSystem.chunklist (hidden files) from OS X Install ESD to OS X Base System (on your USB)

4. Restart with USB plugged in, select these options in BIOS:

- Function keyboard: Function mode
- Disk: AHCI
- UEFI Boot: Enabled
- Secure Boot: Disabled
- Legacy Rom: Disabled
- Add boot option: Add EFI\Boot\Bootx64.efi in USB, then move the boot entry to top.

Save settings and restart.
 
5. Clover bootloader screen shows up, press F4 (this will dump your dsdt, ssdt), and shutdown.
 
6. Use another Mac, download HVT here, run the tool and install Tools > MacIASL, run MacIASL, go to Preferences and set to ACPI 5.0, then open /EFI/Clover/ACPI/origin/dsdt.aml in CLOVER USB drive. Click Compile, you will see 2 errors. Select the first error, you will see lots of Zero, delete them all. Click compile, you will see 1 error left.
Click Patch button, download the patch here and apply:
https://www.dropbox.com/s/du6ee0eislnzan2/Dell%20E7x40%20patches.txt
 
Click Compile to check for errors, if no error (ignore warnings), you can save the file with File Format: ACPI Machine Language Library, name DSDT.aml to /EFI/Clover/ACPI/patched/ (of CLOVER USB).

7. Boot to USB, Clover bootloader screen will show up (if not, add Clover in USB in BIOS again), select "Boot OS X Install from xxxxxxxxx" (your OS X Installer partition).

8. Press spacebar if a nagging screen about Mouse/keyboard appears. Install screen will appear, use Disk Utility to format your drive as GPT, create a Mac OS X Extended (Journaled) partition and install Mavericks to your formatted partition. The installer will extract necessary files to "Install OS X Mavericks" (not your target partition). This takes a lot of time at the end, though you only see "a minute remaining". This will end PHASE 1. If you are installing Yosemite, jump to step 11

9. Restart and Clover bootloader screen (from USB) shows up, select "Boot OS X Install from Install OS X Mavericks" (your Mavericks Installer partition, not your install target partition).

10. Install screen will appear and continue installation. This time, installer will install files to your target partition and create Recovery HD partition. This will end PHASE 2.

11. Restart, Clover bootloader screen shows up, then select "Boot OS X from YourPartition".

12. If everything goes well, you can boot straight to OS X desktop.
 
13. Copy config.plist from USB to /EFI/Clover/ of EFI partition, then use Clover Configurator to IMPORT config.plist (in EFI partition) and edit those values:

- ACPI > GeneratePStates/CStates: uncheck
- SMBIOS: create your new SMBIOS (Macbook Air 6,2) with random Serial Number

 

Then EXPORT config.plist to /EFI/Clover/ of EFI partition

14. Download HVT here, run the tool and select those:
 

- CloverUEFI

- Kexts > Intel Ethernet or Broadcom Ethernet.

- Kexts > Graphics > HD4400/4600 DP/HDMI Freeze (Only on Mavericks 10.9.1 -> 10.9.3)

- Tools > Kext Wizard.

- Tools > SSDTGenerator.

- Tools > MacIASL.

- Tools > Clover Configurator.

- Fixes > Hibernate Mode > Disable Hibernate

 

Use kext wizard to install this https://www.dropbox.com/s/reah7jmuyh1jlpu/AppleHDAALC%20ALC%20292.zip

 

15. Download https://www.dropbox.com/s/mut20ige5ylgj6o/Kexts%20Dell%20E5x30.zip, unzip and copy .kext files to /EFI/Clover/kexts/10.9 and 10.10 of EFI partition

16. Copy /EFI/Clover/ACPI/patched/dsdt.aml from USB to HDD EFI partition.

17. Copy /Extra/SSDT.aml in your Mac partition to /EFI/Clover/ACPI/patched/ (of HDD EFI partition)

18. Recheck if config.plist, dsdt.aml, ssdt.aml are placed correctly in EFI partition of internal drive.

19. Restart, go to BIOS, add Boot entry of /EFI/Clover/Cloverx64.efi in your EFI partition, move it to the top, save and restart, you should see Clover screen and option to boot to OS X. Enjoy!
 

Clear Network Settings

 
If you use any USB Wifi device, or use Mobile Phones to connect to Internet before completing the guide, you won't be able to access to AppStore or iCloud. You must reset your network settings:
 
- Go to /Library/Preferences/SystemConfiguration/ and delete these files:

  • CaptiveNetworkSupport
  • com.apple.airport.preferences.plist
  • com.apple.network.eapolclient.configuration.plist
  • NetworkInterfaces.plist

- Go to System Preferences > Network, delete all connection. Then restart
- Go to System Preferences > Network, add your connection again.
 

Update from Mavericks to Yosemite

If you followed the old guide (without Yosemite mentioned), do extra steps:

- Download latest HVT, run and select Clover UEFI, Clover Configurator > finish.

- Go to /EFI/Clover/kexts/, create 10.10 folder and copy kexts here https://www.dropbox.com/s/mut20ige5ylgj6o/Kexts%20Dell%20E5x30.zip to 10.10 folder.

- Use Clover Configurator to IMPORT /EFI/Clover/config.plist, go to Boot section and select kext-dev-mode=1. Then EXPORT config.plist to /EFI/Clover/.

Run the OS X Yosemite installer and follow the guide.

Done!
 

Windows 8 UEFI Dual Boot

 
- Use Disk Utility to prepare a Mac OS X Extended partition (don’t ever use Fat32, Disk Utility will mess up your drive)
- Create a FAT32 usb drive, extract Windows 8 64-bit iso there
- Boot to usb drive, format the new partition to NTFS, install Windows there.
- Go to BIOS, move the Clover boot entry to top.
 
Done!

  • Like 4

Share this post


Link to post
Share on other sites

HI Pokenguyen,

   Thank you so much for the detailed update.     I went ahead and followed your steps and the Clover bootloader came up,

and showed me Newly made OS installer USB and the previous installed Mac OS partion.  I went ahead and booted

up off of the OS installer.  When the installer showed up, I launched Disk Utility and took my 500G disk and a 256G partion of HFS+ Journalized and the other I left unformatted for later (hoping to install Windows or Linux later on).

 

This went fine, I then went through the install, pointed it at the HFS+.  It finished and I was done with Phase 1.

 

Rebooted to do Phase II and that's where I ran into problems.  It wouldn't boot and go to the installer this time.

 

I correctly told it to load up the USB installer but then it does the following:

 

 

With no -v in the boot flags, it boots to an Apple Logo, then the cursor spins and the Apple Logo disappears and changes to a white square with a red circle and cross through the circle 

 

if we start it up with a -v flag in the boot args:

 

It stops here:

 

Waiting on <dict ID="0"<key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>

AppleIntelE1000e(Infor): AppleIntelE1000e:rx = 256, tx = 256

AppleIntelE1000e(Info): AppleIntelE1000e:WOL = 2

Still Waiting for root device

Still Waiting on root device ....

 

 

and that keeps repeating...

 

 

 

--------------------------->

 

So i went ahead and did a whole Windows 8.1 restore, to start from scratch and now I can't even start up off of the USB installer.    I still always get to the White Square with a Red Crossed Circle.

 

 

I've recreated the USB installer as per the Pokenguyen's instructions and now I always get to the Red Circle during the installer boot up.

 

 

What did I do wrong?

 

 

 

 

Thanks....

Share this post


Link to post
Share on other sites

Still waiting for root when you boot to USB does mean that it can't load your USB 3.0 drivers. Check if you have /EFI/Clover/kexts/10.9/GenericUSBXHCI.kext. It's better to redownload and create CLOVER partition (you can keep the install os x partition)

If you still can't load it, something wrong with your USB config in BIOS.

Share this post


Link to post
Share on other sites

Thanks for the quick response...

 

I had actually redone the entire USB install Disk including the Clover one, starting with a new Partition. But just to make sure, I through away the EFI folder that was on the Installer disk, and re-downloaded and copied and then redownloaded the 7440 files and put the config.plist  and still got the same problem....

 

 

Checked my BIOS for USB items available that I saw was:

 

USB Configuration:

Enable Boot Support (Checked)

Enable External USB Port (Checked)

and Enable USB3.0 Controller (Checked and Unchecked).  It was checked, so I unchecked it but I still get the same problem.    Now for what ever reason, I can't boot off of the Mac Installer USB when I had no problems before...

 

 

Any other ideas?  I saw Mac OS X on my computer partially working but now it's having issues, getting back on with this method.. .i'm sure the issue is sitting in front of the computer but just not sure how to solve that!

Share this post


Link to post
Share on other sites

Thanks again!    Unfortunately, that didn't help.  Same thing.   I guess it must be something on my bios?  Is their anyway to set it back to default?  Because I was able to get your method to show me the installer on my first use, but after that it ran into issues.      

 

I can see above where it is saying: "Still stating waiting for root device"

 

it is showing:

 

USBF: 0.745  AppleUSBEHCI::UIMInitialize  - Error occurred (0x00002be)

 

 

 

Can Do the installer on an SD card if you think this is a USB thing?    I have an SD card slot on my iMac and on this e7440.

Can I use a SD card?    I don't have a DVD drive yet, it's on back order, so i can't go that route.

 

Share this post


Link to post
Share on other sites

Try each of these solutions:

 

1/ different usb 3.0 ports

 

2/ At clover screen, press spacebar, boot without cache/booot in safe mode.

 

3/ replacing GenericUSBXHCI in 10.9 folder with the latest kext: http://www.insanelymac.com/forum/topic/286860-genericusbxhci-usb-30-driver-for-os-x-with-source/

 

4/ remove GenericUSBXHCI

 

5/ Change Fast Boot to Throughout.

Share this post


Link to post
Share on other sites

I tried all of these and it didn't work.   Then tried combinations of them and 

it looks like I was already on Through for the boot, so I changed it to minimal.

Removed the GenericUSBXHCI and started in Safe Mode.  Took those 3 things

together and I got an installer. 

 

I formatted my drive and I'm installing onto the newly partioned HFS+ format

in Phase I, we'll see how it goes. thanks for your help!

Share this post


Link to post
Share on other sites

Ok..I've got a OS 10.9.2 that boots up on my e7440 now.

 

No Wireless (Ethernet works)

 

No Bluetooth (System Report says No Information found)

 

No Sound  - (System Report shows Intel High Definition Audio but no sound and  volume is grayed out in menu)

 

USB - (System Report says No Information found)

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...