Jump to content
PayPal donations: [email protected] ×
GrandMstrBud

Dell Latitude E6520 Problems on both 10.8.5 and 10.9

Recommended Posts

Yes the 

 

Dell     DW1397          Half Mini PCIe 

 

If only it would work, I thought it was in the list of supported cards. 

You still didn't say what the issue is. Is it not detecting your card, device not showing in network preference or just not able to connect to a wireless network?

Share this post


Link to post
Share on other sites

It's not seeing the device in the network preferences 

are you seeing the adapter under wireless in system profiler?

if so, in Network preference, click the + sign to add new network and in the interface, click wifi

Share this post


Link to post
Share on other sites

It does show up but there is no WiFi when trying to add. I wonder if it's that fix that didn't end up taking that 3rd command

 

mac.png

 

 

MacBook-Pro:~ Paul$ sudo chmod 755 /usr/libexec/airportd
Password:
MacBook-Pro:~ Paul$ sudo chmod 755 /usr/libexec/airportd
MacBook-Pro:~ Paul$ sudo chown 0:0 /usr/libexec/airportd
MacBook-Pro:~ Paul$ xattr -d com.apple.quarantine /usr/libexec/airportd
xattr: [Errno 13] Permission denied: '/usr/libexec/airportd'
MacBook-Pro:~ Paul$ 

Share this post


Link to post
Share on other sites

 

It does show up but there is no WiFi when trying to add. I wonder if it's that fix that didn't end up taking that 3rd command

 

mac.png

 

 

MacBook-Pro:~ Paul$ sudo chmod 755 /usr/libexec/airportd
Password:
MacBook-Pro:~ Paul$ sudo chmod 755 /usr/libexec/airportd
MacBook-Pro:~ Paul$ sudo chown 0:0 /usr/libexec/airportd
MacBook-Pro:~ Paul$ xattr -d com.apple.quarantine /usr/libexec/airportd
xattr: [Errno 13] Permission denied: '/usr/libexec/airportd'
MacBook-Pro:~ Paul$ 

 

Try this fix from this link.

Share this post


Link to post
Share on other sites

Tried that and when going to diagnostics and then WiFi is grayed out. 

 

I also have in there a Huawei EM700U card and back when I had it in a Dell D620 with I believe 10.5 or 10.6 that actually worked with a SIM card. 

 

I may just have to buy a DW1510 if that will work OOB.

Share this post


Link to post
Share on other sites

I have an E6520 on 10.9.2 with an Atheros ar5bhb112 that's detected but cannot find networks, secured or not. Any ideas?

Share this post


Link to post
Share on other sites

My understanding is the AR9380 half height card is recognized by the system, but for whatever reason, cannot connect detect networks. The full sized card has no problems detecting networks.

Share this post


Link to post
Share on other sites

I wish that had been noted on the wireless card compatibility page so that I hadn't bought it. It's pretty expensive here in Japan. :-/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...