Jump to content

Latitude E6520 (10.9.2): Atheros AR5BHB112 does not detect networks, keyboard layout is not saved.


Recommended Posts

Two problems:



Wireless Cannot Find Networks

I installed an Atheros AR5BHB112 as recommended on the supported/unsupported card thread. It is detected but cannot find wireless networks. I tried to manually enter my wireless network information, but it could not find it/connect in either clear or WEP modes. My SSID is not hidden.


lspci -nn returns:

03:00.0 Network controller [0280]: Atheros Communications Inc. AR9300 Wireless LAN adaptor [168c:0030] (rev 01)


I've tried running MyFix quick and full and have rebooted several times with no success.


The old Dell card had two antenna hookups for ch 1 and 2; I attached those to ch 1 and 2 on the Atheros card. There was a third cable that was unused; I attached that to ch 0 on the Atheros card. Is this where I went wrong?


Keyboard Layout Is Not Saved

I use a Japanese keyboard layout. When I reboot, the computer reverts to a US layout and I have to go to Keyboard Settings to redetect it. Is there a way to permanently set it to a Japanese layout?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...