Jump to content

Help needed with E6530: Clover, Yosemite final, external Display Issue


Recommended Posts

Hello everybody,


first, I want to thank Jake Lo and pokenguyen for their nice guides. I'm not all new to building hackintoshs, but my last trys are 2-3 years old, and so much has changed.


In the last two weeks I could successfully install Mavericks on my E6530 with the guide Jake Lo posted, and I finished my Clover-based installation of Yosemite PB6 (yeah, I know, they released the final) yesterday.


So far, I like Clover, and a lot of stuff is working:


- Ethernet

- WiFi (replaced Intel with some compatible)

- Sleep (yay!)

- Touchpad (no gestures, but not that important) 

- Appstore, iCloud, iMessage, Facetime


What doesn't work (but I want it to!) is external display port(s). The problem obviously has something to do with the Optimus topic, but let me tell what I found out yet.


Following pokenguyen's guide, the Mackintosh Vietnam Tool installs Clover to the new Macintosh HD. Sounds good, but the new version did break my ability to boot, so I replaced the new Version with the older one (included in the original pack in guide).


After this, I was able to boot. After some testing, I can tell (Optimus enabled): with Clover 2703, only the Intel HD GPU shows up in Option - Graphics and in System booted up, with Clover 2953 its the NVS and the Intel in Option - Graphics in bootscreen.


Problem: I cannot boot with 2953, getting a crash immediately. It doesn't matter if Optimus is enabled or disabled.


So I guess I am missing something really stupid... Can it be I have to change something in my config.plist? Remember, the Intel GPU works fine with 2703.


I'm out of ideas at the moment, even tried to use Jake Lo's DSDT/SSDTs (bad idea)! Any help is really appreciated!





PS. Nearly forgot System Specs...


- E6530, BIOS A13

- I7-3740QM

- 16GB RAM

- Intel HD plus NVS5200m

- Display 15.6" 1920x1080

- WiFi by AR5BHB92

Link to comment
Share on other sites



I upgraded to Yosemite final release yesterday via Appstore. Some hints:


- don't have the laptop in docking station, it didn't work from there (crash caused by BT)

- had to boot from external USB and select the partition created by the installer, but no problems


Stuff that did work before still works - and still no external display yet. :(

Link to comment
Share on other sites

Thank you, Jake.


My Dell Latitude e6530 Mavericks with Chameleon uses HDMI video with Nvidia card and without sleep capability (everything else works).

So, I will jump into Yosemite with Clover.
Please let me know where I can find the guide.


Thank you very much.


Link to comment
Share on other sites

Sorry for the late answer, but work keeps me pretty busy atm.


It is a bit strange; with Yosemite final, I can not boot up if in docking station or external VGA connected (not active)...


I could do it with the Yosemite Beta, so I guess something in the final release has changed. As I'm no pro, I have no idea what this could be.


Clover does allow me to switch to the external VGA in boot screen by Fn+F8, but as it won't boot up I can't tell you if the screen would be working after boot. :D


For me, I could live without sleep but need the ability of connecting a second screen at runtime, which works fine with Mavericks and Jake Lo's Guide without Optimus. So I had the idea to replace DSDT + SSDT from pokenguyens guide with the ones from Jake Lo's guide - but I cannot get the combination of Clover and Jakes DSDT running.

Link to comment
Share on other sites

Hi, I have the same spec of E6530.


I encountered a usb installer bootup problem (with clover bootloader) and can't find a valid answer on any forum to solve it.


I want to use EFI boot so I createed the usb installer with clover. But when I tried to boot with the usb installer, it always halt at the line "Missing Bluetooth Controller Transport" . I search all the article and see several people said it is a video issue. Thus I tried all the combination to enable/disable optimus in BIOS, add/remove nv_disable, inject nvidia/intel driver, and add/remove -x. However, nothing works and it always halts on the same line.


Did anyone boot E6530 with clover? What boot argument do you use? 

Thank you very much.
Link to comment
Share on other sites

  • Create New...