Jump to content

D630 SL Install KP after EDP


Osbert
 Share

Recommended Posts

Hi Forum,

 

This problem is referred to you following several attempts all resulting in errors. I am new to this type of installation but did a successful one on a Dell mini.

 

Machine Details

D630 BIOS A12 Intel Core 2 Duo T7700 2.4 GHz 4 GB RAM, NVidia Quadro NVS135M 128 Mb, Display 1440 x 900, dedicated 320GB SATA HDD Toshiba, DVD +/- RW, Broadcom NetXtreme 57xx Gigabyte Controller (disabled in bios for this setup) Broadcom wireless card, O2Micro OZ776 USB CCID Smartcard reader (disabled), SigmaTel High Definition Audio Codec.

The machine works without problems with Windows 7 and Ubuntu Natty.

 

Install

I followed the wiki instructions as follows: -

usb pen from torrent.

booted ok and formatted as single partition GUID.

Rebooted into it and ran setup. Screen fine at full resolution, wifi ok, no lan (hence disabled for this install), sound fine, touchpad, mouse and keyboard ok.

 

EDP

Installed EDP V1.9.1 with options 7 D630 NV, PS2 option 1 use Apple, NullCPU – no – use Apple, Batt Driver – 1 use Apple, Speedstep –y, Menu item 2 – Fixes – disable hibernation – this had previously given boot error of hibernate image too old. Finally installed Chameleon from Option7.

Then ran updates from Apple download prompt to get up to V1.6.8. (Note in previous tries had omitted updates but still ended up with the KP at boot.

 

Boot Error

On reboot get KP.

running with –s option get the following lines after [PCI configuration….] and PS2 mouse start: -

 

OSMetaClass: Kext org.netkas.fakesmc class FakeSMC is a duplicate; kext org.netkas.FakeSMC already has a class by that name.

Kext org.netkas.fakesmc start failed (result 0xdc00400a).

Kext org.netkas.fakesmc failed to load (0xdc008017).

Failed to load kext org.netkas.fakesmc (error 0xdc008017).

FakeSMC opensource SMC device emulator by netkas © 2009

FakeSMC plugins & plugins support modifications by mozodojo, usr-sse2, slice © 2010

FakeSMC opensource SMC device emulator by netkas © 2009

FakeSMC plugins & plugins support modifications by mozodojo, usr-sse2, slice © 2010

panic(cpu 0 caller 0x2abf6a): Kernel trap at 0x54f53ed6, type 14=page fault, registers:

CRO:………

….

…

….

Error code 0x00000000

 

Having got this error, it is not possible to boot into it via the USB pen drive.

 

I checked the hard drive in Paragon Hard Disk Manager and no partitions were shown as active. Setting the SL partition to active made no difference.

 

To help facilitate repair, I have a MacMini running SL10.6.8 and can access the hd via a usb adapter.

 

Any advice would be welcomed.

 

Kind regards

Osbert

Link to comment
Share on other sites

Hi,

 

Thank you for your reply, it is much appreciated.

 

I gave your suggestion a try. I booted from the usb pen on the mac mini to get setup – disk utilities. Then cloned the mac-mini partition to the laptop hdd.Then rebooted the mac-mini to its op system and reinserted the laptop hdd as a usb device.

 

Next I installed EDP on the mac mini with the target as the laptop. It would not run the commands correctly due to the directory root being different. So I opened a terminal, did a chroot to the laptop root directory and then ran the command as sudo. They ran OK.

 

I did all the installations as before. After putting the drive back in the laptop, I got the kernel panic in exactly the same place with the same error messages as my first post.

 

This suggests that the problem is not with the operating system on the disk but rather with the way I am using the EDP.

 

The kp error message with the little that I understand of it suggests that there is a conflict between two items attempting to be loaded.

 

Since I can get into the workings of the OS by plugging the hdd into my mac mini, is there a methodology of doing the faulting by editing or excluding items?

 

Your further advice would be welcomed.

 

Kind regards,

Osbert

Link to comment
Share on other sites

well you could just clone your mac mini. to it and run edp and chameleon on that instead of using a torrented image at least you know that install is functional.

 

I'm getting the same problem he is having, and I'm using the 10.6.3 Snow Leopard DVD. Whenever I install the 10.6.8 combo update I too get the FakeSMC kernel panic error. And yes, I've followed the guidelines on the wiki.

 

My specs:

 

D620 BIOS A10 Intel Core 2 Duo T7200 2.07

Intel GMA950(27a2)

Link to comment
Share on other sites

Hi,

 

Thank you again for your help, you found the problem.

 

In the event the duplicate was also in /Extra/Extensions. This contained FakeSMC.kext and FakeSMC 21-48-08.kext. System/Library/Extensions was OK.

 

The problem is caused within EDP1.9.1 when running option 1. When the changes are committed, both are written to the directory concurrently.

 

I deleted the latter and it boots fine!

 

Kind regards,

 

Osbert

Link to comment
Share on other sites

====================== Added on Sunday =================

 

Further to my post, whilst the machine is now bootable with shutdown and sleep, and has 1440 graphics,

 

it is missing the following: -

 

no touchpad;

no wireless;

no lan;

no sound.

 

With the exception of lan, all these were working at first boot before the edp configuration.

 

I have tried running the edp both before and after installing updates but with the same outcome.

 

So my first thought about the two Fakesmc kexts may have been wrong as well.

 

Any help would be appreciated.

 

Kind regards,

 

Osbert

Link to comment
Share on other sites

Hi,

 

Thank you for your reply.

 

Before following your suggestions I upgraded the BIOS to the latest – A17.

Then repartitioned and installed from USB.

 

Ran EDP1.9.1 and then Chameleon install.

 

I noted that as previously EDP created both FakeSMC.kext and FakeSMC 21-48-08.kext (I left them both in).

Then ran the 10.6.7 combi update.

 

Rebooted – Kernel panic as before.

 

I put the drive in a usb connector to my mac mini and deleted FakeSMC 21-48-08.kext and rebooted.

Boots OK but: -

no sound,

no trackpad,

no wireless though shown working,

lan working but shown as disabled.

 

Tried replacing the FakeSMC.kext with the other one, but no different.

 

Your advice would be appreciated.

 

Kind regards,

 

Oswald

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...