Jump to content

Case of broken HDMI Audio - Acer Aspire 5755G


sercio
 Share

Recommended Posts

Hello Guys, 

 
I've been following EMlyDinEsH's Complete AppleHDA Patching Guide, I've managed to get AppleHDA, HDMI and HDMI audio working yesterday. I was so happy that I even might opened up window and screamed out 'shake it baby!'. But that was yesterday. 
 
While building my hack, I have tinkered with too much thing and I felt something 'dirty' on the pc (it probably was just me) So I have reinstalled the system. Before I reinstalled it, I have backed up the EFI folder with all kexts, patched DSDT and all that. 
 
After reinstallation, I have inhibited the patched kexts (which resides on EFI partition and gets injected by Clover) and restored the EFI partition, everything were working except for the battery meter. That was no problem, I reinstalled the kexts, and all was fine (at least, I was thinking all was fine.)
 
After I reinstalled all apps I use, I hooked up the pc to the lcd tv via HDMI, but BANG! HDMI audio was not working. That was the moment I realized once more that it was the cost wanting all at once. 
 
I have gone through the AppleIntelSNBGraphicsFB.kext patching procedure again (even thought it was working fine right before reinstallation), but no luck. HDMI is working, but no HDMI audio. 
 
Here are the guides I was using:
 
 
 
P.S.: I could not used the mentioned dsdt patch on last link, since it is missing some headers (I think) but that should not be a problem because it was working fine before reinstallation. Besides, it says 'Patched DSDT with platform id OR SMBios of MacBookPro8,1' and my smbios is set to MBP8.1. 
 
Details of my system: 
 
PC: Acer Aspire 5755G
System: Yosemite 10.10.2
Graphics: Intel HD3000 + GT 540M 
CPU: i7-2670QM/HM65 rev. B2
Botloader: Clover r3193
 
Here is link to my EFI partition. I didn't know what else can be needed to pinpoint the problem so please let me know what else should I send. 
 
 
So, my question is, where should I start looking? Or how do yo even troubleshoot this kind of problem? 
 
Link to comment
Share on other sites

 Share

×
×
  • Create New...