Jump to content

DELL T3500 - Yosemite


vdv
 Share

Recommended Posts

Hi,

I've recently bought a cheap Dell T3500. I really like this workstation: solid, well designed, nice looking.

 
I've been able to install Yosemite using Clover.
Characteristics of T3500
Last firmware available (should be A17)
DDR3 ECC
Dual-core Bloomfield Xeon W3505 2.53GHz installed (I'll receive a 6-core Gulftown Xeon W3690 3.46GHz in 2 weeks)
Video card GTX660. Natively recognized.
Update is fine up to 10.10.3
 
I'm using:
Patched DSDT 
BCM5722D.kext
FakeSMC.kext
 
I know I could use also VoodooHDA.kext to have audio working, but I want to fix other points before.
 
Patches on DSDT are: fixed RTC, add DTGP, add SBUS and ISA (001F000) to recognize ICH10R as ICH10.
 
Problem I have:
1) Wake from sleep is not working properly: System sleeps perfectly (in 20 seconds all fan stop).
When I press mouse or keyboard or case power button all fan starts. HDD starts but black screen.
The diagnostic light code shows led 2 which means "possible expansion card failure".
I have to wait about 4 minutes than system wakes perfectly (diagnostic light code led 2 switch off).
It seems something is delaying wake. Delay seems to be a fixed time.
No notes on console. Wake reason is usb. Wake time on console is usually 4 minutes after I've really pressed key or mouse (generating the wake reason).
 
I tried everything I know: fixDarwin, USB patches (ICH10), ISA patch to force ICH10 (it fixed my old P5KC motherboard which have similar problem).
Taking inspiration from Hervé's guide for Precision 470/670 i tried also with hibernatemode set to 0 + deletion of /var/vm/sleepimage.
Seems not working for me.
 
This is really annoying for me, cause I feel sleep function really useful.
 
2) Not sure on ISA (001F000) patching on DSDT
Correct ID for ICH10R should be 0x16, 0x3A, 0x00, 0x00.
If I force device ID to 0x18, 0x3A, 0x00, 0x00, seems working (it is device ID for ICH10).
 
Forcing 0x18 IORegistryExplorer shows me that ISA is using apple kext, otherwise no kext loaded.
Problem is that by forcing those parameters, system tells me ram is installed on wrong slot (system shows 12 slots, I have only 6). On system properties it shows me only 5 slots. So something is wrong.
 
I also tried different SMBios settings; nothing change.
 
Is there any kext to install or DSDT setting for X58 with ICH10R?
 
3) I'm not sure on some config.plist settings; quite tricky to make system boot (I took inspiration from other who have been able to install using clover).
In particular: FakeID set to 0x0 on all items.
Necessary to patch AppleAHCIPort.
Other setting I can almost understand.
I can post my config.plist.
 
 
I would ask Hervé (I really liked his guide on Precision 470/670 Yosemite)
What would happen to sleep/wake on Precision 470/670 if NO hibernatemode set to 0 and NO deletion of /var/vm/sleepimage.
 
Any suggestion on DSDT patching? I can send my original DSDT and patched + IORegistryExplorer saved file.
Link to comment
Share on other sites

Thanks for reply.

No wake on lan set: it is called NIC Wake on this Bios (is under power management).

USB is enabled on BIOS. Do you mean switch off controller from BIOS? 

If I switch USB off controller mouse and keyboard don't work.

 

I haven't found any other setting or option on bios related to USB or Wake on Lan.

Link to comment
Share on other sites

No, no other options on Bios (at least I can't find any).

I'll check if there is a way to "edit bios" in order to show other options. I already did editing on P5KC motherboard enabling AHCI (this option was not shown). I also installed on bios Xeon extension to install 771 Xeon on 775 Mobo.

 

Btw I think that if it would be a bios related problem (setting on bios) wake should work/not work.

In my case wake is working with 4 minutes delay. So I think it should be more related to DSDT or OS X settings.

Any help appreciated.

Link to comment
Share on other sites

  • Administrators
On 4/29/2015 at 2:06 PM, vdv said:

[...]

I would ask Hervé (I really liked his guide on Precision 470/670 Yosemite)
What would happen to sleep/wake on Precision 470/670 if NO hibernatemode set to 0 and NO deletion of /var/vm/sleepimage.
[...]

It's actually a general Hackintosh matter: setting hibernation mode to 0 means there is no dump of memory to a file that will be retrieved on power resume should power come to fail. Basically, mode 0 = sleep to RAM (often called plain old sleep) and if power fails, system will do a cold start when switched on again.

 

By default, OS X operates in mode 3, for which a hibernation file (=/var/vm/sleepimage) is created to preserve memory contents. If you keep that mode on a Hackintosh, you should be able to sleep but you may experience issues with wake and most certainly on reboot as OS X will attempt to use the sleepimage file and that does not work on Hackintoshes. System then usually reports a boot error until you actually delete the sleepimage file.

 

You can consult the manual pages of the "pmset" command for more details, but here is a short extract:

hibernatemode = 0 (binary 0000) by default on supported desktops. The system will not back memory up to persistent storage. The system must wake from the contents of memory; the system will lose context on power loss. This is, historically, plain old sleep.

 

hibernatemode = 3 (binary 0011) by default on supported portables. The system will store a copy of memory to persistent storage (the disk), and will power memory during sleep. The system will wake from memory, unless a power loss forces it to restore from disk image.

 

hibernatemode = 25 (binary 0001 1001) is only settable via pmset. The system will store a copy of memory to persistent storage (the disk), and will remove power to memory. The system will restore from disk image. If you want "hibernation" - slower sleeps, slower wakes, and better battery life, you should use this setting.

  • Like 1
Link to comment
Share on other sites

Thanks Hervé, I got your point. I tried to set it to 0 but didn't fix.

My question was: If you don't set hibernate mode to 0, what happen to your sleep? Does it sleep or wake properly?

 

My case is a delayed wake, what do you think could be a cause?

Can I post DSDT and IOreg?

 

I just had an idea to try PS2 keyboard and mouse, to see if USB is the problem (Idea coming from Bronxteck reply)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...