Jump to content

Help me with Dell Latitude E5420 OSX SL/Lion installation


Chan Chua
 Share

Recommended Posts

Hello,

 

I've got this new Dell Latitude E5420

Intel core i5 -2410(2.3GHz)

8GB DDR3 RAM, 320G HDD SATA,

LAN : 10/100/1000 Gigabit Ethernet

WLAN : Broadcom BCM57xx Wifi

Intel® HD Graphics HD 3000

14" HD WLED True-Life (1366x768)

 

http://www.dell.com/us/enterprise/p/latitude-e5420/pd

 

I used iFail L1 to install with these options : chimera (chameleon, stolen and rebranded) v1.5.4, Graphics Enabler, /Extra/Extensions, FakeSMC,Disabler, RTC, EvOreboot,IOPCI Family,PS/2,Voodoo HDA 2.7.2.

 

After finish the installation, I reboot it with -s-f-v options and enter the Lion OS.

At this step, I have keyboard, the webcam and audio working. Mouse and wired/wireless are not working, video not correct resoluton (1024x768).

 

I used multifail 4.0.3 to install : EasyBeast Install, Mac BookPro 8,1 and reboot again.

 

Now the mouse /audio / wired / wireless is not working.

 

Keyboard is ok and video is at correct resolution : 1366x768

 

Please help me how to get this Dell running with correct functions !!!

 

Thanks for your help.

Link to comment
Share on other sites

Hello,

 

I've got this new Dell Latitude E5420

Intel core i5 -2410(2.3GHz)

8GB DDR3 RAM, 320G HDD SATA,

LAN : 10/100/1000 Gigabit Ethernet

WLAN : Broadcom BCM57xx Wifi

Intel® HD Graphics HD 3000

14" HD WLED True-Life (1366x768)

 

http://www.dell.com/us/enterprise/p/latitude-e5420/pd

 

I used iFail L1 to install with these options : chimera (chameleon, stolen and rebranded) v1.5.4, Graphics Enabler, /Extra/Extensions, FakeSMC,Disabler, RTC, EvOreboot,IOPCI Family,PS/2,Voodoo HDA 2.7.2.

 

After finish the installation, I reboot it with -s-f-v options and enter the Lion OS.

At this step, I have keyboard, the webcam and audio working. Mouse and wired/wireless are not working, video not correct resoluton (1024x768).

 

I used multifail 4.0.3 to install : EasyBeast Install, Mac BookPro 8,1 and reboot again.

 

Now the mouse /audio / wired / wireless is not working.

 

Keyboard is ok and video is at correct resolution : 1366x768

 

Please help me how to get this Dell running with correct functions !!!

 

Thanks for your help.

 

 

Hi man, i have the same Latitude e5420 , after 3 weeks i got a fully working install Lion 10.7.2

Disable 1394 port in bios and ExpressCard set boot for minimal

just use iboot (chameleon, stolen and rebranded) from tonycrapx86 blog with last chimera (chameleon, stolen and rebranded) edition don't use Graphics Enabler

after install boot from iboot (chameleon, stolen and rebranded) again and add some kexts to /S/L/E/ and use MultBeast for Lion and make smbios,plist Boot.plist files

 

the kexts used was:

to boot

FakeSMC

IOAHCIBlock

AppleCPUPowerManagement patched With speed_stepper_lion_1072(google it) if cannot found use the NullCPUPowerManagement instead (but no Sleep)

 

Mouse and Keyboard Both works but mouse don't recognized as a touch (no gesture working ) Google for Synaptics Keyboard Gesture 32 64

AppleACPIPS2Nub

ApplePS2Controller

 

Audio (Semi Work, Master Volume doesn't work and some glitches at playback music, i can't get intel HDEF working need DSDT hacks and i didn't try )

VoodooHDA 0,2.72 from multifail (delete AppleHDA.Kext to avoid Kernel Panic)

try AppleHDA Patched For Lion

Use BCM5722D Kext

 

For Battery

Voodoobattery kext

 

Onboard Bluetooth No kext needed

Onboard Webcam No kext needed

Onboard wi-fi Not work use a USB or change onboard card

 

Get Almost Info and next at this sites:

http://www.kexts.com/downloads.php?do=file&id=1578OnBoard Ethernet

InsanelyMac or OSX86PC

tonycrapX86

http://www.osx86.es

Link to comment
Share on other sites

Hi, Just received my E5420

 

Installed iFail L1, install runs fine, on reboot my keyboard, mouse and trackpoint don't work so I edit the setup assistant.plist so it boots.

 

I can't get the Intel HD 3000 to work, I've tried using Intel hd graphics kexts and adding my device id, as suggested previously, and also tried updating to the latest chimera (chameleon, stolen and rebranded) but still no look. It also detects the card as 64MB.

 

Specs:

Dell E5420

Intel i5-2520M

4GB DD3

250GB

Intel HD 3000

1600x900 LED screen

Keyboard with Trackpoint (trackpoint has been causing lots of issues, causing my touchpad not to be detected by lion etc)

 

Any suggestions would be appreciated

Thanks

Link to comment
Share on other sites

  • Administrators

hi guys,

 

I use the attached(DSDT_E6220) for my notebook.

But the intel HD3000 can't work and the resolution is only 1600x768.

Can anybody help me??

 

BR,

Eagure

 

 

More details needed.. What machine do you have and what OS are you running ?

Link to comment
Share on other sites

Hi guys,

 

Thanks of feedback soon.

 

My notebook's hardware spec as below:

 

DELL Latitude E6220

CPU: i5-2.45G

RAM: DDR3-2G

Graphic: Intel HD 3000

LAN: Intel 82579M Gigabit Ethernet

 

I remove WLAN and BT.

 

I use Lion(10.7) for my MAC OS and install SOP follow below website.

http://tonycrapx86.blogspot.com/2011/10/unifail-install-mac-os-x-lion-using.html

 

BR,

Eagure

Link to comment
Share on other sites

 Share

×
×
  • Create New...