Jump to content

Install on an E6540 Issues


scbattlepaw
 Share

Recommended Posts

I am currently trying my hand at installing OSX 10.10.5 on a Dell E6540.  The specs are:

  • CPU - i7- 4610M (2 Cores) Haswell
  • GPU - Intel HD 4600 (AMD Discrete - nothing in BIOS to disable)
  • Memory - 8GB DDR3L SDRAM
  • BIOS - A16
  • Samsung SSD Hard Drive set to AHCI Mode

I have been following the instructions on Herve's E6440 Guide to create the USB Boot and perform the following steps:

  1. Mount InstallESD.dmg found in Install OS X Yosemite.app/Contents/SharedSupport
  2. Then mount BaseSystem.dmg (hidden file)
  3. Use Disk Utility to restore the contents of BaseSystem.dmg on a USB key (or HDD partition) formatted Mac OS extended (journaled).
  4. Remove link for Packages in folder System/Installation of your USB key
  5. Copy folder Packages located in InstallESD.dmg to folder System/Installation of your USB key
  6. Copy the 2 hidden files (BaseSystem.dmg & Basesystem.chunklist) of InstallESD.dmg to the root of your USB key
  7. Create a Kernels folder in /S/L
  8. Copy Haswell patched 10.10.5 Kernel into the folder created in step 7
  9. Copy /Extra folder to the / ( I have used the Extra folder from Herve's E6440 and Stoliededog's from his install)
  10. Copy kexts from /Extra to /S/L/E (backup files first)
  11. Install Chameleon 2.3r2437 to the USB
  12. Eject
  13. F12 on the Laptop
  14. Boot with -v -f
  15. Partition hard drive with 1 partition - GUID Partition
  16. Answer questions and watch install

At this point the installer counts down and then becomes a black screen with white text at some point and reboots.  If I select the newly created install from the USB Boot, it reboots the laptop.  If I select the USB Boot, it starts over with the install.  I have tried several USB drives just in case it was something with them.  I must be missing something somewhere in the process and any help would be greatly appreciated.

 

I have attached a CPUID text output - E6540.zip and the latest Extras folder that I was using.

 

Thanks!

 

Extra.zip

E6540.zip

Link to comment
Share on other sites

  • Administrators

After installation has completed, the vanilla kernel is on your freshly created Yosemite installation. As such, you need to boot into the USB installer and copy the Haswell-patched kernel to the HDD before you can boot it. Failing that, indeed, you experience system reset when kernel loads.

 

The above is actually in the guide, though I admit after having created a Clover USB key, installed and booted OS X.

 

You may find the steps of this guide a little easier to follow. You'll obviously have to copy the Haswell-patched kernel to target Yosemite HDD just before copying the Extra folder.

Link to comment
Share on other sites

Looks like sound and network are working fine but I just noticed that the title bar and some windows has a strange artifacting look to them like they are washed out or low resolution.  Everything else looks normal to me.  During the install, everything looked perfect until it hit the actual desktop

Link to comment
Share on other sites

Ahhh great!  That patch did it.  I applied it and rebooted, all graphics look good.  I ran a GeekBench and it shows me at 6895.  A little lower than I guess I expected but the networking, sound and graphics all seem to be working now.  Will do more testing and see if there are any other issues.  Wireless is not working but I guess that is to be expected?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...