Jump to content

D430 - Lion


kr4zyc1d
 Share

Recommended Posts

Hey everyone, I have been jumping around between devices because I have a few spares laying around. Currently I am working on the Dell D430 Core Duo and was able to install Lion successfully to the machine. During the initial setup everything but the touchpad and brightness seemed to work. Ran the 2.1 EDP and did most of the fixes, but now when I boot the machine the pinwheel spins for a while then gets to a point where it freezes in every position of the pinwheel making it completely black. It doesn't look like it is doing anything at this point on the screen, but the hard drive light is going crazy. Any thoughts here of how to boot into the system? Any boot switches I might be missing here? Thanks!

Link to comment
Share on other sites

Awesome, 2.2 I think will be the ticket. Wifi, sound touchpad*, sleep all work. There are a few things to see if you know how to adjust or perhaps what I should be checking on the EDP. I don't want to complain too much and once this computer is set I'll start working with my D630 again. But the last things/issues I am seeing here:

Touchpad - no scrolling/preference pane help. I can open the mouse in preference pane and adjust track pad speed but trackpad doesnt work. I am selecting the first item in the EDP, I believe voodoo.... but whichever number 1 is.

Keyboard - every time it boots it shows that there needs to be a bluetooth keyboard attached - I told bluetooth to not be discoverable, and may turn it off, no extensive testing done here. I did see something earlier about this but not sure of a solid fix for removing this.

 

Sleep works, but I am using the BIOS adjusted DSDT from SL a while back and it required me to have the bios password. I am ok with keeping the password but not sure if anyone knows if this has been fixed to where it isn't required. Again, I can test it manually, but just throwing it out there.

 

Other than that, super work on the EDP and the whole operation. Couldn't have done it with out this site!

Link to comment
Share on other sites

Follow up:

 

Sleep, it looks like the password is still required, no problem here, just researching.

Turning off bluetooth in the BIOS seems to have removed the keyboard error. I don't use it so it was a quick fix

Touchpad, still no scrolling - haven't tried other options on edp.

Screen - edp 2.2 did allow me to reboot after the gma fix, but when it boots the brightness is set to about 80 % and doesn't auto increase, not a problem but was wondering if there was a fix. Currently pressing Fn and F12 increases brightness and everything else is good after that.

 

Thanks again for the help, please let me know if you have any options or if there is anything you need me to test.

Link to comment
Share on other sites

Ok, here is something weird - see if any of the DSDT/BIOS gurus know this one.

 

If the machine is shutdown (Press power button once and select shutdown) it shutdown and starts up with no issue.

If the machine is rebooted (Press power button once and select reboot) it goes down fine, but when it boots it does the long boot through the bios/apple/dell boot sequence. Almost like the bios was just edited or i have seen this occur when the machine is powered off during the bios boot period (dells only) and the second time through it is very slow.

 

Just seeing if anyone had seen this or knew of this issue and some way to resolve it. Thanks!

Link to comment
Share on other sites

Hey, can you please give me some guidance with mi D430? I'm trying to install Lion but I'm not sure of what I've been doing wrong. drivers and kernel, bootloader.. anything.?

 

 

It might be best if you were to start with your current model and computer information, and then move into what you have done thus far and what is/isn't working. Then we can assist diagnosing the issue and forming a resolution! :)

 

I have had really great success with my Core Duo D430 here, there are only a few things that are a bit wonky that were discussed here that appears to be either model/type specific or stuff that just doesn't work for some odd reason. Not deal breaking stuff, just minor annoyances that you might work through with this machine. Otherwise it is really fantastic and super simple and the guys on here know their stuff and are really helpful.

 

I would first start by getting the usual downloads and setting up your USB installer.

*myHack works great, get this

Then you will just want to follow the wiki starting with these three tips:

*http://www.osxlatitude.com/lion/

*EDP: http://www.osxlatitude.com/edp/

*Extra: http://www.osxlatitude.com/supported-models/

 

Good luck!

Link to comment
Share on other sites

 Share

×
×
  • Create New...