Jump to content
Hervé

Proper keyboard layout recognition with VoodooPS2Controller (e.g. Latitude E Series)

Recommended Posts

It's been reported many times by folks who use the VoodooPS2Controller kext for keyboard and trackpad: keyboard layout or mapping does not appear fully recognized when typing text.

 

Example on a French AZERTY keyboard:

FR_keyboard.jpg

The key GT-LT_key.jpg is often not properly interpreted when typing and appears to be swapped out with key Little_2_key.jpg found right under [Esc].

 

This problem is usually due to the VoodooPS2Keyboard PlugIn of the VoodooPS2Controller kext not calling on ISO keyboard layout. However, this is configurable through the Info.plist file of the PlugIn where the associated parameter is very often set to false. Turning it to true usually fixes the problem.

 

So, in order to enjoy proper keyboard layout/mapping recognition, try and adjust your Info.plist from this:

<key>Use ISO layout keyboard</key>
<false/>

to this:

<key>Use ISO layout keyboard</key>
<true/>
 
Hope this helps! I've verified the fix on my E6220 and E6440 so I know it works for the Latitude E Series; no reason why it would not work for other systems too.

Share this post


Link to post
Share on other sites

Note: if you happen to be using an ANSI keyboard on a US model Latitude and you are not seeing the proper behavior for the ` (back quote) or ~ (tilde) key, even though ANSI is selected in the mac OS control panel, then you likely want to set "Use ISO layout keyboard" to false.

 

Share this post


Link to post
Share on other sites

I'm using ApplePS"Controller.kext.

Any suggestion to get this working with this kext?

 

VoodooPS2KEyboard didn't work with my E5550.

Share this post


Link to post
Share on other sites

Try going to Keyboard Preference, change keyboard type

Switch to ANSI to ISO or vise versa, whichever that's working for you.

Share this post


Link to post
Share on other sites

The dialog to change the type starts, i press next, then i have to press the key next to the left shift key.

I can press the < key as many time s i want, it is not recognized.

Share this post


Link to post
Share on other sites

@denkteich

I had to add a German keyboard to do this since I have a US keyboard.

So this is how to switch to ISO keyboard with ApplePS2Controller.kext

Open Keyboard preference, under Keyboard, enable Show keyboard and emoji viewers in menu bar

In the menu bar, click on the keyboard and emoji viewer icon and select Show Keyboard viewer

Now in Keyboard Preference, select Change Keyboard Type, click continue

Now instead of using your actual keyboard, you use the virtual keyboard to select the key right / left of shift key using your mouse to click it

You should now be able to select  ISO keyboard.

If you look at the virtual keyboard, you still don't see the <> key, so just press any key, the <>will appear.

german.pnggerman2.png

I don't have a German keyboard, but I think this should work after selecting ISO keyboard. Hope this helps.

 

 

Share this post


Link to post
Share on other sites

Hi Jake,

 

thx for the tip, but it didn't work.

I pressed the < key and it looks like the keyboard is recognized.

I started Testest, the key is still dead.

After this I wanted to try it again, but the "Change Keyboard Type" button is not there anymore.

 

Any suggestion how to get the button back or start the assistant manually?

 

cheers

.d

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...