Jump to content

Lenovo Flex 2 15


rdracing
 Share

Recommended Posts

I'm having difficulties getting the sound working on a Lenovo Flex 2 15 with an Realtek ALC233 Codec running El Capitan 10.11.3.

 

Here's quick run down of the specs and what I've done so far.

 

CPU Intel Core i7 4510U (Haswell)

8 GB DDR3

Intel HD 4400

Realtek ALC233

Realtek 8111 kext for LAN

BCM43xx kext for WiFI (removed BIOS Whitelist to switch to this)

 

After flashing the BIOS with a modded version by BDMaster I was able to access the advanced menu in the bios and replace hardware without being bothered by a whitelist.

 

After several patches to DSDT/SSDT's I've gotten the HD 4400 working perfectly including the brightness fix and fixing some minor archiving (I had a bit of menu archiving that required an edit of the AppleIntelFramebufferAzul.kext). 

 

Everything is working exceptionally well (Even the touchscreen), other than audio. I've patched the DSDT in every way I could find including RehabMan's 'Audio Layout 12' switching the ID to 86 and nothing.

 

System report shows 'Intel High Definition Audio' under Audio with 'Internal Mic' 'Speaker' and 'External Microphone / iPhone Headset' but nothing is System Preferences -> Sound. 

 

I have a vanilla AppleHDA in my S/L/E but it will not load. I've tried forcing it to load VIA Clover but it will not.

 

I've extracted the audio codec in Linux and tried working my way threw the Apple HDA patching guide but got lost in the renaming on step 3 or 4?

 

If anyone has any experience with either this model of Lenovo or getting the ALC233 working with a patched AppleHDA on any other laptop I would appreciate any tips or pointers to get this working.

 

I'm attaching the Linux codec dump incase anyone would like to see it.

 

Thanks,

Ron

 

 

codec_dump_ALC233.txt

Link to comment
Share on other sites

 Share

×
×
  • Create New...