Jump to content

Dell Venue 11 pro: need help with brightness control


Chao_bee
 Share

Recommended Posts

I have installed el capitan on my dell venue 11 pro recently, and the injected ig-platform-id is 0x0d220003, the gpu is HD4200 while the CPU is i5-4300y. The graphic card works fine, but I cant control the brightness level.

So if there anyone can do me a favor, I'll be very very appreciated for that.

The internal screen is recognized as Appledisplay, I know Applebacklightdisplay is right but don'n know how to change it. Any ideas?

0x0d220003 is a destop one, but others like 0x0a260006 are not working. I modified Appleintelfamebufferazul.kext, and copied the data under 220003 to 260006, then I injected ig-id with 0x0a260006, it became as same as 220003 with no backlight sliders.

Thanks in advance. 

Link to comment
Share on other sites

ioreg.zip

It's not working, I've tried that already.
Rehabman said that the internal screen must be recognized as Applebacklightdisplay instead of Appledisplay, in order to make backlight control method working.
But I've tried several ways, nothing useful. I use ig-platform-id 0x0d220003, it's a desktop one, for only this one, my graphic card seems working right. I thought it might be an intel-framebuffer parameter's issue. I injected Appleinterlframebufferazul, replaced parameters under 0x0a260006 to make it working. Now I use 0x0a260006 instead. But there must be some error for the type of Appledisplay. I cannot change it.

Link to comment
Share on other sites

  • Administrators

Try the attached patched DSDT.

DSDT_meng_patched.zip

 

Updates I've done:

1) add desktop HD4600 device id 0412 + Azul FB #12 layout id 0x0a260006 + hda-gfx entry to IGPU device @0x00020000

2) remove _HID name from LCD device

3) remove _ADR name + _BCL/_BCM/_BQC__DOS methods from PNLF device

 

This DSDT should be used in conjunction with vanilla graphics kexts (restore those if required) and Rehabman's fake PCIID kexts:

  • FakePCIID
  • FakePCIID_Intel_HD_Graphics
  • FakePCIID_Intel_HDMI_Audio
 

Try this and report back.

Link to comment
Share on other sites

Thanks for your help, sir. Best wishes.

I did as you told me, and encountered a system reboot.

I used -v to see what happened, everything seemed fine but when it should change to the white process bar, it didn't, the screen dimmed, then the system restarted.

I think there must be something wrong with the frame buffer. 

I can use 0x0d220003 to enter the system, but no way to control backlight. At before, I modified Appleintelframebufferazul.kext, to use 0x0a260006. I just copied the data below 0x0d220003 to 0x0a260006. Of course it's meaningless.

I tried to modify the port number, such as below,

03 00 22 0D 
00 03 03 03 
00 00 00 02 
00 00 30 01
00 00 00 00 
00 00 00 60 99 14 00 00 99 14 00 00
00 00 00 00 00 00 00 00 01 05 09 00 00 04 00 00
87 00 00 00 02 04 0A 00 00 04 00 00 
It's the vanilla version. I changed 0D 22 00 03 to 0A 26 00 06. I tried to change 01 05 09 00 00 04 00 00 87 00 00 00, which means [email protected], to [email protected], 00 00 09 00 00 04 00 00 87 00 00 00, then the type of connector from DP to lvds (Mine is eDP), it looked like this then, 00 00 09 00 02 00 00 00 30 00 00 00. The screen got blank. It seemed to output on another port, because I could still hear the key stroking sound.
I'm puzzled...
Link to comment
Share on other sites

 Share

×
×
  • Create New...