Jump to content

Dell Latitude E7450 El Capitan 10.11.5 Tweaks and Fine-tuning


Rumster
 Share

Recommended Posts

Following the guide Latitude/Inspiron El Capitan
I obtained a Dell E7450 BIOS A13 | i5-5300U 2.3 GHZ | 16GB LVDDR3 | Intel HD 5500, 1920x1080
I installed a Broadcom BCM94352Z M.2 | Intel 530 SSD(with hard drive bracket off eBay)
I successfully patched DVMT using the provided offsets of 0x15b and 0x15c.
 
Successfully resolved sound after sleep by setting "Reset HDA" in clover and using
codeccommander.kext / EAPDFix.kext without any further tweaks to said kexts
 
Resolved some powerd message spam in console by adding to FakeSMC Info.plist Clover dictionary 

 

<key>ACID</key>
    <array>
         <string>ch8*</string>
        <data>ut7DNVAFEGM=</data>
    </array>

Resolved some basic issues with safari crashing due to el capitan changes in the way media streams

embedded in flash content is handled by installing Perian. 

Resolved some graphical corruption issues by disabling shake mouse cursor to locate in Accessibility -> Display.

 

 

What works:
* Handoff, Facetime, Itunes, Ibooks, Appstore, iCloud, Webcam, Microphone, USB, USB3, Trackpoint and trackpad,

Boot, Shutdown, and Sleep, Bluetooth and Ethernet. Graphics is detected as Intel HD Graphics 5500 1536 MB.

SSD is detected with trim.  System works nearly flawlessly, boots quickly, and runs smoothly.

 

It still has some problems:

* ssdPtrGEN.sh run and smbios.aml put in efi/clover/ACPI/patched, cpu is still detected as an i7.
* System automatically goes to sleep whenever it is booted up, and has to be resumed from sleep before operation.
 - This issue also plagues the E6420 I configured using the same guide.

* webcam does not work after system is manually put to sleep and resumed from sleep(i.e. it works after the bug sleep on boot but not after subsequent sleeps).

* Cannot use custom EDID. System doesn't work right after I put it in. Graphics corruption/ not detected anymore.

Do I need EDID for anything? Will it get colors more accurately?

My EDID is here if anyone knows how to patch EDIDs and wants to give it a shot:

0x00 00 FF FF FF FF FF FF 00 4C 83 48 4C 00 00 00 00
0x10 00 17 01 04 95 1F 11 78 0A 36 25 93 56 55 93 29
0x20 1D 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01
0x30 01 01 01 01 01 01 60 39 80 DC 70 38 40 40 30 20
0x40 25 00 35 AE 10 00 00 1A E7 2D 80 DC 70 38 40 40
0x50 30 20 25 00 35 AE 10 00 00 1A 00 00 00 FE 00 47
0x60 54 4B 44 59 80 31 34 30 48 4C 0A 20 00 00 00 00
0x70 00 00 41 21 94 00 10 00 00 02 01 0A 20 20 00 BA

----

The guide has an minor flaw:
When I set up a USB drive for my E6420 I had to follow the installation media section of the guide. The guide does not 
clearly disambiguate that BaseSystem.dmg and BaseSystem.chunklist go at the root of the USB drive,

not at the root of the Install OS X EL Capitan.dmg disk image on the drive.

Link to comment
Share on other sites

  • Administrators

if it works well without your EDID injection  then you do not have to inject it manually clover might already be doing it. you can check if EDID is found in clover boot.log. as for screen you can manually calibrate it in the display prefpane under the color tab.

Link to comment
Share on other sites

 Share

×
×
  • Create New...