Jump to content

E6430: can't boot after error ejecting external disk and restarting osx


skyswimmer
 Share

Recommended Posts

Hello again all at Osx latitude.

 

I have a new problem booting, I connected an external hard disk and when ejecting there was an error "can't eject disk". Then when restarting my hackbook it's booting to black screen, even witwith safe mode.

 

I'm using Yosemite and I've looked up the various errors in verbose to find solutions, some point to system disk having a corrupt table but im not sure.

 

Please see my screenshots to help me understand what's going on with my system, I really need to do some work on my hackbook today. I'm away from home and it's the only computer I have to use.

 

Thanks for readingpost-71863-0-68978900-1487557558_thumb.jpgpost-71863-0-68978900-1487557558_thumb.jpg

post-71863-0-20112600-1487511660_thumb.jpg

post-71863-0-03212800-1487511683_thumb.jpg

post-71863-0-24341300-1487511702_thumb.jpg

post-71863-0-86529600-1487511715_thumb.jpg

post-71863-0-36514500-1487511744_thumb.jpg

post-71863-0-39211800-1487557585_thumb.jpg

Link to comment
Share on other sites

@ Jake Lo, updated signature , thought I had that already , my bad .

 

Optimus has always been disabled but I tried to boot with it enabled but still no boot, see screenshot 6 for error, booted again with Optimus disabled as it was before and I've got different errors to the ones I originally posted in this topic. I seem to be getting errors opening that kext that troubles me before "can't open cf bundle RTL8192SU8.KEXt screenshot 7. Should I rebuild cache and repair permissions again ?

Link to comment
Share on other sites

@ BronXTeck

I did a repair permissions & rebuild kernel cache from single user mode (I have no USB boot drive ) with no success. I got errors as before. As you'll see in my screenshot I got errors "invalid signature" on many kexts along with "can't open cf bundle for S/L/E/*kext"

 

Then I tried the repair and rebuild CMD again but with the last line of the CMD to -f -update volume / and got some different errors as you can see from screenshots. Alot of "*.kext/ is in hash exception list" along with many invalid signature's for kexts, finishing with "bash/etc/RC.server no such file or directory"

 

And I always have an error "boot cache size is larger than physical memory"

 

Apologies for bad format of my post I'm uploading and writing this from my phone.

post-71863-0-42673200-1487632822_thumb.jpg

post-71863-0-51087000-1487632877_thumb.jpg

post-71863-0-13673500-1487633116_thumb.jpg

post-71863-0-51407100-1487633141_thumb.jpg

post-71863-0-69299000-1487633164_thumb.jpg

Link to comment
Share on other sites

Apologies for extremely late reply! Its been one of those weeks :-)

 

After repeated attempts i got it. 

 

At first i couldnt disable SIP from terminal from single user mode. I kept on getting errors, so i tried to have some luck booting to desktop with safe mode, and after some time i got it, disabled SIP from Terminal & the system has been booting fine since.

 

Thanks for your input, as always its much appreciated, and as always OSX Latitude community provides valuable support. 

Link to comment
Share on other sites

 Share

×
×
  • Create New...