Jump to content

E7470: various issues (wifi, audio, brightness) - Sierra 10.12.5


jerrywilborn
 Share

Recommended Posts

I've used the latest bootback and the card shows as 'matched' in ioreg but I'm still not seeing the card in the network settings. The Bluetooth portion of the card works fine, but no wifi.

 

I'm using 10.12.5, the card shows up in a dspci list:

01:00.0 Network controller [0280]: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03) (subsys 1028:0019)

 

I'm attaching my Clover setup and some info on the kexts I'm using.  Any guidance would be really appreciated.

E7470 Help.zip

Link to comment
Share on other sites

Unfortunately I can't.  I wish I had tried the card in Windows10 before I did the macOS installation.  I've gone thru your install instructions multiple times I feel like I’m missing something simple.

 

I’ve validated the BIOS settings as best I can (don't disable WiFi on ethernet connection, etc) and everything looks like it should be.

 

 

IgauQ3Y.png

Link to comment
Share on other sites

  • Moderators

Try booting to Clover GUI ->Options

ACPI patching -> DSDT name: Change it to BIOS.aml

Tables dropping -> Uncheck Drop all OEM SSDT, place check next to all the Drop "SSDT-xx.aml" below it.

Return to main menu and boot up OS X.

Note: This disables all the patched SSDT/DSDT.

See if Wireless show up.

  • Like 1
Link to comment
Share on other sites

Woohoo!!  Progress!!!

 

So the wifi now works great (was able to establish a connection and send traffic), but audio and brightness controls are not working.  Do you have a list of the DSDT patches you used to create your bootpack?  (Unless you know what I should edit in the bootpack DSDT?)

Link to comment
Share on other sites

  • Moderators

Are you on BIOS version 1.5.4?

Latest bootpack was based on that.

If that still doesn't work, then you'll have to patch all your SSDT/DSDT from your raw files exported through Clover menu - F4

Patches for DSDT are the following in this order:

  • rename HDAS to HDEF
  • Rename HECI to IMEI

From Rehabman github

 

  • _DSM to XDSM
  • HDEF layout1
  • GFX0 to IGPU
  • Mutex
  • HPET Fix
  • IRQ Fix
  • OS X Check Fix (Windows 2013)
  • RTC Fix
  • LPC Skylake
  • USB 3.0 _pwr 0x6D Skylake

Finally add this for graphics + menu glitch fix

# Use this patch if your laptop has Skylake HD 520 graphics#
into method label _DSM parent_adr 0x00020000 remove_entry;
into device name_adr 0x00020000 insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
    If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n
    Return (Package()\n
    {\n
        "AAPL,ig-platform-id", Buffer() { 0x00, 0x00, 0x16, 0x19 },\n
        "hda-gfx", Buffer() { "onboard-1" },\n
        "model", Buffer() { "Intel HD 520" },\n
        "AAPL,GfxYTile", Buffer() { 0x01, 0x00, 0x00, 0x00 },\n 
    })\n
}\n
end;

You'll need to patch the SSDTs without the xx after the numbers as well, place them in the patched folder along with SSDT-PNLF.aml included in my bootpack. Change the Config.plist SSDT sort order accordingly with the new SSDT-xx.aml

Link to comment
Share on other sites

Hey Jake -- thank you for that.  I validated that I'm on BIOS v1.15.4 (released by Dell May 2017).  Instead of jumping in on the patching I'm first going thru a diff of the extracted system DSDT and comparing to a decompiled version of the one in the bootpack.  I'm thinking that I'll have to end up rolling my own DSDT/SSDT because the brightness controls don't work quite right after sleep and I'm pretty sure it's related.

 

I'll post my results!

Link to comment
Share on other sites

Been tinkering with this thru the weekend.  I attempted to apply all DSDT and SSDT patches but I couldn't ever get it to go to the second stage.  I was able to get it booted by doing the following:

 

All of your patches against DSDT *except* the 'GFX0 to IGPU' patch.  When I attempted the GFX0 patch with Maci it never gets to the 2nd stage of the boot.  It gets to the end of the first stage and the screen scrambles and it hangs.  I patched GFX0 via the Clover rename.  I did not do any SSDT patching and I'm using the OEM SSDTs (not using your SSDT-PNLF).

 

My questions...

 

1. What fix were you performing via the SSDT(s) (and SSDT-PNLF)?  It looks like more GFX0 renames for the standard SSDTs.

2. The brightness slider is weird. It toggles between "OFF/ON" (when you get about 80% down the slider goes off, then goes back on when you put it to max) until the first sleep. After the first sleep it slides as you'd expect incrementing brightness normally. If you have any ideas I'd love to hear them (otherwise it's more DSDT debugging).

Link to comment
Share on other sites

 Share

×
×
  • Create New...