Jump to content

E6230 with i3-2350M @2.3GHz HD3000: issues installing El Capitan


eldide
 Share

Recommended Posts

Hi - 

 

Very new to this. I have created a hackintosh in the past on a D630. I have just got a E6230 and I would like some help if possible. 

 

I have been trying for the last week installing El Capitan on it, with no luck. I have followed several guides, the nearest I have got is it installed and then when I try and boot up it hangs at FramebufferCapri is duplicate. 

 

The difference I'm seeing is that most of the guides for 6230 are for i5 or i7 with the HD4000. Mine has the HD 3000. 

 

I have followed this thread : https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-precision-clover-guide/&do=findComment&comment=58699

and this one : https://osxlatitude.com/index.php?/topic/8883-dell-latitude-e6230-with-i5-3340m-hd4000-and-1366x768-lcd-mavericksyosemiteel-capitansierra/

with no luck at all. 

 

Does anyone know of a sound guide for El Capitan for the above spec. Any help would be gratefully appreciated. 

 

Thanks in advance,

Charles

Link to comment
Share on other sites

  • Administrators

Those guides are for IvyBridge CPUs with HD4000 graphics. As such, it should be no surprise that they're not fully applicable to your model since it's apparently a SandyBridge i3/HD3000 model. We haven't seen many of those around here.

 

The overall OS X/macOS installation process remains the same but the patched DSDT and/or graphics settings posted in the guides clearly apply to HD4000 graphics not to HD3000. You must therefore adjust the graphics settings to, say, those described in the E6220 guides. Lookup Rehabman's laptop patches repository as well. I think there are specific DSDT patches for SandyBridge on Series 7 chipset.

 

What's your exact CPU model? It should be listed in BIOS System Information.

Link to comment
Share on other sites

  • Administrators

Ok, so it's indeed a SandyBridge CPU. You therefore need to adjust the graphics settings as mentioned earlier. Please note that there is no Turbo boost mode on this i3 CPU (which is often the case on these entry level CPUs)

https://ark.intel.com/products/53438/Intel-Core-i3-2350M-Processor-3M-Cache-2_30-GHz

 

Post a zipped copy of the DSDT + Clover config.plist you're currently trying to use and we'll try to do the needful, i.e. inject the correct laptop SNB/HD3000 layout (and remove the HD4000 layout injection). You'll also have to remove and CPU power management SSDT not meant for your i3-2350M and re-generate the appropriate one with Pike's usual tool.

Link to comment
Share on other sites

Hi - 

 

Firstly big thanks for all the support its really appreciated and needed !

 

Herve - Attached are the files you requested. It's basically the same as what Jake Lo linked above. 

 

Jake Lo - I cleared down the EFI folder, copied over the default baseline (again) and then added the HD3000 bootpack linked above. However when I reboot now (with -v) it gets so far and then the text becomes garbled and a no entry sign appears. I tried changing the model in the config from 8,2 to 8,1 - as i read somewhere that might be it. but no luck. I've attached a screen shot. 

 

in the BIOS I've got A11 installed, all defaults apart from

   -   set SATA to AHCI. 

   -  boot set too UEFI

 

Cheers,

Charles

config_DSDT.zip

post-109265-0-36541700-1496484589_thumb.jpg

Link to comment
Share on other sites

 Share

×
×
  • Create New...