Jump to content
itsworking

E6410 Nvidia Sierra 10.12.6 no wake from sleep, help

Recommended Posts

Hello,

 

Installed Sierra 10.12.6 on my E6410 with Nvidia 3100m and arrandale i5. 

 

Laptop sleeps but fans keep on, whatever I do I can't wake the laptop from sleep.

 

I use latest USBInject.kext, ECHx to ECH0x via config.plist, have edited _WAK in DSDT,

bumped up to Windows 2009 in DSDT manually (\OSI). 

 

See enclosed DSDT and config.plist, I realize that VoodooHDA is still in there.

 

​Have also enclosed bdmesg.log and have loaded AppleLPC by adding the id in the kext,

but in bdmesg.log it says:

 

38:914  0:000  Start LPCB Fix

38:914  0:000  found LPCB device NAME(_ADR,0x001F0000) at 2B5E And Name is LPCB

38:914  0:000  NewName LPCB already present, renaming impossibble

38:914  0:000  _DSM already exists, patch LPC will not be applied

 
Could this cause problems, how should I fix this?

 

Any help is appreciated, regards,

 

Itsworking (almost)

 

 

e6410-nowake-dsdt-config.zip

Share this post


Link to post
Share on other sites

Try the attached.

 

* DSDT mods done:

  1. combined both _DSM methods of LPCB device into a single one
  2. _PWR methods of GLAN/HDEF/EHCx devices changed from returning (0x0D,0x04) to (0x0D,Zero)
  3. removed "If" tests in _PWR method of EHCx devices to keep a single "Return" statement

NB: It would be interesting to know what mods you made to the _WAK method.

revised_DSDT.aml.zip

 

* Clover config mods done:

  1. removed all selected ACPI fixes
  2. removed USB FixOwnership option 
  3. injected proper MBP6,2 SMBIOS

revised_Clover_config.plist.zip

Share this post


Link to post
Share on other sites

Thanks for the fast reply!

 

Tried it, and the laptop becomes quiet when sleeping, only the power button stays steady on.

AppleLPC is loaded and no more LPC in the bdmesg.

 

Can't get the machine to wake, if I push power button for 5 seconds the fan turns on, nothing more.

 

I patched _WAK by adding the if-line below:

 

Method (_WAK, 1, NotSerialized)  // _WAK: Wake

    {

        If (LOr(LLess(Arg0,1),LGreater(Arg0,5))) { Store(3,Arg0) }

        EV2 (Arg0, Zero)

        AWAK (Arg0)

        Return (Zero)

    }

 
Furthermore, I see the following when going to sleep in the system.log:
 
Aug 19 15:24:06 MacBook-Pro-de- StatusBarApp[388]: goingToSleep  ==>

Aug 19 15:24:06 MacBook-Pro-de-StatusBarApp[388]: goingToSleep  <==

Aug 19 15:24:06 MacBook-Pro-de-loginwindow[95]: objc[95]: Class TIMLog is implemented in

 both /System/Library/CoreServices/Menu Extras/TextInput.menu/Contents/SharedFrameworks/TextInp

utUI.framework/Versions/A/TextInputUI (0x10f518858) and /System/Library/CoreServices/Menu Extra

s/TextInput.menu/Contents/SharedSupport/TIMCore.bundle/Contents/MacOS/TIMCore (0x10f4f5b10). On

e of the two will be used. Which one is undefined.

Aug 19 15:24:06 MacBook-Pro-de com.apple.xpc.launchd[1] (com.apple.imfoundation.IMRemote

URLConnectionAgent): Unknown key for integer: _DirtyJetsamMemoryLimit

Aug 19 15:24:07 MacBook-Pro-de-com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.us

er.501): Service "com.apple.xpc.launchd.unmanaged.loginwindow.95" tried to hijack endpoint "com

.apple.tsm.uiserver" from owner: com.apple.SystemUIServer.agent

Aug 19 15:26:33 localhost bootlog[0]: BOOT_TIME 1503149193 0

 

And at 15:26 I was pushing the power button for 10 seconds to turn the laptop off and

then for power on.

 

I also see the following in the log:

 

Aug 19 15:28:44 MacBook-Pro-de-StatusBarApp[371]: U2U3_MacOSX 10.12.6

Aug 19 15:28:44 MacBook-Pro-de-StatusBarApp[371]: FindUSB30 - Check USB host controller

Aug 19 15:28:44 MacBook-Pro-de-StatusBarApp[371]: FindUSBHost30:: findTask sleep

Aug 19 15:28:44 --- last message repeated 3 times ---

Aug 19 15:28:44 MacBook-Pro-de-StatusBarApp[371]:        0

Aug 19 15:28:44 MacBook-Pro-de-StatusBarApp[371]: FindUSBHost30:: num(0), bFind(0)

Aug 19 15:28:44 MacBook-Pro-de-StatusBarApp[371]: U2U3_Get USB3.0 Error

 

Is this a problem?

 

Furthermore, I use a WLAN usb dongle, could that one prevent sleep?

Or the RtlWlan*kext kext which were installed in S/L/E by the dongle software?

 

Should I delete as much as possible kext in the CLOVER/kext/10.12 such as AppleIntelE1000e?

 

Any hints or help is appreciated, if I should post more logging let me know, regards,

 

Itsworking (almost)

 

 

 

 

 

Share this post


Link to post
Share on other sites

hmm... should your _wak method also return a wake argument of 1 looks like you only specified Arg0 with is sleep Arg1 would be wake or am I wrong on that? maybe an an if statement like

AWAK (Arg1)

        Return (One)

Share this post


Link to post
Share on other sites

Silly question probably but did you disable hibernation?

 

Re: wifi USB dongle, it should not be a problem as long as you do not enable "USB wake" in BIOS". Make sure it's the same for LAN: no "Wake on LAN". Your kexts are Ok.

Share this post


Link to post
Share on other sites

First of all, thanks for your replies.

 

1) Linux extract of DSDT.aml _WAK shows:

 

Method (_WAK, 1, NotSerialized)  // _WAK: Wake

    {

        \EV2 (Arg0, 0x00)

        \AWAK (Arg0)

        Return (0x00)

    }

 

So my patched _WAK is ok...

 

2) pmset -g shows hibernatemode        0

 

So hibernate is disabled... I can't set it in BIOS.

 

Besides the above, my power button does not start to blink when going to sleep,

any ideas?

 

Comments and suggestions are welcome, regards,

 

Itsworking (almost)

Share this post


Link to post
Share on other sites

The only other thing I can think of is CPU power management. Does that work Ok?

 

To me, if the power led does not fade in and out, your computer has not gone into sleep mode.

Share this post


Link to post
Share on other sites

Thanks for the reply.

 

All pm related kexts are loaded:

 

kextstat | egrep -i 'applelpc|appleintelcpu|acpi_smc|acpiplat'

   13    2 0xffffff7f82cd1000 0x60000    0x60000    com.apple.driver.AppleACPIPlatform (5.0) 65E05472-6AE7-3308-8CC8-FA6CB0DB2AEE <12 11 7 6 5 4 3 1>

   24    0 0xffffff7f82b84000 0x2b000    0x2b000    com.apple.driver.AppleIntelCPUPowerManagement (219.0.0) F7CC3395-98DB-3420-9C24-1017D52E13AE <7 6 5 4 3 1>

   34    0 0xffffff7f82b7f000 0x3000     0x3000     com.apple.driver.AppleIntelCPUPowerManagementClient (219.0.0) B802638B-251C-3602-BA8C-001F87228765 <7 6 5 4 3 1>

   90    0 0xffffff7f82aa0000 0x3000     0x3000     com.apple.driver.AppleLPC (3.1) F51595F0-F9B1-3B85-A1C3-F984DAD4107E <89 12 5 4 3>

   96    0 0xffffff7f821d8000 0x10000    0x10000    com.apple.driver.ACPI_SMC_PlatformPlugin (1.0.0) 5D441A20-E42C-313C-BF80-6894AAAE0DFA <95 93 89 12 11 7 6 5 4 3>

 
See attached Speedstep HWsensor image in pdf.
 
Speedstep seems to work.
 
But somehow the call to _PTS sleep does not result in a blinking power button.
 
Should I look in IOPlatformPluginFamily? X86platformplugin?
 
Is there any other log/program I should see?
 
Any hints are appreciated, regards,
 
Itsworking (almost)

Speedstep-e6410.pdf

Share this post


Link to post
Share on other sites

Hi,

 

Have been debugging DSDT lately.

 

Under Windows 10 the machine sleeps with blinking light and wakes correctly.

 

Problem is that under Sierra 10.12.6 it goes to sleep WITHOUT blinking light and can be only waked up

by pressing the power button 10 seconds (power off) followed by cold start by power press.

 

Did put debug statements in dsdt attached, but never see _PTS, it hangs beforehand?

Is there any way to debug what's happening after choosing Sleep upto _PTS?

Any hints are. appreciated, 

 

Regards,

 

Itsworking (not)

DSDT-revHVO.aml.log.debug.txt

dsdt.zip

Share this post


Link to post
Share on other sites

@itsworkingI know this is an old thread, but I'm thinking of using your DSDT debugging technique to resolve the sleep issue on my Latitude E6410 running Mojave10.14.5. The only thing not working on my Latitude E6410 / Mojave is sleep - everything else is perfect as far as I can tell.  When you observed that you "never see _PTS," did you try your test with and without the AC adapter connected?  I have made some progress on my Latitude E6410 DSDT mods to fix sleep and found that the behavior is different when the AC adapter is connected and when the laptop is running on battery.  With my DSDT mods, my laptop "shuts down" when it sleeps and is on battery power (which is closer to sleep than freezing with the power light on).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...