Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 05/06/20 in Posts

  1. 2 points
    As @arsradu suggested, just update to latest Clover and update the kexts to the latest. If you have 3rd party kexts in /L/E make sure to update those as well, repair permission and rebuild cache. See if it still boots. If no issue, then continue upgrading. For sure you'll need a minimum of Clover v5107 to boot 10.15.4. I would recommend just upgrading to the latest v5118 at the time of writing this.
  2. 2 points
    While the EM7430 works with my kext. (I guess the product ID needs to be adjusted still). The EM7455 seems not. What I did: Wrote the kext for DW5811e / EM7411 according to the correct PID & VID attached above. Which after it appears on WANN section (location id show xxxxxxxx / 0 as others also have in their screen). Then with the correct APN the error shows: So I updated the firmware and all config settings using LIVE UBUNTU CD 18.04 with: https://github.com/danielewood/sierra-wireless-modems His autoscript is perfect for updating FW, configuring the whole card according to our needs & sets the PID/VID to generic to bypass any vendor locks. Whilst I updated the kext to reflect all MC/EM7455 cards PID/VID (Lenovo / DELL / Generic). Still the error "Network Connection ... " shows. Please also see the location difference: NOTE the firmware: SWI9X30C_02.08.02.00 r5428 CARMD-EV-FRMWR2 2016/01/06 20:38:53 While at!priid? shows the updated firmware: SWI9X30C_02.33.03.00_00_00_GENRIC So I manually check the connection using COM port: screen /dev/tty.wwan 115200 screen /dev/tty.wwan 115200 Which after I'm able to manually connect using at commands. Any ideas where to look? Perhaps it is the interface mapping? <key>InterfaceMapping</key> <dict> <key>0</key> <dict> <key>name</key> <string>wwanDM</string> </dict> <key>2</key> <dict> <key>name</key> <string>wwanGPS</string> </dict> <key>3</key> <dict> <key>name</key> <string>wwan</string> </dict> </dict>
  3. 2 points
    If you had been patching your own DSDT recently, you most likely encountered this common error dialogue when clicking on the 1st 2 errors, they'll take you to these set of codes To fix the errors, I created this patch which you can just apply with latest version of MacIASL This will fix all 3 errors listed above. Enjoy!
  4. 1 point
    Correct, with WEG and FB patch, they will bypass the error, but for that to work the FB kext must be cache for the FB patch to patch during boot. Usually with fakeID and / or -igfxvesa should be enough to get your installer to continue. You could try adding additional boot arg -disablegfxfirmware
  5. 1 point
    Still errorring out at graphics and seeing that -igfxvesa is not working, you could try going into Clover /Option/ graphics Injector and enable fakePCI / platform-ID = 0x12345678
  6. 1 point
    the boot arg from the screenshot is different from your Config file so not sure if you change it during boot or you're booting from another set of EFI files. From the KP, looks like it's related to graphics. Try boot with arg -igfxvesa As for your kexts, you can remove AppleBacklightFixup.kext (part of WEG now) Remove SMCHelper.efi from drivers/UEFI, you have VirtualSMC.kext. SMCHelper.efi is paired with FakeSMC.kext Once you're able to boot with -igfxvesa to complete the installation. rebuild cache. You should then be able to boot without that arg
  7. 1 point
    The techniques detailed there and in the linked guides applied to Intel framebuffers from Sandy Bridge to Broadwell. They ceased to apply to Intel framebuffers from Skylake onwards because Apple totally changed the way in which they define framebuffer layouts in the kexts. The connector types remain the same of course. If you want to change port types, you'll have to identify the connected ports in IOReg and patch them through Clover Device Properties injection for instance. By far, it's the easiest way to do it. You'll find examples in most packs available in the guides posted for Skylake/Kaby Lake/Kaby Lake Refresh/Coffee Lake Hackintoshes or those posts/threads were such patching was discussed. Here or here for instance. [email protected] translates to con0 [email protected] translates to con1 [email protected] translates to con2 etc. and the parameter you'll want to change for connector types will be type So, to change connector-type of [email protected]<x> to DVI, you'll inject: Key: framebuffer-con<x>-type Value: 04000000 Type: Data And activate framebuffer patching: Key: framebuffer-patch-enable Value: 01000000 (or just 1) Type: Data (or just Number)
  8. 1 point
    E7440 comes with an Alps touchpad, you'll need Dr. Hurt's version of VoodooPS2Controller. You can omit AppleBacklightFixup, it's been added to WEG for sometimes now. Omit BrcmFirmwareRepo, it's meant to be cache in /L/E, you already have BrcmFirmwareData.kext in clover kext. One or the other, not both. For audio, you can try the alc_fix linked in my E7440 guide here
  9. 1 point
    I'm sure you did, and I have a guess as to where you might have seen them. Having all the kexts in EFI/Clover/kexts/Other is easier to manage, and you can keep the system intact. Also, if I'm not mistaken, during the update, you rely entirely on the EFI partition. So...if you don't have your mandatory kexts there, you can't boot. Easy as that. Update: I don't know, man. I never had any issues having all the kexts in Clover/kexts/Other. Also, because of that, I have no such errors when I try to rebuild caches. And I don't wanna keep VirtualSMC/FakeSMC in EFI and everything else in other places. It's just not organised this way. And I tend to forget which kexts I have where. So I just have them all in one place. Easier this way.
  10. 1 point
    Basically, you're trying to cache VirtualSMC and it appears unsupported/incompatible with your Hack for whatever reasons (kext version, bootloader config, applied patches, etc.). I'd switch to FakeSMC instead (and ACPIBatteryManager of course). And you appear to have the same with WEG. You really need to update your add-on kexts to latest versions before you upgrade to Catalina! You're right to cache your kexts from /L/E.
  11. 1 point
    Forget about the laptop, have you seen the view? How can I get a house in the trees? I'd love that! I love nature. Anyway, yeah, congrats on the build. Looking good!
  12. 1 point
    Ok, let's confirm. You have these 3 kexts added to /L/E only and not in clover/kext/Other BrcmBluetoothInjector.kext BrcmFirmwareRepo.kext //make sure it's this and not BrcmFirmwareData.kext BrcmPatchRAM3.kext Run Hackintool again to rebuild the cache Reboot and check again. If it's still showing firmware 4096, then you have a caching issue.
  13. 1 point
    Where are you updating from? In theory, if everything is correctly configured, and if you're not upgrading from Yosemite to Catalina or some really old version of MacOS, then yeah...it should work pretty smoothly. What I would recommend is just making sure the following things are up to date: 1. Clover (here's the official place to download it from) 2. drivers and kexts (you can use Clover Configurator to update those) Also, before anything, copy your existing EFI folder to the EFI partition of a USB drive for safe keeping. This way, if anything happens with the Clover update, you still have a backup. When you're done updating Clover and kexts, before starting the upgrade to Catalina, try to see if you can still boot your current installation with updated files. If everything ok, download the update directly from your current version of MacOS, or make a bootable USB drive with Catalina on it and try to install it. In case the updated EFI folder is still ok, you can add that to your USB, as well.
  14. 1 point
    NB: No need to quote on your replies, just go to reply when you respond. Ok, now regarding BT. Go to system information, check Bluetooth. Look at the Firmware version. If it's 4096, then that mean the firmware kext is not loaded. If this is the case, then remove BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext, and BrcmPatchRAM3.kext from clover kext Add BrcmBluetoothInjector.kext, BrcmFirmwareData.kext, BrcmPatchRAM3.kext to /L/E instead. Repair permissions and rebuild cache. Check the firmware again Test BT again if firmware is anything but 4096.
  15. 1 point
    For wifi, add these kexts to clover kext Lilu.kext AirportBrcmFixup.kext For BT, add these kexts to clover kext BrcmBluetoothInjector.kext BrcmFirmwareRepo.kext BrcmPatchRAM3.kext
  16. 1 point
    Oook... Kexts folder... As I told you, you have 2 Ethernet kexts. Please, remove IntelMausi.kext and IntelMausiEthernet.kext, download the one above, and place it in Clover/kexts/Other. Also, make up your mind. Are you using FakeSMC or VirtualSMC? :)) You should not be using both. So please, remove VirtualSMC from your kexts, for now. Let's use FakeSMC. You're using a bunch of kext (probably normal for a laptop). I can't help you with those, since I don't know exactly what they do, or if you really need them. Drivers folder... Again, make up your mind. You want FakeSMC or VirtualSMC? If you want FakeSMC, then please, remove VirtualSMC.efi from your drivers. Also, you're disabling VboxHfs in config, but you don't even have it in your drivers folder... So...what are you disabling? ACPI/patched folder... About sound...we can discuss that after we get your computer booting. Looks like you're using some custom SSDT but also AppleALC kext... Which I'm not sure are supposed work together. So...maybe try without the SSDT and let AppleALC do its job. You can just place that SSDT-ALC292.aml outside the /patched folder, if you don't want to delete it. Also, you've got a LOT of SSDTs... Do you need all of those? I see some of them which seem to be for renaming USB (from EHC1 to EH01 and EHC2 to EH02)? I could be wrong. But...if that's what they're for, that can be easily achieved from config (and it looks like you already set it there, too!)... I think one place is enough! No need to do it from SSDT and also, config. Also, you seem to be using a patched DSDT along with (probably also) patched SSDTs. Which is never a good idea. Either you put everything in one patched DSDT and basically make sure everything you need IS already included there. Ooor...you just add your custom SSDTs for the stuff you need and let the original DSDT do its job. In this particular case, I don't even know what to recommend you... See? This is exactly why you don't just download EFIs without understanding what's inside them. Personally I would move that DSDT out of the way, as well and test without it. Config.plist... About the iGPU, looks like you're adding device properties (including AAPL,ig-platform-id) from config. So...do you still need ig-platform-id in Graphics and Inject Intel ON? I'm not sure... I'd say probably not, but again, it could be a laptop thing. Also, in config -> System Parameters, if you don't load your kexts from S/L/E, you can set Inject Kexts to Yes instead of Detect. And, to be honest, I would recommend using all your custom kexts from EFI, rather than L/E or S/L/E. Why? Because you tend to forget about them, and then you'll have duplicated kexts and not knowing where do they come from. So...keep it all in EFI. It's a lot easier to manage, in my opinion. Once you're done making these changes, try again. About OC...I'm not using it on a laptop, but I think it does work. However, it's a lot different than Clover. And...I would suggest reading and understanding everything before diving nose first into it. Cause it might hurt. If, however, you wanna give it a try, a few things I wanna tell you: 1. know your hardware! This is incredibly important. Especially on a laptop! Laptops are notoriously harder to hackintosh, due to their different hardware and implementations. 2. make a backup of your current, working EFI folder! 3. when you're done with that, make ANOTHER backup to the first backup, and then one more, just for good measure. I'm not kidding. Well, ok, I'm half kidding. But believe me. You're gonna thank me later. Make sure you always have a working USB drive you can boot from. 4. take your time to read! This is not gonna be a walk in the park. You need time and patience. With that being said, here's an awesome guide to get you started. It's still a very technical text, but it's a lot easier to read and understand than other similar documents on OC. 5. OC doesn't have an installer. And I'm not sure if it will. Maybe some day. But until then, everything you do is directly operating inside that EFI folder. If you still wanna do it, I wish you good luck!
  17. 1 point
    Up until this time last year, I had a Latitude E6440, a Haswell laptop fitted with HD4600 iGPU and AMD dGPU. The AMD dGPU was not supported and therefore disabled via DSDT/SSDT patching. There never was anything to be done on the iGPU front regarding performance per sé. Booting off the mSATA SSD was just about the same as with any other of my Hacks: ~20s from start to finish. I'm a little surprised to read that, on your Haswell desktop, enabling the HD4600 iGPU increases your boot time by almost 20s. I can't say ever heard of such an impact before. Did you try and analyse what happens at boot time through verbose mode when iGPU is on? Other than my Sandy Bridge Latitude E6220 and it's crappy HD3000, I find no particular performance issue on my other laptops running iGPU: whether it'd be my Ivy Bridge Latitude E6230 and its HD4000 iGPU or my Kaby Lake R Latitude 7490 and its UHD620 iGPU. Same applied to the Broadwell Latitude E7250 + HD5500 iGPU I had for a brief spell.
  18. 1 point
    Hi @arsradu, yes we're aware of this recent issue and we're trying to solve this.
  19. 1 point
    As stated in our March 2020 news article, 10.15.4 breaks XCPM capability. If you used that, revert to good old CPU-specific power management SSDT generated by Pike R Alpha''s well-known generator script. Revised Catalina pack #2 provided to that effect. But, as suggested by @Bronxteck, XCPM should be back with Clover r5117 or above. I certainly verified this with r5118. Clover_r5118.pkg.zip
  20. 1 point
    Broadcom BCM43224 14e4:4353 is subject to whitelisting: And, very obviously, those DW1820A-related injected properties do not apply to your Apple card so remove them. It's always essential to pay attention to full computer's hardware specs, especially when re-using someone else's config files...
  21. 1 point
    Replace VoodooPs2Controller with the attached. There's 2 or more model of webcam on the Dell systems: Sunplus and Sonix It should be working OOB, if not then it's not supported..usually the Sonix is not supported. Looks like you don't have the SD card reader enable. You can enable it by renaming #Properties under Devices to Properties by removing the # SD card reader is under PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0,0x0). You can disable the rest by adding # infront of them. As for you Atheros wifi, see here https://osxlatitude.com/forums/topic/11138-inventory-of-supportedunsupported-wireless-cards-2-sierra-catalina/ VoodooPS2Controller.kext.zip
  22. 1 point
    Where did you add the kext? If you had added to /L/E, did you repair permissions and rebuild cache? How did you add the layout-id? with what app? Perhaps you had corrupted the Config file if you're using a text editor instead of using Clover Configurator, Xcode or Plist edit Pro. At clover, add boot arg to determine the boot issue -v debug=0x100 Post your Clover folder if you want us to help you determine the issue
  23. 1 point
    You may adjust the port type definitions in the tool if required. Apart from that, it's that simple, yes.
  24. 1 point
    Use Hackintool.app to generate your ports.
  25. 1 point
    Use Lilu + AppleALC.kext with layout-id = 11
  26. 1 point
    Please specify full system specs and attach your clover folder You can try adding these boot arg to determine where it hang -v debug=0x100
  27. 1 point
    boot with verbose + debug 0x100 + -igfxvesa mode -v -igfxvesa debug=0x100 Post KP when you encounter it
  28. 1 point
    Have you enabled the battery indicator inside of the MacOS so that it shows in your status bar? It's in settings. Then it shows up. There is a bunch of meticulous troubleshooting you get to do when knocking out each thing. The reason is that everything is NOT loaded into Clover Other/Kexts. Only the skinniest number of them are once you close in on finishing your build. The majority end up in the /Library/Extensions (/L/E) inside your build. After you test the kext, I then moved over into /L/E. It's a step by step thing. After moving, then in Terminal, you use the kextcache -i / command to rebuild the /L/E cache each time. Now, other people say to just ignore this method and leave it all in the Clover Other/Kexts and don't mess with the caching from /L/E loading. This seems to be a great debate online. Rehabman over on another forum (a google search will find his homebase) says to use the caching from /L/E method because of some troubleshooting advantages, so that is what I followed. Here is my /L/E folder. Here is my Kexts/Other folder. It has been a fun project, kind of like a 1000 piece jigsaw puzzle putting it all together. Guys like you and I like such brain twisters, along with everyone else on this forum. I would like to believe that this is more of the motivation of doing a project like this during the lockdown. I have the money to go just buy a macbook, but this has been a fun challenge. I wish I could say that it is at 100%, but there are still some oddities. Like the battery indicator sometimes does the countdown from 100% to 0%. Sometimes it stays at 100%, then shuts down without a warning. Other times it does what it should. But it dies at about 17%, it never gets to single digits. I just attributed it to the fact that your T470s has two batteries inside of it, a big one and a small one. I get about 2.5hrs on a charge. I wish it was longer. I have the same Lenovo T470S for my day job issued to me by my company running Win10, and it sure seems to last longer that 150 minutes. I also still get a random non-boot situation that I can't explain. I have to go into the Clover bootloader at the beginning of a boot and use safe mode boot, then I get in and it is fine again for awhile. I can't explain this random fail yet. But for now it mostly all works.
  29. 1 point
    ULTRACORE, These are the bios settings I used.
  30. 1 point
    what? the Intel wifi? You can follow the status linked above https://github.com/AppleIntelWifi/adapter
  31. 1 point
    Give this a try config-gemini.plist.zip
  32. 1 point
    Yes, but you have to have 2 things: EFI partition = 200MB or more (windows default is 128MB, verify it, expand if necessary) Must have GUID formatted drive (Windows might be formatted to MBR - you'll need to convert it) I won't be able to help you with any of the 2 requirements, you'll have to figure that out yourself with google or whatever way you know You can try cloning Windows to another drive, format your disk to the requirements above, create 2 partitions and then restore Windows to the second partition and install MacOS to the 1st.
  33. 1 point
  34. 1 point
    Catmater, I have the same laptop as you. I have clover bootloader with Catalina working good on it too. Was going to try OpenCore when I stumble upon this post. Post any updates if you can.
  35. 1 point
    Check FAQ. Catalina has extra protection that needs to be disable 1st
  36. 1 point
    Yes, it should auto switch from Internal to Headphone and vise versa if headphone is inserted and remove. The kextcache log and IOReg file you attached in the debug file shows no existence of CodecCommander.kext. Google for the kext and install it to /Library/Extensions Repair permissions and rebuild cache. If that still doesn't work, change the layout-id in Config file under devices/properties from 12 to 18. No, as you can see in your system information under display, you'll see both graphics. It's also showing in your IOReg file. Try adding boot arg -wegnoegpu to Config file If that doesn't work, we'll need to disable it via DSDT/SSDT patching
  37. 1 point
    Conflict in your Config and DSDT file. Here's the fixed files. Not sure if sleep will won't on dual graphics enabled. Will have to check with the OP. In your kext/Other folder you have 2 USB kexts, USBPorts and USBMap. Should be one or the other, not both. But looking at USBPorts.kext, it's not config for this system, it's hardcoded to IMac14,2. M6800_audio.zip
  38. 1 point
    Just to be sure, you're following the Catalina guide for Catalina, right? Because your initial link pointed to the Mojave guide. Would I be right to assume that you're installing Catalina 10.15.4? I might need to revisit Catalina's installation guide given that there were many issues with the 10.15.4 update. Will try a fresh 10.15.4's installation on the 7490 to see...
  39. 1 point
    Hello! Installed Catalina 10.15.4 on my Latitude 5400 i7-8665U with UHD 620 Graphics after installation trackpad and right/left click are working fine. Installed clover and copied EFI then reboot, after reboot trackpad is not working. and I've also got a DW1560 wifi adapter, WiFi is working but I can't make the BT working. copied below kexts to /L/E using hackintool BrcmBluetoothInjector.kext BrcmFirmwareRepo.kext BrcmPatchRAM3.kext Please help. EFI folder attached. EFI.zip
  40. 1 point
    This is a recurring question from many people who want to create an OS X/macOS USB installer but neither have a Mac nor a Hack to do this. They only have Windows and a VM can be a little daunting or not successful. Thank fully, there are tools that can be used from Windows to obtain the desired Graal! We can recommend the 2 x following tools: 1) TransMac https://www.acutesystems.com/scrtm.htm 2) Boot Disk Utility http://cvad-mac.narod.ru/index/bootdiskutility_exe/0-5 Those who know how to use Google may look up for tutos. Example: https://www.wikigain.com/create-macos-high-sierra-bootable-usb-installer-windows-10/
  41. 1 point
    Remove the 2 from /L/E, replace all to /E/C/K/Other Repair permissions and rebuild cache DW1550_BT.zip
  42. 1 point
    Generate P States and Generate C States are settings applicable to old C2D/C2Q/1st gen Core platforms only. They do not apply to Sandy Bridge platforms and beyond, including Broadwell platforms such as yours. In fact, if you call on these, you may find your CPU switching only between that low frequency you reported and the highest nominal frequency; all without Turbo boost and intermediate frequencies, which means CPU inefficiency and hammered performance. In order to enjoy proper CPU power management on your Broadwell Latitude laptops: either you apply/select/set/tick PluginType option in Clover ACPI section to which you may add Plugin Type=1. or you drop SSDT tables with ids CpuPm + Cpu0Ist in Clover ACPI section and generate your CPU-specific power management SSDT with Pike R Alpha's good old SSDT generator script; you'll then place the generated SSDT table in E/C/ACPI/patched folder. E7250/E7450 are fitted with low-power CPUs such as i5-5300U/i7-5600U and you should expect idle frequencies of 800MHz. If Intel datasheets do indeed indicate LFM frequencies as low as 500 or 600MHz, I'm pretty sure these are reserved for the programmable TDP-down/7.5W reduced power mode. In fact, if you download and install Pike R Alpha's complete tool and consult the data files for the Broadwell CPUs, you'll see this: # Broadwell mobile processor data. # gMobileBroadwellCPUList=( # # 5th generation Intel® Core™ i7 Processors (socket FCBGA1164) # i7-5950HQ,47,500,2900,3800,4,8 i7-5850HQ,47,500,2700,3600,4,8 i7-5750HQ,47,500,2500,3400,4,8 i7-5700HQ,47,500,2700,3500,4,8 # # 5th generation Intel® Core™ i7 Processors (socket FCBGA1168) # i7-5650U,15,800,2200,3100,2,4 i7-5600U,15,800,2600,3200,2,4 i7-5557U,28,800,3100,3400,2,4 i7-5550U,15,800,2000,3000,2,4 i7-5500U,15,800,2400,3000,2,4 # # 5th generation Intel® Core™ i5 Processors (socket FCBGA1168) # i5-5350U,15,800,1800,2900,4,4 i5-5300U,15,800,2300,2900,2,4 i5-5287U,28,800,2900,2900,2,4 i5-5257U,28,800,2700,3100,2,4 i5-5250U,15,800,1600,2700,2,4 i5-5200U,15,800,2200,2700,2,4 # # 5th generation Intel® Core™ i5 Processors (socket FCBGA1364) # i5-5350H,47,800,3100,3500,2,4 # # 5th generation Intel® Core™ i3 Processors (socket FCBGA1168) # i3-5157U,28,500,2500,2500,2,4 i3-5020U,15,500,2200,2200,2,4 i3-5015U,15,500,2100,2100,2,4 i3-5010U,15,500,2100,2100,2,4 i3-5005U,15,500,2000,2000,2,4 which lists CPU model, TDP, LFM, HFM, max Turbo, cores and threads. LFM frequencies of those CPUs fitted to our Latitude E7250/E7450 are therefore set at 800MHz, even though you may not encounter them much due to sustained minimum load under macOS. In the same respect, HD5500 iGPU of those processors typically clocks between 300 and 900/950Mhz. With regards to iGPU throttling, bear in mind that your Hackintoshes are not fitted with the same CPUs and iGPUs as those real Macs we fake them to be. For instance former are fitted with HD5500 GT2 iGPUs when latter are fitted with HD6000/Iris 6100 GT3 iGPUs. Not entirely the same thing...
  43. 1 point
    Built an Hackintosh Recently with the following Specs: Atermiter X79G motherboard 45$ Xeon E5-2650V2 ~50$ 64GB DDR3 ECC RAM Nvidia GT 710 graphic card: sanddisk 500GB SSD You can directly install Mojave without modifying anything in the bios... using this EFI.. But if you have to install/upgrade to Catalina 10.15.2, before installing or upgrading Disable Virtualization support - CPU configuration disable VTX-D - North bridge. Disable USB ECHI support Post installation you can enable them again. Had no issues with virtualization performance etc... Boots in less than 10 seconds. All working - except small static in AUDIO... (hardly noticeable, but goes away once you play something)... EFI_desktop.zip
  44. 1 point
    Catalina Catalina Guide Bootpack Replace into /EFI/Clover after you install Clover E7470_Catalina.zip E7270_Catalina.zip FYI, kexts in bootpack might be outdated Make sure to 1st upgrade kexts found under /EFI/CLOVER/kexts/Other if you encounter issue Common links for new kexts: https://github.com/vit9696/Lilu/releases https://github.com/vit9696/Lilu/blob/master/KnownPlugins.md https://bitbucket.org/RehabMan/ Note: 1) Post Install: Copy kexts in /EFI/Clover/kexts/Other/CopyToLE to /Library/Extensions. Repair permissions and rebuild cache 2) Enable this patch in Config.plist under KextsToPatch if you have: LiteOn, Plextor, or Hynix NVMe Hynix NVMe patch 10.13.x (Bit swap block size 0x10) -Syscl Finally we have support for SD Card reader (Realtek RTS525a). See here for more info and link to kext UPDATES Catalina 10.15.1 (19B88) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: INSTALL LATEST CLOVER / UPDATE KEXTS PRIOR TO UPDATE REPAIR PERMISSIONS AND REBUILD CACHE Catalina 10.15.2 (19C57) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: INSTALL LATEST CLOVER / UPDATE KEXTS PRIOR TO UPDATE REPAIR PERMISSIONS AND REBUILD CACHE Catalina 10.15.3 (19D76) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: INSTALL LATEST CLOVER / UPDATE KEXTS PRIOR TO UPDATE REPAIR PERMISSIONS AND REBUILD CACHE Catalina 10.15.4 (19E266) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: INSTALL LATEST CLOVER / UPDATE KEXTS PRIOR TO UPDATE REPAIR PERMISSIONS AND REBUILD CACHE Catalina 10.15.5 (19F96) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: INSTALL LATEST CLOVER / UPDATE KEXTS PRIOR TO UPDATE REPAIR PERMISSIONS AND REBUILD CACHE
  45. 1 point
  46. 1 point
    With Catalina 10.15, Apple went further into increasing the security of its OS and the system's/root partition is now locked upon system startup. One of the consequences is that, by default, /System/Library/Extensions folder (/S/L/E) is locked and can not be modified in any way. In the same respect, other reserved folders such as /usr/bin or /usr/sbin are locked too. This can be a problem for such situations where a vanilla kext has to be replaced in /S/L/E or a file of /S/L/CoreServices has to be patched. The trick is basically to mount Catalina's root partition in Read-Write (RW) mode instead of Read-Only (RO) mode. This can be accomplished through Terminal with the following command: sudo mount -uw / followed a restart of the Finder through Terminal command: sudo killall Finder or simply by relaunching the Finder from the Apple menu:
  47. 1 point
    Target macOS release: Catalina 10.15.x This is a Clover-based installation using the well-known/well documented vanilla method detailed below: Working: full graphics acceleration on Intel HD4000 graphics (with Lilu v1.3.8 + WEG v1.3.2) multi-display with HDMI OOB audio, including jack microphone input and headset output (with AppleALC v1.4.1 & layout 12 + CodecCommander v2.7.1) HDMI audio (with Capri Framebuffer patch) built-in GigEthernet LAN connection (with AppleIntelE1000e v3.1.0 or latest IntelMausiEthernet kext) wireless and bluetooth with any compatible card integrated webcam (OOB) full CPU power management, including Turbo boost (with CPU-specific generated ssdt) sleep (Lid, Energy Saver settings, Apple menu, Fn-F1, PWR button) & wake (Lid, PWR button) battery management (with ACPIBatteryManager v1.90.1) SD card reader (with DSDT patch for compatibility with Apple's default reader) keyboard (with Dr Hurt's VoodooPS2Controller R6 + DSDT patch for brightness control) touchpad including tap-to-click (with Dr Hurt's VoodooPS2Controller R6) left combo eSATA/USB2.0 + right USB3.0 ports (with Hackintool's generated USBPorts + Rehabman's FakePCIID kexts for multiplexing) ExpressCard slot OOB Not working: VGA output unsupported Not tested: SmartCard reader fingerprint scanner 1) 10.15 USB installer creation Using a USB key of 16GB minimum, create a Mojave USB installer through the following Terminal command: sudo <path>/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/<USB key> where: <path> = location of Catalina installation package (eg: /Applications if freshly downloaded) <USB key> = name of formatted USB volume (eg: USB_16GB) The process will take several minutes. Once completed: Setup your BIOS for UEFI mode install Clover bootloader on the USB installer with the following customised settings: Clover for UEFI booting only Install Clover in the ESP UEFI Drivers AudioDxe DataHubDxe FSInject SMCHelper ApfsDriverLoader AptioMemoryFix Fat FSInject PartitionDxe Ps2MouseDxe UsbMouse.Dxe VBoxHfs Themes (optional) Install Clover Preference Pane (optional) you may use version r5058 (or later) attached below: Clover_v2.5k_r5058.pkg.zip once Clover is installed, run Clover Configurator app and mount the freshly created EFI partition of the USB installer Clover Configurator.zip open this EFI partition and transfer the files & folders from the Latitude E6230 Catalina Clover pack below to the EFI/Clover folder: E6230_Catalina_Clover_Pack.zip E6230_Catalina_Clover_Pack_#2.zip 2) 10.15 installation boot the Catalina USB installer at the Clover main menu, select the "Install macOS Catalina" partition (but don't press [ENTER]) press [SPACE], select -v verbose option in the menu, then choose to boot with the selected options proceed with installation, creating & formatting the target Catalina installation through Disk Utility as/if required on 1st reboot, boot off the USB installer and select the freshly created "macOS install from <target Catalina partition>" repeat this until this partition is no longer offered and only the target Catalina partition is left to boot Reboot the target Catalina partition via your USB installer 3) Post-installation tuning Once the target Catalina partition has booted, complete the 1st boot configuration tuning Once at the desktop, install Clover bootloader on the Catalina partition/disk with the customised settings listed above Once Clover is installed, launch Clover Configurator app and mount the freshly created EFI partition of the Catalina partition/disk Open this EFI partition and transfer the files & folders from the above Latitude E6230 Catalina Clover pack to the EFI/Clover folder You may then reboot and verify that Catalina boots off your disk through Clover Edit: May 23rd, 2020 - - - - - - - - - - - - - - - Following 10.15.4's breaking of XCPM on Ivy Bridge platforms, revised pack #2 where CPU power management is reverted to traditional CPU-specific SSDT generated by Pike R Alpha's well-known script. A specific XCPM-enabled Clover config is still provided up to 10.15.3.
  48. 1 point
    I've recently acquired a dell latitude d430 and I've seen where people can install lion (10.7.5) on it. I've found no good tutorial on how to do so and I'm wondering if anyone can give some pointers. I'm willing to go down to snow leopard if need at least to 10.6.7. Any help is greatly appreciated
  49. 1 point
    Back in 2015 , when Apple introduced SIP protection in El Capitan, I quickly had a look at the SIP settings and associated CsrActiveConfig 8bit values in Enoch: nibble: 4 3 2 1 | 4 3 2 1 bits: - - - - | - - - - | | | | | | | | | | | | | | | | | | | | | | | | / | | | | | | \ Dev. Prot. / | | | | \ Kext Sig. NVRAM Prot. / | | \ FS Prot. DTrace Prot. / \ Task Prot. Apple Int. Kernel Debug. Source: csr.h (in bsd/sys folder) of 10.11's published XNU source code at https://opensource.apple.com/ On the basis/assumption that Apple Internal & Device Configuration could be kept disabled by default (bit set to 0), CsrActiveConfig could be set to: 00000011 in binary, i.e. 0x03 (3 in decimal) to disable kext signing and filesystem protection 01100011 or 01101111 in binary, i.e. 0x63 or 0x6F (103 or 111 in decimal) to disable all protections that mattered If I booted Enoch in verbose mode with CsrActiveConfig=103 (i.e. 0x63), the displayed info showed: System Integrity Protection status: enabled (Custom Configuration). Configuration: Apple Internal: disabled Kext Signing: disabled Filesystem Protections: disabled Debugging Restrictions: disabled DTrace Restrictions: disabled NVRAM Protections: disabled This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state. In the current days of Clover, most people still use CsrActiveConfig 0x63 and that's fine. But there are also more rootless flags to control SIP than there used to be in El Capitan: nible: #3 | #2 | #1 nibble bits: 4 3 2 1 | 4 3 2 1 | 4 3 2 1 bits: 12 11 10 9 | 8 7 6 5 | 4 3 2 1 - - - - - - - - - - - - N/A | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | / | | | | | | | | | | Policy Over. / | | | | | | | | | Kext app. / | | | | | | | | Recov. OS / | | | | | | \ Device Config. / | | | | \ Kext Sig. NVRAM Prot. / | | \ FS Prot. DTrace Rest. / \ Task for PID Apple Int. Kernel Debug. where: Bit #12 = N/A Bit #11 = Allow executable policy override Bit #10 = Allow unapproved kexts Bit #9 = Allow any recovery OS Bit #8 = Allow device configuration Bit #7 = Allow unrestricted NVRAM Bit #6 = Allow unrestricted DTrace Bit #5 = Allow Apple internal Bit #4 = Allow kernel debugger Bit #3 = Allow task for PID Bit #2 = Allow unrestricted FileSystem Bit #1 = Allow untrusted kexts Source: csr.h (in bsd/sys folder) of 10.14.1's published XNU source code at https://opensource.apple.com/ Whilst the original CsrActiveConfig of 0x03 or 0x63 remains valid by far and large to most hackintoshers, some folks may also want to allow unapproved kexts on top of unsigned kexts. Keeping the same flags as for CsrActiveConfig 0x63 alongside, this would lead to a new value of 0010 0110 0011, i.e. 0x263 or 611 in decimal.
  50. 1 point
    There you are: Archive.zip Rest assured those kexts are part of the vanilla installation, no doubts to be had on that front. For future reference, with Pacifist app you can extract kexts from any given combo update (like 10.14.4) available off Apple's web site. Simply Google for it.
This leaderboard is set to Amsterdam/GMT+02:00
×
×
  • Create New...