Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 09/26/20 in Posts

  1. 3 points
    OPENCORE Here's a WIP bootpack for those who want to try OC Just replace the entire EFI folder Make sure to have a bootable USB ready incase it doesn't work for you or create a Fat32 USB drive and add the EFI folder to the root. OpenCore v0.5.9 HP840G3_OC.zip Update: Improved touchpad gesture functions: Zoom, left & right swipe, scrolling, etc... Big Sur ready OpenCore v6.0 HP840G3_BigSur_Beta4.zip
  2. 2 points
    Dell Optiplex 3070 Micro Form Factor 100% working EFI. Dell Optiplex 3070 Micro 100 Percent Working.zip Thanks Jake for the support.
  3. 1 point
    Why do you want to install such an old OS X version when this laptop fully supports macOS High Sierra? As for the set of kexts required for this model, I'm pretty sure you'll find them in existing threads or JakeLo's multi-platform guides. Look those up.
  4. 1 point
    If you want to install BS, just make sure to use new Clover that has OC quirks added (v5124), and of course update to the latest kexts.
  5. 1 point
    1) SSDT-HPET is required for Audio, it's basically the same for across the board. The extra patches I have experienced to not make a difference added or not. You can experiment adding them 2) I can't remember why I opt for 00001B19, try 00001619. If you lose external video connection switching then that might be why. Also check to see if you get more CPU States switching. Currently for me with 00001B19, I have 30. You can check by launching IORegistryExplorer, under CPU0/AppleACPICPU/x86PlatformPlugin 3) Yes, the 2 values are commented out so they're disabled. They were needed earlier on when testing BS. Latest OC has fixed that, you can delete them 4) You can try MBP13,2 and of course need add NoTouchID to the configuration. Again see #2 if it make a better option 5) No changes needed when switching higher resolution display. Only thing I could think of is if it's a touchscreen, then you'll need to additional kexts (ie VoodooI2C + satellite) 6) When checking the Config file with OC Sanity Checker, it recommends it but I don't see it's needed for audio to work with it already declared in Device Properties... and it's alcid=11, not 1. Post your results when you make those changes. Maybe it'll be better than what I'm using.
  6. 1 point
    Glad that worked out. I used Rehabman's sample NVMe spoof file to create this patch.
  7. 1 point
    If that doesn't work, try just adding this SSDT SSDT-DisableNVMe.aml.zip
  8. 1 point
    assuming your Micron is an NVMe drive, your PCI path is incorrect. Should be according to the location of my NVMe drive PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)
  9. 1 point
    Yes, it should be backward compatible to Catalina.
  10. 1 point
    I meant the link to VoodooPS2, you mentioned version 2.7 but I guess you mean 2.1.7. Have you tried VoodooSMBUS/VoodooRMI I has suggested on the 1st page? Post your IOReg files, let's see if it's supported
  11. 1 point
  12. 1 point
    Known issue with OC dual booting with Windows. I just select Windows from BIOS boot option by pressing F12 Now that Clover v5124 supports BS, you can try that.
  13. 1 point
    Hi @all i try to install Catalina on my E490 Lenovo but i get an error during installation: ACPI Error ae_bad_parameter i guess i have to change my xhci option in bios ... but ... i dont have this option. What can i do ? BR Hubierft
  14. 1 point
    I'm sending my opencore files with tools (propertree, GenSMBIOS). I'm using dw1820a, i removed pci section in config.plist file, but kexts still in efi. I changed smbios info, if you want, you can change again. This is my latest working opencore efi sample. I followed this guide for opencore post-install settings. That you must not forget, if you changed anything in opencore folder via propertree, for instance add/remove SSDT or kext, use "cmd + control + r" keys. This key combinations are arrange the config.plist file easily. And then cmd + s for save. After change efi, if your device not boot, clear NVRAM in opencore boot menu. There are many resources on opencore on the internet. Before you edit the efi file in NVME, always do it with a usb stick. Otherwise, the running system may become not boot. If usb efi boots normally, copy usb efi folder to nvme efi. Hope it helps. Optiplex_Opencore_05_10_2020.7z
  15. 1 point
    should be a patch under KextToPatch. Otherwise it can be done in the terminal Check in system information under Sata/Sata express to verify if Trim is enabled or not sudo trimforce enable sudo trimforce disable
  16. 1 point
    Give this a try, updated all the kext, added a couple of SSDT's and updated the Config. You'll need to fix your USBPortsE5x70.kext. The purpose of the kexts is to have only 15 ports or less as required by latest MacOS. Your kext has 21, way over the limit and I doubt it has that many USB ports on that system. I only see internal and USB 3.0 and none USB 2.0 on your kext. You should be testing each external USB ports with an USB 3.0 and USB 2.0 devices, changing the default setting in Hackintool. For example, if you have 3 external USB ports, you should end up with (3) USB 3.0 ports (SSxx) and (3) USB 2.0 ports (HSxx) and a few internals like BT, Webcam, and SmartCard if it exists. E5470_Update.zip
  17. 1 point
    A supplemental update was issued to address and fix the problem.
  18. 1 point
    It's been reported that Mojave's Security Update 2020-005 causes performance issues due to unexpected memory usage. After installation of the update, a very significant quantity of RAM is used as reported in Activity Monitor app where App Memory/Wired Memory/Compressed are at much higher level than before the update. It's a very impacting situation for systems with 4GB or RAM which will suffer severe performance degradation. Think twice before installing!
  19. 1 point
    It's entirely up to you. There's a chance you won't see much difference in terms of CPU power management and performance between patched kernel and unlocked CFG register/variable. But I guess, only experimentation can tell...
  20. 1 point
    Built an Hackintosh Recently with the following Specs: Atermiter X79G motherboard 45$ Xeon E5-2650V2 ~50$ 64GB DDR3 ECC RAM Nvidia GT 710 graphic card: sanddisk 500GB SSD You can directly install Mojave without modifying anything in the bios... using this EFI.. But if you have to install/upgrade to Catalina 10.15.2, before installing or upgrading Disable Virtualization support - CPU configuration disable VTX-D - North bridge. Disable USB ECHI support Post installation you can enable them again. Had no issues with virtualization performance etc... Boots in less than 10 seconds. All working - except small static in AUDIO... (hardly noticeable, but goes away once you play something)... EFI_desktop.zip
  21. 1 point
    You're extracting those raw vfiles out of a complete dev package. Download the complete package from parent level and you may compile the .asl files with the provided makefile. These .asl files are plain source code. You may rename the extension to .dsl to open them in MaciASL app. MaciASL uses .dsl extension for source code and .aml extension for compiled code. Here, the .asl files are meant to be compiled with the command line (Intel) iasl tool through the makefile. If you open up the makefile with a text editor, you'll see how it operates. As for errors, well they can depend on the ACPI version the code is based on and the ACPI version the compiler will be using. Check your MaciASL settings here. After a few years with good old DSDTEditor, I switched to rehabman's version of MaciASL several years ago and have been using that same version without problems ever since. Of course, I had to get into ACPI coding to be able to fix DSDT/SSDT when compiler returns errors... https://github.com/RehabMan/Intel-iasl https://github.com/RehabMan/OS-X-MaciASL-patchmatic
  22. 1 point
    Thank you for you. Now Intel wireless network cards can be driven on 10.15.6, and Bluetooth is also normal.MY E470 usbe Ax 200 is Works OK ,
  23. 1 point
    worked like a tee thank you fyi i am running a visiontek radeon hd 7750 boots wonderfully
  24. 1 point
    My 7490 is USB-c/DP only, no optional TB. You may check the SSDT used on that laptop in the pack I posted in the associated guide.
  25. 1 point
    The parent device is 8086:1576, i.e. DSL6340 Thunderbolt 3 Bridge [Alpine Ridge 2C 2015]. The XHC5 device you see underneath is the associated DSL6340 USB3.1 controller. Seeing an "XHCx" device is what you want.
  26. 1 point
    RP05 is the PCIe root port (hence RP). RP05.PXSX and/or RP05.UPSB are the actual TB/USB-c PCIe devices.
  27. 1 point
    Yes, this may happen from time to time. Could be a bug in AppleALC, I'm not too sure. Solution is to put the laptop to sleep and wake it after a couple of seconds or reboot. Check that you use latest versions of Lilu, AppleALC and CodecCommander and update if required. You may use Clover Configurator app to that effect.
  28. 1 point
    Hi everyone, I successfully installed Big Sur beta 4 on my Latitude E 7450 using OpenCore 0.6.0. The machine is already running Catalina 10.15.6 based on Jake Lo's guide, so I will not repeat the same story (especially for specs). I only underline that this is the iGPU only model (no dGPU to be disabled here). Working: - keyboard, trackpad and trackstick (only with ApplePS2Controller provided in Jake Lo's packages. Latest VoodooPS2Controller will not be useful for this ALPS touchpad) - Wifi (thanks to Jake Lo patch) using a Dell DW1560 (as per signature) - Graphic card acceleration - Screen backlight - Bluetooth - Audio - SD card reader Not working - Bluetooth (and webcam) - Audio - Fingerprint sensor (of course, as always) - SD card reader Not tested - SD card reader (supposed not working) Hackintool (and IORegistry, of course) is able to recognize both audio and EH01 usb controller, but they seems to be "inactive" and I don't know how to fix them. Fortunately, USB3 is working, otherwise I couldn't install macOS since I used an external WD HD on a USB3 caddy. In any case, I share my EFI for development and further testing, especially for @Jake Lo. Credits: Jake Lo (and all the guys and teams who inspired him for his original clover guide) EDIT: Bluetooth, webcam and Audio work fixing IRQ issues by adding SSDT-HPET (and related patches) to ACPI. SSDT-PLUG is actually useless (you can even turn it off from the config.plist). I updated the EFI folder. EDIT 2: Properly injected device properties made the SD card reader working again. Thanks Jake! I uploaded the working EFI Updates: Big Sur Beta 5 (20A5354i) installed through software updates Big Sur Beta 6 (20A5364e) installed through software updates Big Sur Beta 7 (20A5374g) installed through software updates Big Sur Beta 9 (20A5384c) installed through software updates Enjoy! E7450-OC060-BSb-EDIT2.zip
  29. 1 point
    Specifications: Intel 6th generation Core i5-6200U 2.3 GHz, up to 2.8 GHz with Intel Turbo Boost Technology, 3 MB cache, 2 cores Integrated Intel HD Graphics 520 Non touch 35.6 cm (14 in) diagonal LED backlight FHD Slim eDP SVA Anti-glare (1920 x 1080) with camera System can be configured with a hard drive and M.2 SSD drive / NVMe 8192 MB total system memory (8192 MB x 1) Up to 32 GB - DDR4 PC4-17000 (Transfer rates up to 2133 MT/s) Intel Wireless-AC 3165 802.11 a/b/g/n/ac (1 x 1) WiFi and Bluetooth 4.0 combo (non-vPro) HP Module with NXP NFC Controller NPC100 Intel Ethernet Connection I219-V 10/100/1000 Ethernet Synaptics Touchpad Audiio Conexant CX20724 - VendorID: 0x14f150f4 Integrated HD Webcam (1) USB 3.1 Gen 1 charging (1) USB 3.1 Gen 1 (1) USB Basic Type-C (1) DisplayPort (1) VGA (1) RJ-45/Ethernet (1) Docking connector (1) Headphone/microphone combo (1) AC (1) External SIM (1) SD media card reader, supports SD, SDHC, SDXC Working: full graphics acceleration on Intel HD520 iGPU, including brightness control (F5 and F6) multi-display with DisplayPort OOB, VGA and HDMI over USB Type-C audio, microphone input and headset output (F8 and F9) - Mute button not working GigEthernet LAN connection wireless and bluetooth with any compatible card (a DW1560 in my case, no Whitelisting) left and right USB ports including USB Type-C integrated webcam (OOB) CPU power management sleep (Lid, Energy Saver settings, Apple menu, PWR button) & wake (Lid, PWR button) battery management (with SMCBatteryManager v1.0) keyboard and touchpad (with VoodooPS2Controller v1.9.2) keyboard backlight (Fn + F3) touchpad including tap-to-click, scrolling, mouse buttons (can be disable with prt scr key) Partially working: RTS522a microSD card reader (read-only mode) - after sleep, need to eject and reinsert New updated kext allow read and write Not working: TrackStick Finger Print reader Wifi button Mute button (grayed out) BIOS Settings: Installation: Follow the standard UEFI Clover guide Replace contents to /EFI/Clover after installing Clover HP840_G3.zip Updates: Added VoodooSMBUS for better touchpad experience, most gestures work! HP840G3_BetterTouchpad.zip Add HPFanReset.efi to /EFI/Clover/drivers/UEFI HPFanReset.efi.zip Post install: Install CsmVideoDxe.efi to fix stretched Clover boot screen using Clover Configurator. The version from Clover installer does not work. Change BIOS settings for Secure Boot Configuration Configure Legacy Support and Secure Boot = Legacy Support Disable and Secure Boot Disable Note: Files tested on Catalina, Mojave, High Sierra, El Capitan ( Just need to add boot arg -no_compat_check) Credits: Rehabman for hot patched files Sinetek /Cholonam for Sinetek-rtsx (SD Card reader) Leo-laps / 1Revenger1 for VoodooSMBUS & VoodooRMI
  30. 1 point
    Last update: 22 Mar 2020 EDP being in semi-permanent revamp, here are full packs for the Latitude D620/D630 series. The packs do not require any subsequent EDP tuning at all, they provide everything required to obtain a fully working system (CPU power management, graphics, LAN, audio, keyboard, trackpad), non-OOB wireless, bluetooth and any other devices excluded of course. However, some manual tuning for proper Sleep/Wake operation is required: setting hibernation mode to plain old sleep and deleting any eventual sleep image file. This is done through the following Terminal commands upon final OS X installation: sudo pmset -a hibernatemode 0 sudo pmset -a hibernatefile /dev/null sudo rm -f /var/vm/sleepimage Vanilla support stops at Lion 10.7.5 for all Intel GMA based models and the D620 nVidia due to GPU support limitations. For those systems, ML may be installed and tuned back to 32bit operation through MLPF hack. Look at the Dell installation guides forum subsection for MLPF'ed ML guides and packs. It's not 100% bug-free though... Only the D630 nVidia supports vanilla installation of Mountain Lion, Mavericks, Yosemite, El Capitan, Sierra and High Sierra (Sierra & HiSie only with Penryn CPUs). For all models, read the Performance tuning thread for CPU + GPU tuning if required but the FakeSMC kext included in the packs below brings it all. D620 GMA950 LoRes (WXGA 1280x800): D620_GMA950_LoRes_10.6.8_Pack.zip D620_GMA950_LoRes_10.7.5_Pack.zip D620 GMA950 HiRes (WXGA+ 1440x900): D620_GMA950_HiRes_10.6.8_Pack.zip D620_GMA950_HiRes_10.7.5_Pack.zip D620 nVidia Quadro 110M (all res): D620_NV110m_10.6.8_Pack.zip D620_NV110m_10.7.5_Pack.zip D630 GMA X3100 LoRes (WXGA 1280x800): D630_X3100_LoRes_10.6.8.zip D630_X3100_LoRes_10.7.5_Pack.zip D630 GMA X3100 HiRes (WXGA+ 1440x900): D630_X3100_HiRes_10.6.8.zip D630_X3100_HiRes_10.7.5_Pack.zip D630 nVidia Quadro NVS 135M (all res): D630_NV135m_10.6.8_Pack.zip D630_NV135m_10.7.5_Pack.zip D630_NV135m_10.8.5_Pack.zip D630_NV135m_10.9.5_Pack.zip D630_NV135m_10.10.5_Pack.zip D630_NV135m_10.11_Pack.zip D630 nVidia Quadro NVS 135M + Penryn C2D CPUs (all res): D630_NV135m_10.12_and_10.13_Pack.zip NB: MyHack highly recommended for installation of Snow Leopard, Lion, Mountain Lion and Mavericks. Use myHack v3.3.1, except for SL which requires v3.1.2 (there's a bug related to SL in v3.3.1). For Yosemite and beyond, we recommend manual USB installer creation using instructions that have been detailed in numerous guides posted here. NB: For Chameleon-based Yosemite installations (i.e. no Clover or otherwise), not all kexts load from /E/E. Eg: VoodooHDA + HDADisabler or lspcidrv. In such cases, copy the kexts to /L/E, repair permissions and rebuild the cache with the following Terminal commands: sudo chmod -R 755 /Library/Extensions sudo chown -R 0:0 /Library/Extensions sudo touch /Library/Extensions sudo kextcache -Boot -U / Update to Chameleon r2468 is recommended for proper hardware support such as good CPU detection. Chameleon-2.3svn-r2468.pkg.zip NB: For Enoch-based Yos/EC/Sierra installations (recent Enoch versions such as r2795 and beyond for instance), you may use a kernel.plist file in /Extra with parameter KernelBooter_kexts set to Yes to load kexts from /E/E directly. Those kexts will not natively be considered for prelinked kernel/kext cache generation so boot time will be a little slower. To maximise boot time, you can either move kexts from /E/E to /L/E or copy them from /E/E to /L/E and set KernelBooter_kexts to No. You will then repair permissions and rebuild the cache as detailed above. macOS Sierra and later can only be installed on D630 nVidia models fitted with a Penryn FSB800 C2D CPU (e.g.: T6xxx, T8xxx, T9xxx). Enoch-rev.2839.pkg.zip
  31. 1 point
    Here, replace this into /EFI/Clover Courtesy of Rehabman HP840G2.zip
  32. 1 point
    Nawcom's sort of disappeared from the Hackintosh scene but tribute can still be paid to him and his great tools. It sure is dated today but it did the business back in the days and greatly so. These may still be useful for those novices who want to setup a Hackintosh on a platform capable to run Snow Leopard but have no access to a Mac or an existing Hack. Snow Leopard remains the Mac OS X version from which many platforms can upgrade to subsequent OS X/macOS versions as long as their profile (SMBIOS) meets the requirements. Provided one has the Snow Leopard retail DVD or a USB key with retail SL restored to it, Nawcom's modCD or modUSB can be very useful to setup a temporary basic SL installation to work from. It does not have to be fully tuned up... Nawcom's tools are hard to find on the Net today, so here are copies it. I hope (and think) Nawcom's would not mind... OSX86_ModCD-032311-151021.zip -> rename from .zip to .iso and burn the image to a CD/DVD (can be done from Windows or Linux) OSX86_ModUSB.pkg.zip -> unzip this Mac app and run from OS X to create a bootable USB installer (cannot be used in Windows/Linux)
  33. 1 point
    Hello! I just merged Javmain work on v7 trackpads on my fork: https://github.com/douglas/OS-X-ALPS-DRIVER/releases/tag/R7A1 Could you test with this kext? VoodooPS2Controller-R7A1dsarch.kext.zip Thank you!
  34. 1 point
    Attached a pic of hard drives, link to dropbox will follow
  35. 1 point
    Annoying... When running OS X on an Intel Series 330 SATA-III (6Gb/s) SSD, boot time is dramatically impacted if the IOAHCIBlockStorage kext is binary patched to enable TRIM support (binmod of IOAHCIBlockStorage to replace hex string 00 41 50 50 4C 45 20 53 53 44 00 (="APPLE SSD") by a string of 00s). I've made some comparisons with my Dell Latitude E6440: 1) Vanilla kext - No TRIM support: . boot time Mavericks 10.9.5 (13F1077): ~7s . boot time Yosemite 10.10.3 (14D136): ~8s 2) bin-patched kext - TRIM support: . boot time Mavericks 10.9.5 (13F1077): ~46s . boot time Yosemite 10.10.3 (14D136): ~50s I had previously read similar reports but I'm still a bit baffled as I do not experience such slowdowns on my D630 (ICH8M controller, SATA-II 3Gb/s) fitted with a SATA-III (6Gb/s) 128Go SAMSUNG PM830 + TRIM enabled. Will need to try a swap out to try and verify if it could be controller related or SSD related.
  36. 1 point
    Having replaced the Intel SSD by a 256Go Samsung SM841N mSATA SSD, I can report that the issue lies with the Intel drive itself. Slow boots cannot be reproduced neither with the Samsung mSATA SSD, nor with the Samsung PM830 SSD whether fitted to my SATA-II Latitude D630 or my SATA-III Latitude E6220. However, slow boots are reproduced with the Intel SSD when fitted to the D630 and the E6220.
  37. 0 points
    In fact, I have no way to replace the network card. Is it possible to somehow get by with the existing one?
  38. -1 points
    Hi Friends Install macOS Catalina on Dell Latitude E6440. Install with my uploaded EFI.zip. if problem with USB Ports, Block GenericUSBXHCI.kext in Clover. USBInjectall.kext and USBinjecter.kext not worked for me. SSDT.aml is Already Present in ACPI Patched Folder for Solved the USB ports Problem in macOS Catalina 10.15 Beta. I updated my Bios version to A-23 I Attached my EFI.zip and After install.zip Folders. and Pics Also. EFI.zip After Install.zip
This leaderboard is set to Amsterdam/GMT+01:00
×
×
  • Create New...