Jump to content


Popular Content

Showing content with the highest reputation since 06/21/19 in all areas

  1. 2 points
    So according to @Hervé's guidance, I was able to use my DW1820A. My configs were posted here. After some research, I'm able to use Auto Unlock function now, and still no freeze, after 1 hour of usage. A. Some research. Model Typical Devices Device ID Auto Unlock Supports BCM94331CSAX MBP 2012 14e4:4331 NO BCM943224PCIEBT2 MBA 2011 14e4:4353 NO BCM94360CS MBP 2013 14e4:43a0 YES BCM94360CS2 MBA 2013 14e4:43a0 YES It looks like by faking dw1820a(bcm4350) into 14e4:4353 will make it looks like an 2011 mba card, and won't get Auto Unlock function. BCM433x can't use auto unlock, BCM436x can. DW1820A was BCM4350, in between of 433X and 436X. B. The new config. So instead of faking the card into 14e4:4353, and setting brcmfx-driver=1, I tried 14e4,43a0 and set brcmfx-driver=2. And that's it, nothing else changed, everything's working, including Apple Watch Auto Unlock. (It didn't work in the first place, but worked after disabling and enabling the feature again). C. Some screenshots and terminal outputs. a. kextstat|grep -y brcm b. SysInf Wi-Fi. (firmware version changed, and the Auto Unlock line comes out) c. SysInf BLE.( firmware version changed) D. Some problems. I heard some noise, maybe coil whine, after booting into the system with this new config. The noise disappeared after several minutes. I never noticed such noise before switch to this config.
  2. 2 points
    Hello everyone Thank you very much for your wonderful and useful forum I want share with you after long search and fixes my final EFI Partition for Dell Precision WS M6800 & M4800 and will work 99 % on any similar Model All files , Kexts , ACPI , Guide are all included in zip file linked below This my final EFI with alots of fixes and tweaks works for both High Sierra and Mojave only you will need Nvidia web drivers and Cuda to get fully working machine for graphic designing , video editing and 3D ... - Fully working everything , audio , Bluetooth, Brightness slider , card reader , mSata , ethernet , Wifi , Camera ,all USB 3 Ports and many more you will explore it yourself ...... - Bios Reset issue fixed - Optimus Graphic enabled - Use Intel HD only or Intel HD + Nvidia (if you want Nvidia only then disable Optimus in bios) - External Monitor use Nvidia - No black Screen when external monitor is connected - What is missing and doesn't work !!!! You will tell me - all fixes files and instructions are included ************************* UPDATED 30 JUN 2019 ************************ - Alots of Tweaks has been added to ACPI , config.plist and IntelFrameBuffer - USB 3 all ports fixed natively - KEXTS has been updated -Clover bootloader has been updated - Fans has been adapted by ACPIPoller.kexts and SSDT for more cooling and less noise - CPU and RAM Tweaks - No more Kernel Panic with release or security update - Clean DSDT , SSDT , plist - Alots of work, search and tests to get this result with this Laptop - Ready for Catalina ( wait for the official release and Hacks developers final fixes to be ready ) All Updated Files are here ( 50 MB) ; https://drive.google.com/file/d/107_34arPRYoiObJUCH9l7TG_tZsK2FOD/view Thank You ********************* 30 Nov 2018 Fix OLD .zip If you need any help or have any questions or issue please let me know in the Support section of the forum and I will reply as soon as possible Cheers
  3. 2 points
    Mojave Mojave Guide Bootpacks - HD5500 Only Add this to /EFI/Clover replacing the old Exx50_Mojave.zip - For Discrete Model Also add this to /EFI/Clover/ACPI/Patched SSDT-Disable-DGPU.aml.zip Follow Post Install above under Sierra Guide UPDATES Mojave 10.14.1 (18B75) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.2 (18C54) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.3 (18D42) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.4 (18E226) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.5 (18F132) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover / update kexts prior to update
  4. 1 point
    Replace DSDT and Config with attached Use Fn+F3 and Fn+Insert to control Brightness BirghtnessFix.zip
  5. 1 point
    Hi idjundje, you will have to replace the wireless card, e.g. with a DW1560. I would upgrade the memory, 4GB is quite low. Create an install stick and use the bootlick for the e5550. I attached my clover folder, maybe it of some kind of help for you. cheers .d CLOVER.zip
  6. 1 point
    Go ahead and upgrade the following kexts from links below: Lilu.kext Whatevergreen.kext AppleALC.kext AirportBrcmFixup.kext VirtualSMC.kext NoTouchID.kext SMCBatteryManager.kext https://github.com/vit9696/Lilu/releases https://github.com/vit9696/Lilu/blob/master/KnownPlugins.md
  7. 1 point
    should be fine. looks like it goes through but just to make sure. try this sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/"USB" --nointeraction
  8. 1 point
    answer the questions above issues with permission...did you use a different tool to repair permission and rebuild cache previously?
  9. 1 point
    What's the source of your installer? Is it a Distro or vanilla ? post your clover folder for review
  10. 1 point
    Dell Latitude 5290 2-in-1 UHD620 iGPU CLOVER Specifications - CPU : Intel® Kaby Lake R Core™ i5-8350U Processor @1.70GHz (Turbo boost up to 3.60GHz) - Graphics : Intel® UHD Graphics 620 - Sound : Realtek ALC225 (ALC3253) - Display : 12.3" WUXGA+ 1920x1280 3:2 10xPoints Multi Touch - Memory : 8GB LPDDR3 1867MHz - SSD : M.2 NVME 256GB TOSHIBA KXG60ZMV256G - Wireless : Broadcom BCM943602BAED-based DW1830 - External Ports : 1 x USB 3.1 Gen1, 2 x DP over USB Type-C, 1 x Audio Jack - SmartCard Reader Bios/Clover Bootloader/macOS Version - Bios : 1.7.3 - Clover Bootloader : v2.4k r4920 (or Higher) - macOS : 10.14 Bios Setup - Load Optimized Defaults Drivers64UEFI - ApfsDriverLoader-64.efi - AptioMemoryFix-64.efi - FSInject-64.efi - HFSPlus.efi - VirtualSmc.efi Kexts - AirportBrcmFixup.kext - AppleALC.kext - BrcmFirmwareRepo.kext - BrcmPatchRAM2.kext - EFICheckDisabler.kext - Lilu.kext - NullEthernet.kext (because this tablet PC has no built-in Ethernet) - SMCBatteryManager.kext - SMCLightSensor.kext - SMCProcessor.kext - SMCSuperIO.kext - USBPorts.kext - Hackintool generated, HS / SS port matching and realignment - VirtualSMC.kext - VoodooI2C.kext - VoodooI2CHID.kext - VoodooPS2Controller.kext - Add 'Info.plist - IOKitPersonalities - IONameMatch - Item 0 - PNP044E' - WhateverGreen.kext ETC After installation - Remove these boot flags -v debug=0x100 keepsyms=1 - Additional patches are required for iMessage and Facetime activation Intel UHD Graphics 620 - This build is suitable for 'Dell Latitude 5290 2-in-1' system uses iGPU of 'Intel UHD Graphics 620' If your iGPU is not 'Intel UHD Graphics 620', additional graphics patches might be required NullEthernet.kext & ssdt-rmne.aml - Null Ethernet is used to prevent a Mac address-based license for some software from being broken when a wireless card is absent or replaced (including iCloud) If you do not need to consider blocking software licenses by changing your Mac address, you can remove it What Works Graphics/Display - Intel® UHD Graphics 620 QE/CI, 2048MB Vram - Type C DP 2 ports Video / Audio output Hot Swap - Brightness control - Lid Close Sleep with Magnetic Travel Keyboard - I2C touch screen Up to 4 points Gesture action (recognized as Magic Trackpad 2) Audio - Built-in speaker - Built-in microphone - Line input - DP Audio Output Input - I2C touch screen Up to 4 points Gesture action (recognized as Magic Trackpad 2) - I2C Keyboard (Magnetic Travel Keyboard) with Backlight - Touchpad (Magnetic Travel Keyboard, recognized as mouse) - Volume button, window button, power button Power Management - CPU/Speed Step - Battery - DP over USB Type-C, 2 Ports Charging - Sleep/Wake Storage Device - Full Size / Type-C USB 2.0, 3.0 Hot Swap - M.2 NVME 2280/ m.2 SATA 2280 1 Slot and m.2 NVME 2230(2242)/ m.2 SATA 2230(2242) 1 Slot Wireless communication - iMessage/FaceTime/App Store - Wi-Fi, Bluetooth, Airdrop, Continuity with macOS compatible wireless card Issues - If USB device is connected to Full size USB port with power connected state, it wakes up immediately after sleeping Fixed after Full size USB port as internal port As a result, if you connect a device above USB 3.0 to the Full size USB port, it will be recognized as an internal disk icon - When the battery is in use, the disk not ejected properly after sleeping Fixed with SafeSleepUSB.app or Jettison.app - WWAN communication via WWAN card, USIM, and Legacy_Sierra_QMI.kext is feasible, but has not been tried yet - DW1820A (BCM94350ZAE) - 1028:0021 (part# CN-0VW3T3) Issue 1 : WiFi Down sometimes - DW1830 (BCM943602BAED) - VendorID : 0489, DeviceID : E0A1, Firmware Version:v5 c4510 (v5 c4096) Issue 1 : Bluetooth not works after sleep Issue 2 : If check 'Wake for Wi-Fi network access', wifi speed will be very slow after sleep. - MicroSD slot not working properly If you use modified Sinetek-rtsx.kext, you can use HFS + formatted SD card, but there are still some problems - PCIe front and rear camera (AVStream2500, OV series camera) not recognized - Compared to Windows, white noise occurs a little on speakers - In case of new installation, Magic Trackpad 2 touch screen via VoodooI2C, VoodooI2CHID is not immediately recognized and suddenly recognized after specific setup / injection event after personal setting Once recognized, the touch screen will not be lost After recognized the touch screen, the touch pad of the Magnetic Travel Keyboard is disabled, which can be activated using Karabiner - 3:2 resolution HiDPI not works through known method Files and Details (Github) https://github.com/laelsirus/Dell-Latitude-5290-2-in-1-UHD620-iGPU-CLOVER
  11. 1 point
    run it again a second time last line is normal
  12. 1 point
    feels like deja vu follow instructions here
  13. 1 point
    Yes, make sure to copy the bootpack after installing clover.
  14. 1 point
    Can't really tell since the error occurred way before that last line. Try this, go to Option during Clover boot. Go down to graphics injector and change ig-platform-id to 0x12345678 and faked to 0x12345678 see if you could boot from that
  15. 1 point
    are you still booting with -igfxvesa?
  16. 1 point
    NOTE: Workaround is only needed on clean boot, no issue if system has gone through a sleep/wake cycle If you read the note, just place system to sleep once after boot and you won't have an issue until the next reboot. If there's a fix, let me know. I have not pursue it further since it's not a big deal for me.
  17. 1 point
    There graphics is not loading because you didn't set the DVMT, but that's okay, I have the patches in place. Only problem is it won't work during installation because the graphics kext needs to be cache. So to get the installation going, you need to boot with no graphics support by adding boot arg -igfxvesa So when you boot to Clover, press the letter O. This will bring you to Options. Go down to the boot arg line and add -igfxvesa Now go back to the main menu by hitting the escape key or click on return Continue booting to the installer
  18. 1 point
    NO longer need to modify DVMT but you do need to set BIOS according to the guide. UEFI/AHCI/Secure boot off (most important) The patch if for NVMe drives mentioned, you SSD is not an NVMe, so you could ignore it.
  19. 1 point
    Sorry, I was not clear. I just updated the guide. The copying of the kexts in CopyToLE is a post installation step. Don't merge the bootpack files, but replace it into /EFI/Clover
  20. 1 point
    @TheSparctan Looks like you're using TonyMax installer and trying to install HS 10.13.3. We don't support any installer other than the vanilla. I invite you to try my guide here. Bootpack is for Mojave and below.
  21. 1 point
    Ok, got it. I've reverted to uncompressed firmware file; it's not as if it made a big difference in terms of size...
  22. 1 point
    Obviously, the E5550 the latest and current macOS version, i.e. Mojave 10.14 . Please refer to existing guides for this model in our Guides section and to existing topics/disucssions in this current Support section. I also recommend you consult our FAQ section.
  23. 1 point
    you can try hackintool to create a kext for you. You'll have to remove USBPorts-Exx30.kext. Instruction can be found within the tab of the tool.
  24. 1 point
    I found what I believe to be a more recent firmware here which works fine too. It would appear to be version 4688 (which would equate to v7 c8784), dated July 2018. BCM4350C5_003.006.007.0221.4688_v8784.hex.zip In BrcmPatchRAM2 kext, the FirmwareKey for device 0a5c_6412 in Info.plist file must be updated to "BCM4350C5_003.006.007.0221.4688_v8784" Edit: reverted to uncompressed .hex firmware file.
  25. 1 point
    Yes, it's been known for years and quite frequently/widely mentioned here and at other forums too. https://osxlatitude.com/forums/topic/3181-carbon-copy-cloner-and-chameleon-boot-loader/?tab=comments#comment-24428 https://osxlatitude.com/forums/topic/907-usb-configuration-seagate-hybrid-install/?do=findComment&comment=6248 https://osxlatitude.com/forums/topic/2836-how-to-dell-inspiron17-3721-fully-working/?do=findComment&comment=30498
  26. 1 point
    Ok, I downloaded the latest driver for DW1820A I could find on Dell's web site here (Win7 64bit for XPS 9350, dated May 2019). I extracted the firmware 1707 for our 0A5C:6412 DW1820A device: BCM4350C5_003.006.007.0095.1707_v5803.hex.zip All you need to do then is: copy the uncompressed .hex firmware file to the Resources folder of BrcmFirmwareRepo kext to supersede current version 1703 (=v7 c5799) update the key for device 0a5c_6412 in Info.plist file of BrcmPatchRAM2 kext After repairing permissions and rebuilding the cache, I can now connect to my JBL USB speaker without issues: This firmware version 1707 (which equates to v7 c5803) seems to be quite old (dated December 2015) but works Ok nevertheless. I'll try and lookup for a more recent firmware than that one. Edit: reverted to uncompressed .hex firmware file.
  27. 1 point
    BCM4313 chipset is not supported. You can find a list of supported / unsupported cards here https://osxlatitude.com/forums/topic/11138-inventory-of-supportedunsupported-wireless-cards-2-sierra-catalina/
  28. 1 point
  29. 1 point
    add it to the other folder in your EFI/CLOVER/KEXT folder and also S/E
  30. 1 point
    Add this kext and see if it fixes the trackpad VoodooPS2Controller-R6RC2.kext.zip
  31. 1 point
    I have an issue with Mojave 10.14.5 on my E6540:- I got rid of the CD Drive and replaced it with a Caddy SATA drive to use a 2nd internal SSD. The second SSD not recognized by the MacOS but it is recognized correctly by Windows. The SSD drive is actually recognized if I use a normal SATA to USB adapter under MacOS but not when its inserted as an internal HD using the Caddy. I have just tried the kext in this post and its still not recognized actually !. NEVERMIND, I got it to work using the kext mentioned. I needed it to place the AppleAHCIPort.kext under S/L/E not Clover/Kexts/10.14
  32. 1 point
    Niresh is not vanilla, it's a Distro. Anyway, try this, replace attached into /EFI/Clover 5548_Mojave.zip
  33. 1 point
    @Saksham2000 You're using a Distro for a Desktop system, worst combo. I assume because you don't have a real Mac to make your own vanilla installer? Well since you now have a booted MacOS, you can download the latest Mojave and create a new Installer following the vanilla guide I'll send you a new bootpack.
  34. 1 point
    Hi, I have also DW1820A part # CN-0VW3T3, but 1028:0023. I was able to get it to work by clover hack injecting: ... <key>compatible</key> <string>pci14e4,4353</string> ... it works without AirportBrcmFixup and brcmfx-driver=1. But I want to get to work also Apple Watch unlock. Problem is, that with pci14e4,43a0 system not booting. I tried it also with AirportBrcmFixup and brcmfx-driver=2, but still no luck. With brcmfx-driver=1 system boots but it says, that WIFI HW is not present. Did you use FixAirport and AddDTGP? I can work without this hack, because my path is <key>PciRoot(0)/Pci(0x1C,0)/Pci(0,0)</key>, but may be without this fixes pci14e4,43a0 not working? I just guessing. Thank you for any suggestion. BTW. I also found wifi card BCM943602CS that is newest and have 14e4:43ba, but this also not working for me.
  35. 1 point
    Kabylake requires a minimum of Sierra 10.12.6 to run See sources here If you want El Capitan, you might succeed by faking the CPU as Skylake, but will need a minimum of 10.11.4.
  36. 1 point
    Questions still arise about this matter so here's a recap of what caching kexts and injecting kexts (through Clover) mean: 1/ Caching kexts: Kexts placed in /L/E and/or /S/L/E are cached in the kernel cache (or prelinked kernel) which aims to accelerate boot time. Cached kexts are subject to signature by Apple and must be set with the correct permissions (Cf. our FAQ topics on permissions). Cached kexts will be shown/listed/registered in System Info (ex-SysProfiler) -> Software -> Extensions. Caching kexts is the recommended scheme for all add-on kexts. /S/L/E is the location for Apple's own (i.e. vanilla) kexts. Ideally, this should be left untouched by Hackintoshers unless for very specific and rare reasons (eg: patched AppleHDA). /L/E is the location for 3rd party/add-on kexts. This is where all kexts we use for our Hackintoshes should go. Add-on kexts should only be placed in either folder, never in both. 2/ Injecting kexts through Clover: Injected kexts are not cached and will not be shown/listed/registered in System Info (ex-SysProfiler) -> Software -> Extensions. Injecting kexts results in a slightly slower boot than caching kexts (though many would arguably say it's hardly noticeable). Kexts injection operates according to Clover settings on the matter: If kext injection is set to Yes, kexts placed in E/C/K/O (or E/C/k/10.xx) will be injected. If kext injection is set to No, no injection takes place; obviously... If kext injection is set to Detect, kext injection operates according to the presence of FakeSMC in the kext cache (the kext having been poperly installed in /L/E or /S/L/E). If present, no injection takes place, if absent, kext injection is performed. If kext injection is used, make sure the kexts aren't cached at the same time. Clover's E/C/k/O and E/C/k/10.xx are the locations for kexts that Clover injects at boot time: E/C/k/O is used to inject kexts regardless of the OS X/macOS version. E/C/k/10.xx are used to inject kexts for the given OS X/macOS version and therefore allow different kexts to be injected for different versions. Kext injection is very useful for recovery purposes (like booting without cache which ignores /L/E) or when testing kexts for instance; if a newly injected kexts causes issues (like a KP), it's very easy to remove/bypass it. On the other hand, kext injection is known to occasionally cause problem because it's not the natural way in which kexts should be loaded. Kext injection is basically a form of forced loading and, sometimes (though rare these days), it does not work. My own recommendation is to experiment with kexts through injection and, once kexts are validated, to cache them from /L/E. Google for this kext injection matter or consult the Clover wiki/InsanelyMac forum. It's all quite widely documented.
  37. 1 point
    I've found something interesting for settings via PrefPane So, who has an empty prefPane when you installed a fresh copy of modern system 10.12+ and you want to make some settings in it. Like to enable Clicking. By default PrefPane saves it's settings in plist file located at ~/Library/Preferences/com.apple.AppleMultitouchTrackpad.plist and by default sometimes earlier you can enable Clicking via Terminal: defaults write com.apple.AppleMultitouchTrackpad Clicking -bool true but something went wrong (AAPL cheers) and a Key 'Clicking' has a wrong value format. It should be bool but has an integer. So we have to fix this issue integer --> bool Open this file with your editor.app (PlistEdit for ex) and fix this: to this and then reboot or reenter account. Voila! Your prefPane will work properly. EDIT: Also I tried to revert this value format to the wrong one (integer --> 0) and reentered acc. PrefPane worked after all. Setting 'Tap to click' was enabled but no clicking was physically. Then I tried two commands: defaults write com.apple.AppleMultitouchTrackpad Clicking -integer 1 defaults write com.apple.AppleMultitouchTrackpad Clicking -int 1 without success. Then unchecked 'Tap to click' and prefPane automatically fixed in it's plist integer (0) --> bool (false). Checked it once more to enable Clicking and voila: plist file has bool (true) and everything is working fine.
  38. 1 point
    Further to new information posted here, it appears that calling on AirportBrcmFixup with boot option brcmfx-driver=1 (to force BRCM4360 kext rather than BrcmNIC) allows to run Ok with some if not all those DW1820a cards that were reported to cause performance degradation and system freeze after a few minutes. Using that add-on kext + boot option allows me to use the CN-096JNT card without clogging the Hackintosh too a halt. I only experienced 2 x brief wireless disconnections during which system appeared to briefly freeze or, at least, the USB ports froze (hence mouse frozen) but all resumed after wireless automatically reconnected a few seconds later. I've updated the above posts accordingly.
  39. 1 point
    Last update: 22 May 2019 I received the CN-096JNT. Once plugged in, I was actually surprised to see it carry subsystem id 1028:0021, not 1028:0022 as expected (I've modified post #2 to that effect). Once fitted in, the card seemed to perfectly Ok without any issue at all in my Latitude 7490, just like my other 2 x CN-0VW3T3. However, after 5 to 10mins, CPU got clogged up to full speed and laptop grounded to a near-halt and became unusable. This was reproduced systematically as previously reported for the CN-08PKF4 model. Further to a report by @DalianSky here, I can confirm that the workaround is to cache or inject AirportBrcmFixup and use brcmfx-driver=1 boot option. The card can then be used without killing its host although some occasional brief and unexplained wireless disconnections may be experienced. These can be expected to be accompanied by brief USB disconnections/freezes until wireless network is reconnected. MAC address OUI for that card is AC:E0:10. -> Ok-ish 'beginning to wonder if manufacturer's OUI wouldn't have a part to play in all this too...
  40. 1 point
    I got to test the Dell WD15 USB Type-c docking station today. Supported OOB: HDMI, mini-DP and VGA outputs GigEthernet RJ45 port (Realtek RTL8153 USB3-to-Ethernet converter, 0x0bda:0x8153) Rear USB2.0 ports Rear USB3.0 port Front USB3.0 port Front headset jack Unsupported: Rear line-out jack (tried various layouts to no effect) Regarding VGA output: VGA worked OOB as single connected display, laptop booted lid closed. VGA worked as 2nd display only if connected at startup (it's quite usual for VGA not to work if connected after system has started). VGA worked alongside DP and/or HDMI but only in clone mode, not as 2nd or 3rd display. This is something apparently done at docking station level. Dell manual states it's the expected mode in 3 x displays setup but, in my case, this was experienced only with DP connected, laptop's lid closed. Front headset output: VGA output (lid closed): DP/HDMI output (lid closed, with or without VGA): Dual display, built-in LCD + VGA: Dual display, built-in LCD + DP or built-in LCD + HDMI:
  41. 1 point
    Last update: 03 Jul 2019 Specifications: BIOS 1.8.0 1.9.3 1.10.0 (needs SATA in AHCI mode, not RAID or disk won't be seen) Intel 8th gen Kaby Lake R quad-core i7-8650U 1.9GHz CPU (Turbo boost up to 3.9GHz for 3 & 4 cores and up 4.2GHz for 1 & 2 cores) integrated Intel UHD620 GPU 300-1150MHz (PCI ven id 0x8086, dev id 0x5917) 14" 1920x1080 FHD non-touch LCD 16Go DDR4-2400 RAM M.2 2280 512GB SATA SSD (in socket M) Intel i219-LM Gigabit Ethernet (PCI ven id 0x8086, dev id 0x15d7) Realtek ALC256 (ALC3246) High Def audio (PCI ven id 0x10ec, dev id 0x0256) Intel Wireless-AC 8265 M.2 combo wireless card (PCI ven id 0x8086, dev id 0x24FD) + Bluetooth 4.2 PCI ven id 0x8087, dev id 0x0a2b) Dell DW1820A M.2 802.11ac combo wireless card (PCI ven id 0x14e4, dev id 0x43a3) + Bluetooth 4.1 (PCI ven id 0x0a5c, dev id 0x6412) integrated Realtek HD webcam (USB internal, PCI ven id 0x0bda, dev id 0x5650) integrated Realtek RTS525A microSD 4.0 card reader (PCI ven id 0x10ec, dev id 0x525a) Alps I2C HID Multi-Touch Touchpad (PCI ven id 0x1028, dev id 0x081c) Alps I2C HID TrackPoint (PCI ven id 0x044e: dev id 0x1212) 1 x M.2 2230 WLAN slot (socket A) 1 x M.2 2242 WWAN slot (socket B ) 1 x 3.5mm universal jack (combo audio) 3 x USB 3.1 gen1 ports Type-A (right port with PowerShare) 1 x HDMI 1.4 port 1 x DisplayPort on USB Type-c Lat7490:~ admin$ lspci -nn 00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [8086:5914] (rev 08) 00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) 00:04.0 Signal processing controller [1180]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem [8086:1903] (rev 08) 00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller [8086:9d2f] (rev 21) 00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Thermal subsystem [8086:9d31] (rev 21) 00:15.0 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 [8086:9d60] (rev 21) 00:15.1 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 [8086:9d61] (rev 21) 00:15.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #2 [8086:9d62] (rev 21) 00:15.3 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #3 [8086:9d63] (rev 21) 00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-LP CSME HECI #1 [8086:9d3a] (rev 21) 00:16.3 Serial controller [0700]: Intel Corporation Sunrise Point-LP Active Management Technology - SOL [8086:9d3d] (rev 21) 00:17.0 SATA controller [0106]: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] [8086:9d03] (rev 21) 00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 [8086:9d10] (rev f1) 00:1c.2 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #3 [8086:9d12] (rev f1) 00:1f.0 ISA bridge [0601]: Intel Corporation Sunrise Point LPC Controller/eSPI Controller [8086:9d4e] (rev 21) 00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-LP PMC [8086:9d21] (rev 21) 00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21) 00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21) 00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (4) I219-LM [8086:15d7] (rev 21) 01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01) 02:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4350 802.11ac Wireless Network Adapter [14e4:43a3] (rev 08) NB: The E7490 is able to boot from microSD card in Legacy mode but, unfortunately, the RTS525a is not supported under OS X/macOS.
  42. 1 point
    I initially installed Mojave on an external USB3.0 HDD in order to avoid messing with the Win10 installation that's on the built-in M.2 SATA SSD. Given that the Latitude 7490 can boot from microSD card (needs Legacy boot enabled in BIOS), I installed Clover and the 7490 pack on an old 2GB microSD card I had lying around. Card was initially reformatted FAT32. I now use it to boot Mojave from a freshly created partition on the SSD without having had to mess around with the Win10 Boot (EFI) partition. It works great.
  43. 1 point
    Update the Mojave guide with a tuned-up Clover pack: removed unnecessary SSDTs removed unnecessary patches removed unnecessary settings added NoTouchID kext to fix authentication lag when making changes to /LE and/or /S/L/E replaced I2C kexts to fix TouchPad laggy/jumpy movement
  44. 1 point
    I've got it working I only needed to generate an AppleBacklightInjector.kext. After installing the generated kext I have full brightness control. DSDT + Kext.zip
  45. 1 point
    Last update: 16 Apr 2019 Target macOS release: Mojave 10.14.4 (at time of writing) This is a Clover-based installation using the well-known/well documented vanilla method detailed below: Working: full graphics acceleration on Intel UHD620 iGPU, including brightness control (with Lilu v1.3.5 + WEG v1.2.7) multi-display with HDMI OOB, including HDMI-to-DVI adaptation (HDMI-to-VGA not successful) audio, including HDMI, microphone input and headset output (with AppleALC v1.3.6 & layout 11 + CodecCommander v2.7.1) GigEthernet LAN connection (with IntelMausiEthernet 2.4.0 kext) wireless and bluetooth with any compatible card (a DW1820A in my case) left and right USB ports (OOB) integrated webcam (OOB) CPU power management sleep (Lid, Energy Saver settings, Apple menu, Fn-Insert, PWR button) & wake (Lid, PWR button) battery management (with ACPIBatteryManager v1.90.1) keyboard (with VoodooPS2Controller v1.9.2) touchpad (with VoodooI2C v2.1.4 + VoodooI2CHID v1.0), including tap-to-click (mandatory in PrefPane settings), scroll & zoom, rotate or other multi-finger gestures Not working: RTS525a microSD card reader Touchpad buttons TrackPoint Not tested: DP over USB Type-C display output GeekBench v2.4.3 (32bit) gives a 14200+ rating: 1) 10.14 USB installer creation Using a USB key of 8GB minimum, create a Mojave USB installer through the following Terminal command: sudo <path>/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/<USB key> where: <path> = location of Mojave installation package (eg: /Applications if freshly downloaded) <USB key> = name of formatted USB volume (eg: USB_8GB) The process will take several minutes. Once completed: install Clover bootloader on the USB installer with the following customised settings: Clover for UEFI booting only Install Clover in the ESP UEFI Drivers AudioDxe-64 DataHubDxe-64 FSInject-64 SMCHelper-64 ApfsDriverLoader-64 AppleImageLoader-64 AptioMemoryFix-64 Fat-64 HFSPlus NvmExpressDxe-64 PartitionDxe-64 Ps2MouseDxe-64 UsbKbDxe-64 UsbMouseDxe-64 Themes (optional) Install Clover Preference Pane (optional) you may use version r4919 attached below: Clover_v2.4k_r4919.pkg.zip once Clover is installed, launch Clover Configurator app and mount the freshly created EFI partition of the USB installer Clover_Configurator.zip open this EFI partition and transfer the files & folders from the Latitude 7490 Mojave Clover pack below to the EFI/Clover folder: Clover_Pack_7490.zip Clover_Pack_7490_#2.zip Clover_Pack_7490_#3.zip Clover_Pack_7490_#4.zip Clover_Pack_7490_#5.zip 2) 10.14 installation boot the Mojave USB installer at the Clover main menu, select the "Install macOS Mojave" partition (but don't press [ENTER]) press [SPACE], select -v verbose option in the menu, then choose to boot with the selected options proceed with installation, creating & formatting the target Mojave installation through Disk Utility as/if required on 1st reboot, boot off the USB installer and select the freshly created "macOS install from <target Mojave partition>" repeat this until this partition is no longer offered and only the target Mojave partition is left to boot Reboot the target Mojave partition via your USB installer 3) Post-installation tuning Once the target Mojave partition has booted, complete the 1st boot configuration tuning Once at the desktop, install Clover bootloader on the Mojave partition/disk with the customised settings listed above Once Clover is installed, launch Clover Configurator app and mount the freshly created EFI partition of the Mojave partition/disk Open this EFI partition and transfer the files & folders from the above Latitude 7490 Mojave Clover pack to the EFI/Clover folder You may then reboot and verify that Mojave boots off your disk through Clover
  46. 1 point
    Hi all, We have successfully upgraded the forum to latest IPboard version 4.4.2. The current default theme is still buggy. We will upgrade the theme to the latest OSXL 2018 v1.07 later today. Thank you all for your patience. Best regards, Syonagar
  47. 1 point
    Morning everyone, Things are moving forward as planed and some cool things will come over the corse of this week,. IPboard upgrade: First of all - we are testing the latest 4.4.2 of IPboard over att http://dev.osxlatitude.com - so faar it seems a few theme issues will have to be fixed - but besides that it looks good.. so expect and upgrade later this week New server: OSXL will be moving to a new hosts - so faar we have been on shared hosting - usually sponsored - but have now decided to move to our own box - this will improve performance but also allow us to integrate features and new services better - the server move is expected to happen with the next two seeks. Discord: Join us on discord - IPboard and the forum is awesome .. a great solution.. but why not take the chance to hang out with the rest of us.. Joins us at: https://discord.gg/Wz7EU3
  48. 1 point
    Hi again my friends... Now I'm working in new hack from Asus G750JX. All work, but have same issues and don't can fix it. I need some help to fix. I upload files. Issues: - Don't can get shutdown. - Don't go to sleep. - AR9285 is working, but don't can create iCloud account. Solved - Bluetooth is detected, but not can found devices. Solved 50% - I use Asus G75VW bat fix from Rehabman repository to fix battery, but don't ups to 100% and when I unplug AC power, the icon does not change its status. Solved. Thanks in advance... I Delete old files and upload new files. Send me MacBook-Pro-de-Antonio.zip
  49. -1 points
    A first-time Hackintosher needing some assistance. Could anyone assist with the necessary kexts and config.plist required to get to boot? Two weeks in and I'll take anything I can get right now even if it's for Sierra, HFS or APFS. LAPTOP specs: Dell Latitude E6520 - i7-2620M - 8GB RAM - HD3000 - NVS 4200 - Crucial 525GB SSD - WD 250GB HDD Finally got a bootable High Sierra image from Hackintosh Zone and able to boot into clover, though get stuck during boot using either legacy or UEFI. Using Legacy I get the 'Still waiting for root device error' - Applied the USBBusFix flag, aptiofix to no avail with UEFI I get the prohibited sign (Verbose mode does reveal some other error) FakeSMC is added. I've tried the Sandy-Bridge config.plist as well as generic ones for legacy & UEFI to no avail I've attached my current EFI folder, EFI_CLOVER.zip
This leaderboard is set to Amsterdam/GMT+02:00
  • Create New...