Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation since 12/07/10 in all areas

  1. 6 points
    Last update: 17 Sep 2017 UPDATE: 17 - 09 - 2017 Just wanted to clear few things about my commitments to community, and development on my projects which has been going slow due to my personal life as I have been hit really hard since an year, and I am trying to sort out personal things still. So decided to take timeout on my commitments to my projects and put my attention on personal life first. Don't expect any regular updates on this project and others projects of mine till end of this year 2017. It does not mean I will not be working, and it is just that I won't post any update or respond to you all unless I have something worth to share. I know many of you are disappointed with me and some of my choices/decisions for the last one year, but believe me I had no other option and good reason for that. So your patience will be rewarded properly once I have started releasing updates as I have big plans and willing to commit myself to long term development, and I apologize for not keeping up with promises so far. In case I fail to keep up like I promised above, then I will give up and release all of my work to others to continue. Hope you understand and support me with beta tests when I need them Thanks Hi everyone, This is a multitouch driver for ELAN, FocalTech and Synaptics touchpad for Mac OS X based on the documentations available and some ideas from VoodooPS2, ApplePS2 and Linux open source code. I have successfully accomplished everything so far and added many new features to take advantage the touchpad completely to make it close to Apple touchpad in every way. Also my driver is implemented with my own universal logic for all the features, so it can be adapted to all touchpads easily and I'm still improving these to achieve even better results. My driver supports every hardware version of ELAN touchpads except version 1 (which is too old and can't find in existing notebooks will support that if i get some testers), mostly all available FocalTech touchpads and Synaptics touchpads (still experimental) with firmware version v7.5+. NOTE: For Synaptics, it was developed based on my touchpad hardware i have, so support is limited to touchpad with firmware version 7.5+ only, but will try to improve support other hardwares also if users interested in my features and help me with beta testing. FOR BUG REPORTING: Please read the below threads which explain the features after installing the driver, so you can understand and learn how to use every feature. If anyone still have doubts/issues then PM me to get help from myself (or) post them in other thread about issues so others can help you. I will respond to you mostly during weekends only for some time. FEATURES DETAILS: (UPDATED FOR v4.6) Touchpad features: Click here to learn Keyboard features: Click here to learn Supports OS X version 10.6 or later (10.6 support is only from v4.4) For Prefpane, try to install the version from this link, and add the prefpane to start up items: http://www.hackintosh.zone/file/997-correct-preference-pane-trackpad-macos-sierra/ UPDATE: 06-06-17 Hi everyone, It has been long time since I have given you all an update on my development. The reason for this was I had a pretty rough personal life and busy time in my job last few months, so I was really under big stress and had busy days which did not allow me to do any progress on my projects. Good news is that I was able to sort some of my issues, and find some time to continue my projects again. I have already done some analysis on my project, and figured that I had to do some major code rewrite (most of the code was depending around work arounds which are not optimized well for the time being back then) in order to better support future hardwares and also improve features with ease. My plan is Setup a way to support and track bugs from users Setup a way to gather feedback from users Re-build the project from the scratch with good design for cross-platform support in mind, to support multiple touchpad vendors and interfaces (thinking about I2C) as universal driver Refactor the project code with as much clean code (so when I make it open others can understand) as possible of mine from the scratch Finish basic features (Keyboard and Mouse emulation) Integrate basic vendor specific features Develop and Integrate basic prefpane of mine Release first beta to test Integrate and implement my old driver features one by one for better stability Update prefpane for new features and release another beta Update and improve support for newer hardware based on linux and other sources Finish integrating all the features of old driver by reviewing each one with community feedback Add new features and improve it's stability and performance I have big list of TODO's, but I promise this time that I will try to finish each of them as soon as possible with a beta release happening very soon before the end of this month in best case. Understand your patience is really needed here, as I do not want to rush and have limited time of mine. Also, I am gonna give weekly update on my progress if possible when I have finished my milestones. I will try to respond to your PM during weekends, and if you want to be beta tester then send me your skype ids with GMT time via PM. One more thing, current version of my driver is deprecated and so will not be continuing this. But, I will try to give you some support if there is a need before I finish my new version of driver for any issues which are not big enough for time being. Thanks for your support and co-operation. PS: Sorry for those who want my project to be open sourced now, as I cannot do that until I finish above TODO's. Hope you understand, and support me as I really worked hard on this project. I have worries to get this open right now, and understand that with more people development can progress faster but opening this right now might create issues and end myself supporting to the development in the long run due to fragmentation. I would request you to go through plist editing for controlling the features (as I have a lot of them and its important users to know about those details, because it will allow the driver to be tweaked as you want and my default values are not going to be best for every touchpad or user) for now (will make my own prefpane very soon within 3 months, and its a promise). Going to update my thread which details the features every week one after another for keeping it updated with latest version. Version v4.7 beta 5 (10 - 12 - 2016) (work in progress, available to try from attachments). Added back feature multi finger drag due to users request (can be dragged using 1-3f, Note: This drag wont be as smooth as 1f because the data is not as good as 1f in 2-3f which is why I stopped working on this long time ago, but currently it works nicely and usable in my touchpad. So its usage varies to each touchpad). You have to hold fingers for 2-3 sec at fixed position and move to trigger drag. Improved support for Sierra Support for new style prefpane (most of the features wont control my feature, but I will fix them by next weekend to match them) [Drag, scroll, double click speed can be controlled inside Accessibility Settings->Mouse & Trackpad] [Experimental] USB mouse can now stop trackpad if you enable Accessibility setting of Ignore Trackpad [Works only in 10.10 or lower (?). Will find a way for new OS X versions asp] Improved scroll inertia with more control options in Plist to choose Fixed Sierra Caps Lock bug using a workaround Fixed a bug with some new ELAN touchpads which have issues with virtual buttons acting weird if pointing was enabled at button area, so added option to diable/enable this in plist Fixed sierra OS X functions like Launchpad, Dashboard, Mission control etc., which are not working by redirecting to new keyboard shortcuts. (Needs to be configured at Keyboard shortcuts) Updated support for Asus keyboard backlight with two levels Several minor bug fixes and improvements And more to come as am still looking at improving others things that are buggy and also using feedback from users Version v4.6.5 Released Major code optimizations Updated support for 10.12 (Still some Fn keys wont work, will try to fix close to release) Added plist options to control Apple Trackpad prefpane values for 10.12 Several bug fixes and improvements Version v4.6 Fixed CapsLock key change plist option Fixed a firmware bug in ELAN v3 hardware Updated driver to accept new revisions of ELAN Touchpad to be recognized as Version 4 Added plist option to disable the touchpad when LID id closed (Enable back auto when its opened)) which will stop strange behavior from touchpad when using HDMI in some systems. Pointer acceleration enhancements (new plist options to control) Partial support for the extra buttons and track point from Synaptics trackpad Improved support for synaptics Updated documentation for features Several minor bug fixes and optimizations Version v4.5 Added new plist option to control touchpad edges dead zone Added plist option to change 2f and 3f tap default actions Added option to tweak pointing acceleration Added 4f pinch gesture and plist option (ELAN and Focaltech) Updated plist options to better organize Improved 2f dragging in clickpads Improved edge swipes Fixed synaptic touchpad sleep issue seen in some systems Fixed some keyboard bugs Several improvements, minor bug fixes and optimizations Version v4.4.5 : Improved support for Synaptics touchpads (Clickpad working fine now) Updated support for new ELAN touchpads Improved edge swipes Fixed a bug with Karabiner app to allow mapping Several bug fixes and optimizations Version v4.4 : Released (For Asus keyboard backlight auto off, use updated DSDT patch and v2.5 Fn keys kext) Improved support for Synaptics touchpad (Clickpad still have some issues so i need beta testers) Improved support for some new ELAN and Focaltech touchpads Improved pointer acceleration Reworked scrolling Improved Swipes, Zoom and Rotations Added more plist options to tweak the gestures and option to control delay after sleep Added GIGABYTE Fn key mode layout Added support for 10.6 (32bit build) Fixed several bugs in both keyboard and Touchpad Optimizations Version v4.3 : Added support for Synaptics touchpads (Firmware v7.5+) found in new laptops but still its experimental for others as it has not been tested on many laptops. (Tested only on Lenovo Z50-70 and G400) Added support for unsupported touchpads to work in enhanced mouse mode without multi touch Improved support for Focaltech and ELAN touchpad (especially ELAN v2) Improved pointing and scroll with new smoothing features and other improvements which can be controlled in plist Improvements and optimizations for all features Added plist option for keyboard to make Num Lock into clear instead of soft controlled num lock mode Added Fn keys mode layout for Lenovo Added support for ACPI brightness controls from EC calls (You have to use DSDT patch) Fixed many bugs For the complete change log of all the updates follow this thread: https://osxlatitude.com/index.php?/topic/1966-elan-touchpad-driver-issues/ FEATURES OF ELAN v4 HARDWARE, FOCALTECH and SYNAPTICS: (Supports up to five fingers touch) Mouse mode with Virtual Buttons Left, Right and Middle Tapping - Up to 5 fingers Clicking - Up to 5 fingers Dragging : Tap to release and Finger Lift ⃠Left Button Drag, Double Tap Drag, Single Tap Drag and Click Drag Corner Tapping Scrolling - Single finger Edge and Two Fingers swipe Continuous, Linear, Sling and Inertial scroll effects Finger Press - Up to 5 fingers Swiping - Edge, Three and Four Fingers Zoom - Two fingers pinch zoom, OSX Zoom with Keyboard 4 (Elan, Focaltech) & 5 fingers Pinch gesture Rotations - Arc and Swipe Rotations Accidental Input/Palm check when typing Fn Keys Mode Features Toggle Full customization FEATURES OF ELAN v2 and v3 HARDWARE: (Supports up to three fingers touch) Mouse mode with Buttons Left, Right and Virtual Middle Tapping - Up to 3 fingers Dragging - Tap to release and Finger Lift ⃠Left Button Drag, Double Tap Drag and Single Tap Drag Corner Tapping Scrolling - Edge Scroll and Two Fingers Continuous, Linear, Sling, Circular and Inertial scroll effects Finger Press - Up to 3 fingers Swiping - Edge and Three Fingers Zoom - Two fingers pinch zoom, OSX Zoom with Keyboard Rotations - Arc, Circular and Swipe Rotations Accidental Input/Palm check when typing Fn Keys Mode Features Toggle Full customization HOW TO INSTALL: Remove any existing "ApplePS2Controller, VoodooPS2Controller, AppleACPIPS2Nub, ApplePS2Keyboard and old Elan Touchpad" kexts if you have already installed from the HDD '/System/Library/Extensions ', '/Extra/Extensions', and '/System/Extensions/Library/myHack.kext/Contents/Plugins/' (if you used myHack USB installer for OSX). If you use USB installer to boot (used to install OSX), then you have to remove the above kexts from USB '/Extra/Extensions'. Install the Kexts (Recommended to use Kext utility for installing) inside the attached zip file using any kext installing methods (In clover, some systems may have problems with kext injection, so try to install them to System/Library/Extensions in that case). 
 ​ NOTE: From v3.3, there is only one kext as my driver in the attached zip file. For Support PM me or POST here . I may respond slowly sometimes due to busy life. NOTE: Please don't mirror my files at other places, let the people know about this thread for the latest version and support. NOTE: I've worked very hard on this driver (especially ELAN v2, 4 and Focaltech without hardware) and will try to continue support in future. I do the development everyday with some time dedicated to this and many other projects. But i need your support so i can get more time to spend on these projects for improvements. Also we maintain this website without ads for all of you and it costs a bit for us to host. IF POSSIBLE PLEASE MAKE A DONATION BY CLICKING BELOW PAYPAL DONATE BUTTON FOR ME Paypal: FOR WEBSITE DONATE HERE: http://www.osxlatitude.com/donate/ THANKS FOR YOUR SUPPORT I would like to thank following people for beta testing the driver and providing valuable feedback: Leon, Ramalxlama, Shin zon, Sherlocks, Dragon, Ðнтошка, Thomas benhamou,68x, Eli and many others. SOURCE: Project source code: https://github.com/E...Touchpad-Driver I am still doing some major work with beta testers to improve the features and stability, so I cannot update my git until its done, because it may allow others to modify and distribute their own version which can miss my changes and also worried about something else too which I do not want to mention here. I want to support this project for very long time and did spend hundreds of hours so far with testers (without hardware) and implemented many of the features myself from the scratch. So, I deserve and have rights to not to update my project source until I feel confident. The base of the Apple PS2 open sources I have used for my project are pretty much same which you find in the source from my above git link and rest of the changes from that are based on documentation and my own ideas. CREDITS: ELAN - Arjan Opmeer for ELAN linux documentation/source FocalTech - mgottschlag (github) for linux source Synaptics - Synaptics official documentation and linux source I would like to thank the VoodooPS2 team (Slice, King, rehabman and many others who contributed to the VoodooPS2) for ideas, Apple for their PS2 open sources which i've used as base for my driver and linux sources for the touchpad initialization and packet info. SmoothMouse 1.0.5.zip mouseaccelerationpref11d.zip Apple Keyboard Layout ID.rtf ElanTouchpad_v2.8.3.zip ELAN_v3.8.5_Final_Upd.zip ELAN_v4.0.5.zip SmartTouchPad_v4.2_Final.zip SmartTouchPad_v4.3_Final.zip SmartTouchPad_v4.4_Final_64bit.zip SmartTouchPad_v4.4_Final_32_64bit.zip SmartTouchpad_v4.4.5_32_64bit.zip SmartTouchpad_v4.4.5_64bit.zip SmartTouchPad_v4.5_Final_64bit.zip SmartTouchPad_v4.6.zip SmartTouchPad_v4.6.5.zip SmartTouchPad_v4.7 beta 3.zip SmartTouchpad v4.7 beta 5.zip
  2. 6 points
    Mojave Mojave Guide Bootpacks - HD5500 Only Add this to /EFI/Clover replacing the old Exx50_Mojave.zip FYI, kexts in bootpack is outdated Make sure to 1st upgrade kexts found under /EFI/CLOVER/kexts/Other if you encounter issue Common links for new kexts: https://github.com/vit9696/Lilu/releases https://github.com/vit9696/Lilu/blob/master/KnownPlugins.md https://bitbucket.org/RehabMan/ - For Discrete Model Also add this to /EFI/Clover/ACPI/Patched SSDT-Disable-DGPU.aml.zip Follow Post Install above under Sierra Guide UPDATES Mojave 10.14.1 (18B75) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.2 (18C54) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.3 (18D42) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.4 (18E226) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover prior to update Mojave 10.14.5 (18F132) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover / update kexts prior to update Mojave 10.14.6 (18G84) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Install latest Clover / update kexts prior to update Repair permissions and rebuild cache
  3. 5 points
    High Sierra Clover Guide Warning: Follow guide at your own risk, I hold no responsibility if you brick your system or destroy all data during the process. If you're creating the installer from a real Mac, make sure you don't accidentally select the real Mac drive when installing Clover loader. It may cause your Mac to not boot again. You've been warned! New Installation Note: By default, upgrading or new Install of HS on an SSD drive, it'll automatically convert to APFS format. If you want to use APFS format, skip step 4 (1) Create the USB installer via Terminal with "createinstallmedia" (a minimum of 16GB UFD is needed or an external USB drive) sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/"target_USB" --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction Note: target_USB = name of the USB drive you're writing to (2) Install Clover with following config, add appropriate Sierra bootpacks Only + Generic EFI from post #2 above ( See note1 below for updating bootpack for HS if there isn't one for your model in post #2) UEFI: Install for UEFI booting only Install Clover in the ESP UEFI Drivers\Recommended Drivers ApfsDriverLoader AptioMemoryFix AudioDxe DataHubDxe FSInject HFSPlus SMCHelper (leave off if you have VirtualSMC.kext in bootpack) Additional drivers PartitionDxe Themes (Optional) Install Clover Preference Pane (Optional - only available on installed disk, not installer) Legacy: Install Clover in the ESP Boot Sectors Install boot0af in MBR Clover for BIOS (Legacy) booting CloverEFI 64-bits SATA BIOS Drivers, 64 bit\Recommended Drivers ApfsDriverLoader AudioDxe FSInject HFSPlus SMCHelper XhciDxe Themes (Optional) Install Clover Preference Pane (Optional - only available on installed disk, not installer) (3) Boot with the USB installer, start Disk Utility and initialize your SSD as an APFS drive. Close Disk Utility, select Install MacOS. If you DO NOT want APFS, then select HFS+ format instead. Then Close Disk Utility and follow step 4, otherwise continue to Step 5 (4) Open the terminal (on the menu bar click Utility>Terminal), and launch this command /Volumes/"Image Volume"/"install macOS High Sierra.app"/Contents/Resources/startosinstall --volume /Volumes/"HighSierra" --agreetolicense --converttoapfs NO Note: HighSierra = name of the drive you're targeting (5) System will auto reboot after files has been copied (6) Boot with USB installer, select "Boot macOS Install from HighSierra". Installation will continue installing and reboot (Might have to do this rebooting a couple of times) (7) Boot with USB installer, finish the customization (8) Follow post install steps from Post # 1 NOTE1: Updating the Sierra Bootpack to be use for High Sierra unless there's a High Sierra bootpack already 1) Edit config.plist from Sierra Bootpack (I recommend using Clover Configurator 4.59 or newer) and activate FixHeaders option under Acpi: 2) Update USB port limit for High Sierra where applicable, if current Sierra Bootpack doesn't have it, then you don't need this. Either disable 10.12 (Red) and add 10.13 (Green - 9 or 100 Series) or modify 10.12 to 10.13 port limit Update: New USB port Limit patch for 10.13.4(5) and 10.13.6 credits to PMHeart 3) Under SMBIOS, update the definition so that Firmware Features and Firmware Feature Mask is now populated 4) [Recommended] Update the Sierra kexts under /EFI/CLOVER/kexts/Other/ Common links for new kexts: https://github.com/vit9696/Lilu/releases https://github.com/vit9696/Lilu/blob/master/KnownPlugins.md https://bitbucket.org/RehabMan/ Upgrading to High Sierra and keeping HFS+ format If you want to keep HFS+ format, run this command instead of launching the "Install MacOS High Sierra.app" /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --agreetolicense --converttoapfs NO If you want to install or upgrade to a different partition/drive /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/startosinstall --volume /Volumes/"targetdrive" --agreetolicense --converttoapfs NO Note: Repair permission and rebuild cache if you lost audio after upgrade. You must upgrade Clover, Config.plist and kexts as noted in NOTE1: Updating the Sierra Bootpack to be use for High Sierra When posting for HELP, please include full system specs and attach debug files. If you're not able to start the installer, then attach the Clover folder and include screenshot(s) of the error / KP by booting with verbose + debug 0x100 mode
  4. 4 points
    I initially installed Mojave on an external USB3.0 HDD in order to avoid messing with the Win10 installation that's on the built-in M.2 SATA SSD. Given that the Latitude 7490 can boot from microSD card (needs Legacy boot enabled in BIOS), I installed Clover and the 7490 pack on an old 2GB microSD card I had lying around. Card was initially reformatted FAT32. I now use it to boot Mojave from a freshly created partition on the SSD without having had to mess around with the Win10 Boot (EFI) partition. It works great.
  5. 4 points
    Give this a try, replace into /EFI/Clover E5530_Mojave.zip
  6. 3 points
    A few things are required to successfully run macOS Catalina on a Hackintosh, whether through a new/fresh installation of a direct upgrade from a previous OS X/macOS version/release. 1/ Embedded Controller: As mentioned here by MaLd0n at InsanelyMac, since beta #5, macOS Catalina requires Embedded Controller (EC)-related patching for many computers. It's therefore important to check your Embedded Controller device (aka "PNP0C09" id) in DSDT/ACPI and apply the mandatory device renaming to "EC" in Clover's config (or directly in DSDT), failing what, Catalina will never boot. For instance, most Dell laptops since the era of the Latitude E4x00/E5x00/E6x00 range have an Embedded Controller device called "ECDV" in DSDT; in Clover, the necessary ACPI device renaming is as follows: Description: Changes ECDV to EC Find: 45434456 Replace: 45435F5F Other known names for the Embedded Controller include "H_EC" or "EC0". If you find no Embedded Controller device in ACPI, this patch is not necessary. 2/ Clover: Clover needs to be at a minimum version supporting Catalina. Versions r503x, r504x and r505x are generally Ok. At the date of general release of Catalina, we recommend using Clover r5093 as the minimum version. Clover versions are available off Dids' Github repo. 3/ Add-on kexts: Lilu and associated plugins also need to be at versions updated for Catalina. At time of writing, we recommend the following minimum versions, all available off Acidanthera's Github repos: Lilu v1.3.8 Whatevergreen v1.3.3 AppleALC v1.4.2
  7. 3 points
    Hi all, I am very excited to finally hack this world famous GPU mining motherboard and pleased to share with you all the clover bootpack. Specifications Asrock H81 BTC Pro Ver 2.0 4th Gen 3.5 GHz i3-4330 8 GB DDR3 1600 MHz Memory Intel Graphics HD 4600 HDMI output on 24-inch LED Monitor (1920 x 1080) Clover Bootpacks Catalina Support for Mac OS Catalina 10.15 (Clover 5070) CLOVER-10.15.zip Support for Mac OS Catalina 10.15 Beta (19A471t) (Clover 4945) CLOVER-10.15 Beta (19A471t).zip Mojave Support for Mac OS Majave 10.14.6 (Clover 4945) CLOVER-10.14.6.zip Support for Mac OS Majave 10.14.5 (Clover 4934): CLOVER-10.14.5.zip Support for Mac OS Majave 10.14.4 (Clover 4910): CLOVER 10.14.4.zip Support for Mac OS Mojave 10.14 Beta 4 18A326h (Clover 4586): CLOVER 10.14 Beta 4.zip Support for Mac OS Mojave 10.14 Beta 18A293U (Clover 4517): CLOVER 10.14 Beta.zip High Sierra Support for Mac OS High Sierra 10.13.6 (Clover 4635) CLOVER 10.13.6.zip Support for Mac OS High Sierra 10.13.4 (Clover 4428) CLOVER-V4.zip Support for Mac OS High Sierra 10.13.2 (Clover 4360) CLOVER-V3.zip Support for Mac OS High Sierra 10.13.1 (Clover v4293) CLOVER-V2.zip Support for Mac OS High Sierra 10.13.1 (Clover v4293) with Intel Graphics: CLOVER-Intel.zip Support for Mac OS High Sierra 10.13.1 (Clover v4293) with ATI Graphics: CLOVER-ATI.zip Notes on Mac OS Catalina 10.15 (1) Everything works (2) Updated clover, efi drivers & kexts to latest version (3) Swapped from FakeSMC to VirtualSMC Notes on Mac OS Catalina 10.15 Beta (19A471t) (1) Everything works (2) Whatevergreen.kext requires graphics injection from Clover Notes on Mac OS Mojave 10.14.5 (1) Everything works (2) Mac OS 10.14.5 Update Installer now complaints "Cannot Find Installer Resources". A very crude workaround is to remove all other hard drives except for the Mac OS hard drive. Let me know if anyone find a solution to this without having to open the casing each time we want to update. Notes on Mac OS Mojave 10.14.4 (1) Everything works (2) Whatevergreen.kext now autodetects the graphics card. Make sure no graphics injection is done in Clover. Notes on Mac OS Mojave 10.14 Beta 4 18A326h (1) Everything works (2) Updated from Mac OS Majave 10.14 Beta 18A293U via Software Update in the System Preference. Notes on Mac OS Mojave 10.14 Beta 18A293U (1) Everything works including sleep. (2) Dedicated GPU Radeon Pro 560 not displaying on monitor. May need to wait for WhateverGreen.kext to be updated with support for this Mac OS version. Notes on Mac OS High Sierra 10.13.1 (1) Everything works including sleep. (2) Updated all kexts to latest versions (3) Added IntelGraphicsFixup.kext and Shiki.kext (4) Combined all ATI & Intel GPU configs & kexts into single bootpack for multi GPU support (5) For those that need to update 10.13 to 10.13.1, you will need to install the latest clover (version 4293 is the one I used). If there are error messages, you may try to remove EmuVariableUefi-64.efi from Clover EFI temporarily, clear NVRAM using sudo nvram -c in terminal, download the update directly from apple website and install. Notes on Mac OS High Sierra 10.13.2 (1) Everything works including sleep. (2) Updated all kexts to latest versions (3) For those updating from 10.13.1 to 10.13.2, you will need to install the latest clover and lilu including plugins (or download latest bootpack above) as well as download and install the update directly from apple website. Updating via App Store doesnt seem to work for me as I get the mkpg not found error message after reboot. Notes on Mac OS High Sierra 10.13.4 (1) Everything works including sleep. (2) Updated all kexts to latest versions (3) For those updating from an earlier version of 10.13 to 10.13.2, you will need to install the latest clover and lilu including plugins (or download latest bootpack above) as well as download and install the update directly from apple website. The OS X installer will reboot several times. Notes on Mac OS High Sierra 10.13.6 (1) Everything works including sleep. General Notes (1) The UEFI Bios does not detect Clover EFI natively. For first boot into Mac OS, you will need to boot Clover EFI using the Installer USB. In order to add Clover EFI into UEFI Bios, you will need to manually add it using the Clover UEFI shell using the following command:- (a) bcfg boot add 3 fsX:\EFI\CLOVER\CLOVERX64.EFI "Clover" (You will need to replace X with the location of your Clover EFI partition. This is shown in the list when you first enter the UEFI shell) (b ) Lastly, do bcfg boot mv 3 0 to move the Clover boot order to the first. (2) I found that this motherboard is very compatible with Mac OS and patched DSDT / SSDT is not required. Notes on Mining (1) As all you miners know, this motherboard can take up to six (6) GPUs, I have yet to test additional GPU on the PCIEx1 slots. At the moment, the single GPU that i'm using is installed on the PCIEx16 slot. I will test it once I have opportunity to get additional GPU. In the mean time, for those miners who already have this motherboard in their rig and are already using Windows or Linux, Mac OS may be a good OS to try since some miners (like ethereum's ethminer) are also released for Darwin and both NVIDIA and ATI have provided drivers for their latest GPUs. This does open up a good possibily of using Mac OS for GPU mining! (2) I was able to use the dedicated RX560 GPU for both as primary display as well as for mining. However, it causes the system to slow down and created artifacts when I rebooted / shutdown. I was able to make the system more stable by using the integrated HD4600 GPU as primary display and the dedicated RX560 GPU for mining. In order to use both integrated GPU and dedicated GPU, both Intel and ATI need to be injected by Clover. In the case of ethereum miner, ethminer was able to recognized all GPU but I only selected the RX560 for mining. This made the system more stable. (3) [10-11-2017] I just installed a third old AMD Radeon HD 7750 GPU on the first PCIEx1 slot and am very happy to see that Mac OS recognized it straight away. In the case of ethereum miner, ethminer was able to recognized all GPU. Attached pictures below:- (4) One of my main concern is I am still not able to get HWMonitor to show GPU temperature which is very important to monitor the current health of the GPUs. We would not want the GPU to overheat due to unforeseen reasons. Let me know if you are able to solve this issue. (5) During my discussion with crew member Rhyker, we were discussing on ways to tune the GPU from within Mac OS. As you know, currently the manufacturer only provide tuning software for Windows and to a limited extend Linux. We were thinking of running Windows under a virtual machine to access the GPU tuner to tune the GPUs. However, based on my last attempt, accessing native GPU from a virtual machine is still not possible although there are projects that are attempting to do this. Let me know if this idea is workable. Let me know if the clover bootpack works for you. Credits goes to Jake Lo and Bronx Teck Cheers! CLOVER-10.15.zip
  8. 3 points
    @Nancy10 Try my Mojave guide here Use this bootpack, files goes into /EFI/Clover replacing the default installed by Clover Kexts in ../kext/Other/CopyToLE should be copied to /Library/Extensions after installation as part of post install. Good luck 7480_HD620.zip
  9. 3 points
    - First create 2 partitions Extended Journal when installing OS X. Make sure to jot down the size so you won't wipe out the wrong partition when you install Windows on it later. Hint: don't make both the same size - Use Disk Utility to prepare a Mac OS X Extended partitions (don’t ever use Fat32, Disk Utility will mess up your drive) - After installing OS X, everything all setup. Then install Windows - Create a FAT32 usb drive, extract Windows 10 64-bit iso there (done on a Windows system) - Boot to Win10 usb drive, select custom install, locate the partition that is not OS X, delete it. Then select it (unallocated space) format it to NTFS, install Windows there. - Windows will automatically boots back to Windows. Install all drivers...etc. - Now to fix the boot option - Go to BIOS, create boot option. Browse to /EFI/Clover/Cloverx64.efi, give it a Name. Now move the Clover boot entry to top. - Save and reboot. Now you'll see the option to boot Windows or OS X from the Clover GUI. To fix the time in Windows, launch regedit navigate to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation] create a DWORD (32 bit) value, name it RealTimeIsUniversal. Set the value to 1. Exit Boot to OSX, then reboot to Windows. You should see time is correctly sync'd up.
  10. 3 points
    Just another 1-2 weeks, and you will have updates from me sure. I am working on it as I have some issues with my dev environment right now to finish. Thanks for the patience.
  11. 3 points
    Updates El Capitan 10.11.1 STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: None El Capitan 10.11.2 (15C50) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: None El Capitan 10.11.3 (15D21) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: None El Capitan 10.11.4 (15E65) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Upgrade to latest Clover prior to upgrade just in case New Issues: 1) KP on some systems with VoodooPS2Controller (Alps touchpad). Reboot with USB installer, select HD/SSD to boot. Remove /EFI/Clover/Kexts/Other/VoodooPS2Controller and replace it with Dr. Hurt's version R6B6 2) DummyHDA with Clover-on-the-fly patch stopped working Install new kexts for according to your CodecID Latitude Exx20 AppleHDAIDT.kext.zip Latitude Exx30 AppleHDA_IDT.kext.zip Latitude E7x40, E6540, E5440 Precision M4800, M6800 AppleHDA_ALC292.kext.zip Latitude E7x70, E7x50, E5450 Precision 7510 AppleHDA_ALC293.kext.zip Inspiron 3542, 5548, 5558, 5458 Latitude 3340, 3550 AppleHDA_ALC255.kext.zip Inspiron 5537 Latitude 3440, 3540 AppleHDA_ALC283.kext.zip Optiplex 9020 AppleHDA_ALC280.kext.zip Lenovo Z51-70 AppleHDA_ALC236.kext.zip * If your dummyHDA is not listed here and was working prior to 10.11.4, see here how to update it El Capitan 10.11.5 (15F34) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Same fix applied from 10.11.4 if you're upgrading from 10.11.3 and below or new install using provided bootpacks El Capitan 10.11.6 (15G31) STATUS: GOOD UPDATE METHOD: APP STORE/SYSTEM UPDATE MODIFICATIONS NEEDED: Same fix applied from 10.11.4 if you're upgrading from 10.11.3 and below or new install using provided bootpacks
  12. 2 points
    By popular demand and building on the guide I wrote for those cards some time ago + the subsequent extended feedback (mostly poor) on users experience, I thought it'd be useful to list those cards and laptops combinations that work or not. People may then opt for BCM450 cards with the best of knowledge. I invite all those who tested such cards to report their conclusions in order to build-up the registry. Important note: This is not a troubleshooting thread, there's already one here. This thread is only to report success or failure stating card model + computer model in order to complete a registry. Non-compliant posts will be deleted without any notice. DW1820A #0VW3T3 1028:0021 DW1820A #0VW3T3 1028:0023 DW1820A #096JNT 1028:0021 DW1820A #096JNT 1028:0022 DW1820A #08PKF4 1028:0023 T77H649 #00JT494 17aa:075a WCBN808B #00JT493 ? Dell Latitude 7490 Y ish N N Dell Latitude E7250 N N N Dell Latitude E7450 N Dell Latitude E7470 N Dell XPS 9360 Y Dell XPS 9560/9570 Y* Y* Dell Inspiron 7x72/7x60 Y* Dell Inspiron 7460 N N ? Dell 3040 micro Y Lenovo M900 mini N ThinkPad T440p/T440s N Lenovo P50 Y* Intel NUC8I7HVK Y Asus Zenbook UX410UQK Y* Latitude E5570 Y Lenovo R70 Y Acer Swift 3 SF314-54G Y* ASUS UX410U Y Lenovo Air IWL Y* Y* Y* Lenovo Y7000 81V4 Y* ASRock Deskmini 310/COM Y Asrock Z390 Phantom Y Lenovo Thinkpad 450s Y N N * with pin masking Notes: - - - - - DW1820A #08PKF4 1028:0023 reported to work Ok with: pin masking (3pins @front, 2pins/3pins @rear) (there's one report stating masking makes wireless unreliable but Bluetooth work) BrcmAirportFixUp kext brcmfx-driver=1 boot option (or brcmfx-driver=2 to gain Auto Unlock as described here) - - - - -
  13. 2 points
    Hello everyone, Little background information about firmware patch from linux: I've developed this kext to update the firmware needed for those Atheros AR3012 and Broadcom Bluetooth devices to work with all functionalities that hardware supposed to do. Also integrated support for the Atheros bluetooth AR3011 (from old kext by mac4mat) with some improvements/fixes in my kext to make a single solution for bluetooth. BUG REPORT (HAVE A PROBLEM?): Send me your system log file from /var/log, ioreg file saved using IORegistryExplorer app v2.1 and Sys info saved from the app System Information (found in Utilities) in File menu. To receive files from other bluetooth devices (like Mobiles), enable the option "Bluetooth Sharing" in System Preferences->Sharing. Want to know why you can't pair iPhone? Read here Your Combo card WiFi hardware is detected and working, but Bluetooth hardware was not detected in ioreg and not working ? Read this post (Credits: tomwho) Following are the Bluetooth cards supported by my kext: AR3011: Atheros AR5B195 Combo (AR9285 Wifi + AR3011 Bluetooth) Atheros AR5B197 Combo (AR9287 Wifi + AR3011 Bluetooth) Other Atheros AR3011 cards with ids list below AR3012: Atheros WB225 Combo (AR9485 Wifi(doesn't work) + AR3012 Bluetooth) Other Atheros AR3012 cards with ids list below Atheros AR3011 30 sec delay fix (or) after sleep issues patch: (Should be working in 10.9.1+) Enter the following two commands in terminal and reboot: sudo perl -pi -e 's|\x0F\x85\x07\x01|\x0F\x84\x07\x01|g' /System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/IOBluetoothHostControllerUSBTransport.kext/Contents/MacOS/IOBluetoothHostControllerUSBTransport sudo touch /System/Library/Extensions/ For Clover, add this to kext patches instead: Name: IOBluetoothHostControllerUSBTransport Find: 0F850701 Replace: 0F840701 Comment: Fix Bluetooth 30 seconds delay patch Credits to TimeWalker for the patch idea. NOTE: BCM4352 WiFi 5Ghz access is now working (Credit goes to SKVO fromapplife.ru. For complete details on making this WiFI card work, follow this thread: BCM4352 WiFi BROADCOM WiFi/BT Combo cards Bluetooth: Broadcom BCM4352 Combo Broadcom BCM4360 Combo Broadcom BCM43162 Combo Broadcom BCM4313 Combo (Not all cards need Update) BROADCOM USB/Integrated Bluetooth: Asus BT-400 USB Bluetooth Belkin 20702 USB Bluetooth USB Dongles with 20702A1 Bluetooth (Delock, IOGear etc.,) HP BRCM1043 Integrated Bluetooth (found in HP Elite Notebooks) Supported Bluetooth Vendor and Product ID: (Few device ids below work only from v2.8) Broadcom: VID: 13d3 PID: 3404 (Azurewave 4352) VID: 13d3 PID: 3413 (Azurewave 4360) VID: 13d3 PID: 3418 (Azurewave 4352) VID: 13d3 PID: 3435 (Azurewave 4352) VID: 13d3 PID: 3456 (Azurewave 4352) VID: 0b05 PID: 17cb (Asus USB) VID: 0b05 PID: 17cf (Asus 4352) VID: 0b05 PID: 180a (Asus 4360) VID: 050d PID: 065a (Belkin) VID: 13d3 PID: 3411 (Dell Alienware 4352) VID: 413c PID: 8143 (Dell DW1550 4352) VID: 0a5c PID: 216f (Dell DW1560 4352 NGFF) VID: 0a5c PID: 21e1 (HP Elite NB) VID: 0a5c PID: 21fb (HP 4352) VID: 0a5c PID: 216b (HP 4352 NGFF) VID: 0a5c PID: 216e (HP BCM43162 NGFF) VID: 0a5c PID: 21fd (Generic 4352) VID: 0a5c PID: 21de (4352) VID: 0a5c PID: 22be (4352/4360) VID: 04ca PID: 200a (LiteOn 4352) VID: 04ca PID: 200b (LiteOn 4352) VID: 04ca PID: 200c (LiteOn 4352) VID: 04ca PID: 200f (LiteOn 4352) VID: 0a5c PID: 21e6 (ThinkPad NB) VID: 0489 PID: e079 (Lenovo BCM43162 NGFF) VID: 0489 PID: e07a (Lenovo NGFF) VID: 0930 PID: 0223 (Toshiba NGFF) VID: 0930 PID: 0221 (Toshiba) VID: 0a5c PID: 21e8 (Dongles Delock, IOGear etc.,) VID: 0489 PID: e032 (BCM4313) AR3011: VID: 03f0 PID: 311d VID: 0489 PID: e027 VID: 0489 PID: e02c VID: 0489 PID: e03d VID: 0930 PID: 0215 VID: 0b05 PID: 179c VID: 0cf3 PID: 3000 VID: 0cf3 PID: 3002 VID: 0cf3 PID: 3005 VID: 13d3 PID: 3304 VID: 04f2 PID: aff1 VID: 04ca PID: 3002 AR3012: VID: 0489 PID: e056 VID: 0489 PID: e036 VID: 0489 PID: e03c VID: 0489 PID: e078 VID: 04ca PID: 3005 VID: 04ca PID: 3006 VID: 0cf3 PID: 311d VID: 0cf3 PID: 0036 VID: 0cf3 PID: 3004 VID: 0cf3 PID: 3010 VID: 0cf3 PID: e004 VID: 13d3 PID: 3362 VID: 13d3 PID: 3402 VID: 13d3 PID: 3474 VID: 0b05 PID: 17d0 Kext Customization: You can customize the kext for choosing firmware by editing the file "info.plist" located inside my kext "BTFirmwareUploader.kext/Contents/". Go to the section "IOKitPersonalities" and edit the entry which has your vendor and device id values. Atheros AR3011 and AR3012 BT: You can choose firmware from either linux (or) windows. (Linux firmware is recommended mostly) For Linux firmware, edit the plist entry "Use Linux fw" to Yes (or) true. ) For the Windows firmware, edit the plist entry "Use Linux fw" to No (or) false for both AR3011 & AR3012. For AR3011, you can also choose three firmwares from windows by editing the plist entry "Windows fw" to the values 0-2. Value '0' is the most recent firmware. [Note: Only Windows firmware 1 supports Fn key toggle for BT Off/on in Asus] Broadcom BT: Firmware to use: You can choose either firmware which is meant for that specific device (or) higher version available so far by editing the plist entry "DeviceSpecificFw" to Yes/No (or) true/false. You can abort (or) ignore subsequent firmware updates if the last update was failed by editing the plist entry "AbortOnFwUpdFail" to Yes/No (or) true/false. This is optional and its meant only in case if any system needed update process to continue even if last update was failed for success.(Available from v3.0.5) How to install: 1) Remove any patched kexts (or) Bluetooth enablers installed for Bluetooth and use Apple vanilla Bluetooth kext. 2) Install my kext (BTFirmwareUploader.kext) using your favorite kext installers to /System/Library/Extensions. (Don't install my kext through E/E (or) clover injection). Supports: ​Atheros BT is supported from 10.6.8 or later Broadcom BT is supported from 10.8.5 or later NOTE for 10.11: If you have any problems with my kext firmware update for Broadcom BT in 10.11 then use only "BluetoothDevBroadcomInjector.kext" instead which is just an injector to load Apple BT driver. Change Log: Update: v3.1 5 Released (Legacy version is for 10.10 or lower) Added support for new device ​Supports for 10.6.8 ​Fixed legacy version which was not working Some Minor bug fixes and optimizations Update: v3.1 (Legacy version is for 10.10 or lower) Updated non-device specific firmware version to latest available Added support new devices (check the updated list) Improved 10.11 support Some Minor bug fixes and optimizations Update: v3.0.5 Released Fixed a major bug affecting Atheros Bluetooth Improved 10.11 support Added a plist option for Broadcom Bluetooth to abort update process on fail (Optional) Some Minor bug fixes and optimizations Update: v3.0 Updated support for 10.11 using new SDK and USB API (you have to use kext compiled for 10.11) Made several Improvements and optimizations Fixed some minor bugs Update: v2.8.7 Added OS X detection to prevent/solve issues in 10.11 Fixed some bugs and made few improvements Update: v2.8.5 Fixed a major bug affecting some asus systems with KP Fixed issues related to firmware not getting updated sometimes Fixed some bugs in Atheros firmware update Added few new Atheros AR3012 bluetooth device ids to supported list Some improvements and code optimizations Update: v2.8 Updated firmware for some devices and higher version option Added support for some new devices Improvements to upload process time which finishes quicker now as i've reduced the time needed by doing more beta tests so works better Some minor bug fixes and optimizations Update: v2.7 Updated firmware for some devices and higher version option Added support for some new devices Fixes a bug when dual booting from windows which breaks BT Fixed a bug in BluetoothDevInfo kext injection and renamed the kext name Removed unnecessary "UpdAfterSleep" option from plist Some minor bug fixes and optimizations Update: v2.6 Added support for new Broadcom bluetooth devices Added support for new Atheros bluetooth devices Updated kext to use firmware specific to the Broadcom BT devices Removed unnecessary patch for HP BT (PID:21e3) Fixed some bugs Optimized code Update: v2.5.2 Final Added support for two Broadcom bluetooth devices from HP(VID: 0a5c PID: 21e3/PID: 21e1) Fixed a minor bug in BluetoothDevInfo kext Update: v2.5 Final Added plist option "UseStandaloneFw" to choose standalone firmware meant for BT only cards like Asus BT-400. Added support for two new BCM4352 BT (Dell alienware BCM4352 combo) Fixed device reset error bugs Some minor bug fixes and optimizations Update: v2.4 ​Added support for two new AR3011 BT(VID: 0489 PID: e02c and VID: 0930 PID: 0215) Added support for two new BCM4352 BT (HP and NGFF Toshiba) Added support for new AR3012 BT (VID: 0cf3 PID: 311d) Minor optimizations Update: v2.3 Improved performance of upload ​Fixed issues related to BCM Fixed issues related to firmware update after sleep Updated Broadcom firmware to new version Added LiteOn BCM4352 and an AR3011(PID: e027) card Moved bluetooth info to a plugin kext located inside the PlugIns folder Optimized code Update: v2.1 Added fully working support for AR3012 Updated new firmware in Broadcom Added Dell DW 1550 BCM 94352HMB card and AR3012 card ID's Fixed an issue with AR3011 bluetooth Optimized code Update: v2beta Added experimental support for AR3012(still in testing phase) Added firmware option for Broadcom and updated to new firmware Added new firmware for Atheros Added Asus BCM4352 card support Fixed an issue with AR3011 bluetooth which is failing for some cards like (dev:0x3000 & 0x179c) Apple bluetooth kext patch is not needed for Broadcom bluetooth anymore Update: v1.5 Added more Atheros Bluetooth devices (VEN:0cf3, DEV:3000,3002,3005) Fixed an issue with Atheros AR3011 Bluetooth after sleep Fixed an issue with Broadcom Bluetooth which prevented successful system boot without -v flag First release: v1.3 Enables Bluetooth in the new ac Broadcom BCM4352 card Added support for AR3011 from old kext(credits: mac4mat) Fixes an issue for AR3011 with the old uploader kext which is breaking during reboots in Asus Notebooks Added options to choose firmware for Atheros Bluetooth in the plist For any support, PM me in forums. Note: Don't mirror my kext please, just provide the link for my post. Credits: Leon for providing the opportunity & testing the kext, donators who helped to get me a card for the development, mac4mat (tonycrapx) for the AR3011 source and laloch(archlinux) for the ideas of Broadcom card PS: I've worked very hard in this and need your support , so I request you to consider a small donation if possible which helps me and allows to spend more time on this for future updates. Paypal: Thanks for the support. BTFirmwareUploader_v2.7_Final.zip BTFirmwareUploader_v2.8_Final.zip BTFirmwareUploader_v2.8.5_Final.zip BTFirmwareUploade_v2.8.7.zip BTFirmwareUploader_v3.0_Final.zip BTFirmwareUploader_v3.0_Final_10.11.zip BluetoothDevBroadcomInjector.kext.zip BTFirmwareUploader_v3.0.5.zip BTFirmwareUploader_v3.0.5_10.11.zip BTFirmwareUploader_v3.1_Legacy.zip BTFirmwareUploader_v3.1.zip BTFirmwareUploader_3.1.5_10.11.zip BTFirmwareUploader_3.1.5_Legacy.zip
  14. 2 points
    So here goes the T3500 Pack: I took a different approach to minimize effort and only use ssdt, no more DSDT, try attached EFI Folders. ( I added HDEF to DSDT but it did not help and voodoo seems to work better without, as HDA does not load) Only using //Patched: SSDT_LPC.aml to get "pci8086,3a18" loaded for PM/AppleLPC.kext. EFI Folder Voodoo: Sound works, sleep/wake works. EFI Folder ALC : Sound shows icons and values in sysprefs (and AppleHDA is loaded, see pic), but does not actually play sound. (I tried to resolve sound but apparently it is not that simple - at least I couldn't. Lots of info on ALC / AD1984A / Mojave being a problem.) Sleep/wake works too. Hardware is T3500 w W3680 cpu, GB Aorus AMD RX570, ASMedia Sata3 Card w/ 2 SSDs, a TP-Link wifi card , and 24 Gig Ram. I will continue to play with the settings in the plist checkboxes to minimize as much as possible. If you find there are useless settings (or important ones missing) in the config.plist please share your knowledge here. Give it a try...(EFI is from clover r4911/Mojave 10.14.6) Good luck T3500 pack.zip
  15. 2 points
    If HDEF (or whatever other audio device name) is not defined by default in your DSDT, maybe it is in an SSDT. You can dump all raw BIOS tables by pressing F4 at Clover main menu and then check things out. All extracted tables will be saved in EFI/CLOVER/ACPI/origin folder. But you probably already know that...
  16. 2 points
    Can't guarantee this will work, but here it is. Only patched for battery, nothing else DSDT.aml.zip
  17. 2 points
    It's a high-end GCN4.0 card, probably in the USD $150-$200 price range these days. Good for Mojave too. It really depends on what you want to do with it. For a fraction of the price (say USD $50), you can probably get a Kepler GT730 which will roughly provide similar performance as the GTX460 and is Mojave compatible too. Higher Kepler cards will do great too. I would have loved to recommended Pascal cards (I have a low-end GT1030 in my Vostro200 for High Sierra) but these are not Mojave compatible...
  18. 2 points
    @MrJonesIII Download AppleALC.kext + Lilu.kext and place into /EFI/Clover/kexts/Other In Config file, change Devices/Audio, change Inject from 1 to 5, under ACPI, enable FixMutex
  19. 2 points
    The release version also has layout-id 21, so should work too. https://github.com/acidanthera/AppleALC/releases
  20. 2 points
    Virtualsmc.efi driver is only needed for filevault. for normal booting all you need is virtualsmc.kext in clover/kext/other folder. if you are not using fakesmc.kext.
  21. 2 points
    @chabkhaled1960 Yes, but your wifi is not supported @mtpiplod Copy the files from the USB to the internal drive
  22. 2 points
    That's normal in Hackintosh for those brief seconds. Lilu.kext + Whatevergreen will remove some but not 100%. If you boot with verbose mode, you won't see it, so take your pick.
  23. 2 points
    No need to patch the kext or DSDT. Add Arbitrary under Devices in Config file. You just need to determine the PCIAddr by looking at the IOReg file under RPxx/PXSX, search for pcidebug. In this example it's RP01/PXSX@0, pcidebug = 01:00:00 You can also use dspci (app attached below) to find the address Change the PCIAddr accordingly If the card reader is not on this list, it might not be supported by this patch dspci.zip
  24. 2 points
    did you use all the different boot -arg after each reboot and insert the USBs? ie. boot flags (-uia_exclude_ss -uia_exclude_hs uia_include=x)
  25. 2 points
    Looks like your'e using my hot patched bootpack but not following my install guide. In /EFI/Clover/drivers64UEFI, remove everything except the following: Drivers64UEFI\DataHubDxe-64 Drivers64UEFI\FSInject-64 Drivers64UEFI\SMCHelper-64 Drivers64UEFI\ApfsDriverLoader-64 Drivers64UEFI\AptioMemoryFix-64 Drivers64UEFI\PartitionDxe-64 Drivers64UEFI\HFSPlus
  26. 2 points
    You forgot to mention it has discrete graphics as well. Your system is not Kabylake, not sure why you have MBP 15,2 as SMBIOS. So you have no graphics acceleration. Remove these from /S/L/E FakeSMC AppleIntelE1000 VoodooHDA realtechALC AppleHDA AppleIGB Replace the bootpack from here , goes into /EFI/Clover Also the SSDT-Disable-DGPU.aml goes into /EFI/Clover/ACPI/Patched Restore vanilla AppleHDA.kext from USB installer to /S/L/E You might need to add HFSPlus.efi into /EFI/Clover/drivers64UEFI Repair permissions and rebuild cache
  27. 2 points
    Clover Guide MacOS: Sierra / High Sierra / Mojave BIOS Settings: Set to Load Default, apply, then set Boot List Option to UEFI, SATA Operations to AHCI, Enable Legacy Option ROMs Disable Wake on LAN / USB / Wifi Follow my Clover guide Bootpack E7440_Hotpatches.zip //causes HP static noise on sleep/wake E7440_Mojave.zip //fixes HP static noise on sleep/wake FYI, kexts in bootpack is outdated Make sure to 1st upgrade kexts found under /EFI/CLOVER/kexts/Other if you encounter issue Common links for new kexts: https://github.com/vit9696/Lilu/releases https://github.com/vit9696/Lilu/blob/master/KnownPlugins.md https://bitbucket.org/RehabMan/ Post Install: Kexts inside /EFI/Clover/kexts/Other/CopyToLE are to be copied to /Library/Extension Repair permissions and rebuild cache sudo chmod -Rf 755 /L*/E* sudo chown -Rf 0:0 /L*/E* sudo touch -f /L*/E* sudo kextcache -Boot -U / Working: HD 4400 Full QE/CI DP/HDMI Video / Audio Webcam Sleep / Wake USB 2.0 / 3.0 ( not tested for speed) Speakers / Headphone SD Card Reader Fn+F3 & Fn+Insert for Brightness Control
  28. 2 points
    Broadwell is supported from Yosemite (forgot which version) up to the latest Mojave. You'll need to replace the Intel wireless card of course since it's not supported with a DW1560 or a USB device. Your system's specs: Inspiron 3558, supported devices: i3-5005U HD 5500 Synaptics touchpad ALC255 Webcam
  29. 2 points
    You need to remove the FakeID 0x12345678 from the Config file
  30. 2 points
    Found a fix here at InsanelyMac (thx @lubeats) for loss of DVI 2nd screen; patch of AppleGraphicsDevicePolicy kext: Find: BA05000000 Replace by: BA00000000 With this patch in place, I recovered DVI output off my docking station in Sierra 10.12.6 and High sierra 10.13.6.
  31. 2 points
    noticed a RX 580 expresscard eGPU attached to one of these systems: 2013 15" Dell Latitude E6540 HD8790M + RX580@4Gbps-EC2 (EXP GDC 8.x) + macOS 10.13.5 & Win10 [nando4] (eGPU.io) FCPX BruceX is accelerated and completes in 30s. Pretty good.
  32. 2 points
  33. 2 points
    Hi Guys, (Esp Jake). I just wanted to share my deep and complete gratitude for this forum and the support offered on here. I did a random google search a few weeks ago for Hackintosh & Latitude and found these forums. I quickly and easily installed OSX HS on my Dell e7240 (yes initially a bit buggy but oh well) I noticed that the E7440 was almost the same laptop but with a better screen. Something that really bugged me about the e7240 was the screen size, Lack of Hard drive expansion, and it really sucked for Programming. So picked up a used e7440 of eBay and moved my SSD and extra ram from the 12 inch into the 15-inch machine. A few patches, bugs, checking with the forum and getting help here has left me with an ALMOST perfect Mac pro!!!! Sound, Keyboard (UK) Battery life multiple screens outputs with HDMI + Mini DP. All WOrk brilliantly! Just can't believe that a low-cost laptop of eBay is as powerful if not more powerful than a $2000 USD Mac pro! Its just so awesome, and I am so thankful for all the work you do here. Right now my machine has: i5, 1080p screen, 256gb SSD, 16GB Ram, 2TB Seagate HDD, and I have 2 extra batteries on the way too! And it triple boots macos (Works perfectly) Linux mint (Works Perfect) and Win 10, (Obvs, slow as a dog, but works perfectly) So thank you thank you thank you very much!
  34. 2 points
    I am glad you enjoy it.
  35. 2 points
    Just an update to share as I promised few days ago. I am still working on it, and might need an extra week or 2 to share some news as i have issues with my development environment. Thanks
  36. 2 points
    maybe thats the problem! how do you add him to the cache? he is in the kexts folder!!!
  37. 2 points
    Hello and welcome to OSXLatitude. Post a pic about your error. Boot the system with -v and debug=0x100
  38. 2 points
  39. 1 point
    Here's what things look like on my Dell Latitude E6440 with a little Samsung SM841N 256GB mSATA SSD (SATA-III connection @6.0Gb/s):
  40. 1 point
    Nothing changed and nothing will...
  41. 1 point
    Moved from Guides section to Support! Please ensure you use the correct section for all future posting. K3100M is Kepler and is therefore expected to work OOB. K2200M is Maxwell and requires the nVidia Web Driver. It's therefore only supported up to High Sierra. You also have to take the potential issue of Optimus into account (unsupported on Hackintoshes).
  42. 1 point
    Replace the files I had linked here into /EFI/Clover Remove these from /EFI/Clover/drivers64UEFI VBoxHfs-64.efi OsxAptioFixDrv-64.efi Make sure you set BIOS to Load Default. Apply. Then change to UEFI / AHCI / Secure Boot Disabled / Legacy Option ROMs enabled
  43. 1 point
    Great great Mr Jake!!!! You Are the Man!!! One more time you make my day!!!! Thanks a lot my friend!!! Works good!!!! Very very thankfull!!!! Thanks Jake...
  44. 1 point
    ealextrain has Vendor ID: 0x1217 Device ID: 0x8221 Yours is Vendor ID: 0x1217 Device ID: 0x8621 Not the same but give it a try anyway. config.plist.zip
  45. 1 point
    @malcolm-d1g 1) The AppleALC.kext in Clover/kext/Other is corrupted, don't know if it's from the upload or in your Clover folder as well 2) The AppleALC.kext in /Library/Extension won't work without Lilu.kext in the same directory My suggestion, remove AppleALC.kext from /L/E Download new version of AppleALC.kext to clover/kexts/Other folder Repair permissions and rebuild cache
  46. 1 point
    I've an XPS 2720 All-In-One computer and successfully installed macOS Sierra 10.12.6 with Clover. Fully native graphics support on 2560x1440 built-in 27" screen. Touchscreen works too. Fully working Ethernet, WiFi, Bluetooth, Audio (patched AppleHDA), Internal Web Cam. Kexts used: CoreDisplayFixup.kext IntelGrpahicsFixup.kext FakePCIID_HD4600_HD4400.kext FakePCIID.kext Lilu.kext LiluFriend.kext RealtekRTL8111.kext Kexts_XPS2720_SIERRA_10_12_6.zip IntelGraphicsFixup_1.2.1.kext.zip Config.plist: IntelGFX 0x04128086 ig-platform-id 0x0D220003 config.plist.zip Ask me if you have questions.
  47. 1 point
    you probably need to update your usb limit patch as it has changed for mojave.
  48. 1 point
    Sorry, my previous patch was tested on Sierra. For High Sierra, use this instead.
  49. 1 point
    You need to create a _DSM method for each device and you need to determine the location of the device. You'll need know how to patch DSDT and read IORegistry to determine the location of the device. example: For my Wifi card, looking through IORegistryExplorer.app, I'll find it under RP04->PXSX So I need to create a _DSM Method in my DSDT under RP04/PXSX
  50. 1 point
    Hi balazs630 See in attached my full directory EFI my computer E5440. All seems to be OK (with post install audio kext ALC292 and wifi bluetooth) Stable with sierra 10.12.3 without success for me to install a 3G module (DW5570 or Hp un 2420) best regards EFI.zip
This leaderboard is set to Amsterdam/GMT+02:00
×
×
  • Create New...