Jump to content

Smart Tek Peru

Members
  • Content count

    9
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Smart Tek Peru

  • Rank
    Private

The recent visitors block is disabled and is not being shown to other users.

Enable
  1. Smart Tek Peru

    Dell e6530 Post installation issues High Sierra 10.13.6

    I took a look to your DSDT but I cannot see a patch related to the sd card reader. Is it working on your laptop?
  2. Smart Tek Peru

    Dell e6530 Post installation issues High Sierra 10.13.6

    I am sorry, made a mistake somewhere. Kexttopatch are loading from clover correctly. See attached 1. Sleep: Followed instructions and now sleeps works fine. SOLVED (actually I had to apply patches mentioned on the next line ) 2. A minimal video glitch on boot. I had to apply rehab video patched to fix sleep completely and the low brightness issue on boot. REMINING ISSUES 1. USB 3.0 not working yet. Changed my DSDT file as suggested, installed FakePCIID + FakePCIID_XHCIMux kexts to system/library/extensions (just to make sure, I have them in clover/others too ). Kext wizard shows that they are not being loaded. USBinjectall is loaded though. See attached. 2. SD card reader: applied patches to RP06 but it's not working. IOreg shows device on RP06. Attached is my updated dsdt Thank you DSDT.zip
  3. Smart Tek Peru

    Dell e6530 Post installation issues High Sierra 10.13.6

    1. Sleep: Followed instructions and now sleeps works fine. SOLVED 2. USB 3.0 not working yet. Changed my DSDT file as suggested, installed FakePCIID + FakePCIID_XHCIMux kexts to system/library/extensions (just to make sure, I have them in clover/others too ). Kext wizard shows that they are not being loaded. USBinjectall is loaded though. See attached. 3. SD card reader: Work in progress... 4. Graphics glitches: Patched as suggested but the glitches are still there. Something I noticed is that the clover boot log shows that only 2 kext to patch requested are being processed when there is a third one (intel glitches fix), see attached. 0:147 0:000 KextsToPatch: 2 requested 0:147 0:000 - [00]: AppleAHCIPort (Fix IO Error ICH10) :: BinPatch :: data len: 20 0:147 0:000 - [01]: com.apple.driver.usb.AppleUSBXHCI (USB 10.13.4+ by PMHeart) :: BinPatch :: data len: 10 Any other suggestions? Thank you
  4. Smart Tek Peru

    Dell e6530 Post installation issues High Sierra 10.13.6

    Tried but it did not add neither the sd card reader nor the usb 3.0. Thank you anyway
  5. Hi everyone, I recently managed to install Mac OS 10.13.6 to my dell E6530 (dual gpu>Nvidia graphics nvs5200m + IntelHD4000), Dell Bios ver A20. After some customization I got almost everything working but there a few things that I would like to fix: 1. Sleep issues: if I press the power button, the laptop goes to sleep but only for 2 seconds and then it's up again. If I close the lid, it does the same. I looked for the wake up reason in the log files and all show the same: LID0 EH02. 2018-09-06 14:49:11.170999-0500 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: LID0 EH02 2018-09-06 14:57:59.577740-0500 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: LID0 EH02 2018-09-06 14:57:59.577742-0500 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: LID0 EH02 2. Usb 3.0 not injecting: My laptop has 2 2.0 USB ports and 2 3.0 ports. On system report/USB, I am able to see the 2.0 ports but there's no 3.0 ports on the list. I am using USBinjectall kexts + ACPI patches: change EHC1 to EH01, change EHC2 to EH02 + Kextstopatch: com.apple.driver.usb.AppleUSBXHCI 837D940F 0F839704 0000 837D940F 90909090 9090 , but I am not able to make the 3.0 ports available. 3. Sd card reader: Is any way to make the O2 micro sd card reader work? 4. Video glitch on boot (apple logos and a grey bar at the bottom of the screen): this is not affecting performance if the intel gpu, as far as I can tell, but it’s a little bit annoying. Jake Lo already explained me that it is not possible to make the HDMI video output work since in this laptop model the HDMI connector is hardware connected to the Nvidia GPU and since it is being disable via DSDT, it won't work. I hope somebody can help me. Thank you very much for your assistance. PD DSDT file attached DSDT.aml.zip
  6. Smart Tek Peru

    [SOLVED] Latitude E6530 High Sierra Upgrade using Clover

    Actually, I found that voodoohda had an issue with my internal mic. I followed Bronxteck's advice and cleared up unnecessary kexts and leave only vanillaHDA in S/L/E and place latest ALC+Lilu in efi/clover/kexts/other . After restarting, audio worked as expected and there was no issue with my internal mic.
  7. Smart Tek Peru

    [SOLVED] Latitude E6530 High Sierra Upgrade using Clover

    I went back to voodoo and sound is working as expected (internal, usb headphones, line out). Too bad that hdmi video output is not available in the dual GPU of E6530 (nvidia nvs5200m + intel HD4000). Hopefully, somebody can find a way at some point. Thank you for your help.
  8. Smart Tek Peru

    [SOLVED] Latitude E6530 High Sierra Upgrade using Clover

    Thank you for the advice. I'll star over.
  9. Smart Tek Peru

    [SOLVED] Latitude E6530 High Sierra Upgrade using Clover

    Hi everyone, I read that using the hdmi video connection for the E6530 is possible (turning Nvidia off via DSDT) but the applehda audio kext must be used (not voodoo), is that correct? I am trying to activate the internal sound of my laptop using Applehda (patched via HDA patcher) + applealc + lilu + commander but I can´t (usb headphones work ok). Thank you for your help (attached is my DSDT file) DSDTv2.zip
×