Jump to content

macOS X Sierra on ThinkPad X201 Successful


crownace
 Share

Recommended Posts

Hello, osx86 Hackers, First of all i checked and didn't find duplicate and so hope its not a repost. i have successfully installed macOS Sierra (10.12.1) on my Lenovo ThinkPad X201. My specs are as follows:

8GB DDR3, 256GB SSD, Intel HD 1st Generation, Core i5 520M at 2.4GHz, 12.1" LCD, Native resolution is 1280x800.

Also Dual booting between Windows 8.1 (x64) and macOS Sierra, running on MBR partition, using Clover.

 

What works.

=========

Graphics works Flawlessly with QE/CI (Also Screen Brightness slider works), Sound works, Wireless (replaced with AR5B95- works OOB), LAN works with Driver (Intel Gigabit), Broadband HP hs2350 works OOB, TrackPad works, Keyboard works, USB works, SD Card works.

 

What does not work

===============

Bluetooth (Strange! see story below), Hibernation not working

 

How it worked

===========

After struggling with installation of osx on this portable machine, 10.9 was hell trying to install but decided to install Yosemite, which installed successfully but could not boot due to graphics Problems. I decided to go for EL Captain which was a last resort, but found it installed successfully and then gave a shot to Sierra which worked very well.

 

But this is now the order for sierra.

==========================

First i had windows 8.1 running on one partition and the second partition was reserved for osx. 

I had to patch the Installer for MBR installation, then using my Mhack Pro i created a Sierra bootable USB hard disk.

Installed Clover over the USB disk so i could access EFI folder both in windows and OSX without having to remount.

In the Clover i added the Essential Kexts (FakeSMS and HWinfo). Also added 2 other required kexts, VoodooPS2.kext, Natit.kext. The VoodooPS2 ensured my Keyboard and Trackpad both work since they are hooked to a PS2 terminal in ThinkPad. The Natit ensured i use my internal LCD for installation without having to hook external display or without getting scrambled Graphics. These Kexts i placed in EFI>Clover>Kexts>10.12

Then to successfully boot into installer, you can remove the intelHDGraphics files from Extensions folder or you can place the attached IntellHDGraphics kexts into your extensions folder.

Note that the attached Framebuffer is of Single link because my Resolution is 1280x800. So i used the Patched Framebuffer of Single link. The installer displayed everything because of Natit but if yours fails to diaplay because of graphics issues, then remove all IntellHDGraphics kexts from extensions folder and install.

 

After installation, if the installer displayed correctly, you copy the IntellHDGraphics files attached to extension folder and boot up to do post installation.

i have attached my DSDT but patched to boot without Natit, but if your installation does not display after the installation, use Natit and you will proceed to Desktop.

You will have to install Clover, then use Kext utility to install those Kexts in Extension folder or simply run it to repair permissions.

The intelHDGraphics are from Sierra and if you need to patch your own Frame buffer, you will have to use the stock files from Extension folder after installation completes. 

Always back them up before removing them.

My Config, DSDT,SSDT are all attached. 

 

Now the challenge i still have is battery that i'm yet to fix and Bluetooth.

 

Here is Bluetooth Story

==================

I have run this machine for about a year and windows 8.1 has been on for that time. up until now i had never thought OSX86 would work on this machine, as i was running it on my HP Pavillion Desktop.

Since it was well with Win81, everything including Bluetooth was working well. But because this machine has no Touchpad, i have been using this tiny trackpad (the Accupoint in the Keyboard). Also machine has only 3 USB ports. so i decided to reserve the USB ports by getting an Apple Margic mouse, which has been working well.

This Bluetooth Rodent was very good until i decided its time to put Mhack on x201.

Along the installation, as the installer was booting, it turned off the Bluetooth and even after completion of the installation, i could not activate bluetooth. When i switch to Windows, i don't equally see bluetooth. In the Lenovo Settings, i see all other Wireless connections can slide on and off, but bluetooth is greyed out that you cannot turn it on!

First i thought the Bluetooth Daughter card had died, but when the machine boots, i see bluetooth is light and immediately OS begins to load (OSX or Windows) it turns off. Mhac says bluetooth can't be turned on. Windows now says Bluetooth Hardware is not found.

To check my suspicion, i put into a ThinkPad T410S and it worked without problem. I put another Daughter card (underneath the LCD) and it still did not work.

Now this machine is funny because in Bios there is no where Bluetooth is mentioned, but thats no problem because it was working that way when Bios is not mentioning it.

Now i wonder if any one has a solution to have my Magic mouse to work. I didnt want to add usb Bluetooth as it reduces the USB Ports available to 2. I have bios updated to 1.4, (with whitelist removed) but still no luck.

I don't know what Mac installation did to switch off bluetooth to point of no return.

Tried uninstalling and re-installing power management in windows. But now i'm out of ideas. Anyone?

 

Essentials.zip

  • Like 1
Link to comment
Share on other sites

Actually, there is a bluetooth activate/deactivate option in BIOS, but is under a not so intuitive menu.... Anyways, that's not the problem causing this issue, if you didn't deactivate it under BIOS prior to that... 

 

The problem is caused by the MacOS!

 

To have your bluetooth back on, just make a live USB with any Linux (I've used Kali) distribution and boot into it (just that, no need to do anything else in Linux).

 

After that, you will have your bluetooth back, under both Windows and MacOS.

 

It's a 'strange' FIX, I discovered it by mistake a few years ago, but will do the trick.

 

BTW: Is your Sleep/Wake from Sleep working? You only mentioned the 'hibernation' issue under 'not working' line, or that's what you meant by 'hibernation'(which are not the same thing)?

Link to comment
Share on other sites

Hi .. 

 

Can you tell me which version of clover did you use?

I created a bootable usb with Sierra 10.12.6 applied Clover_v2.4k_r4220.

Applied your DSDT.aml and SSDT.aml.

I also put FakeSMC, HWInfo, Natit and VoodooPSController into EFI>Clover>Kexts>10.12

 

In your instructions.. you mentioned... Then to successfully boot into installer, you can remove the intelHDGraphics files from Extensions folder or you can place the attached IntellHDGraphics kexts into your extensions folder.

 

I do not see this file in your Essential.zip and also... you say remove intelHDGraphics from the Extensions folder.. where is this extension folder..... it is definitely not in the EFI folder? during initial install there is no Extensions folder...

 

Anyway i get a black screen with a blinking cursor.. i cannot seem to boot my machine..... 

Can you also tell me what yours bios setting is?

 

I have got this machine to work with Mavericks a long time ago...with the instruction found in website..

 

I would really like to get my x201 to work with Sierra... 

 

Thanks

 

bd4utonite2

Link to comment
Share on other sites

Check out the post #7 from this thread, I've exposed there a simple guide on how to install High Sierra on X201.

Hi....

 

Thanks for the link but it did not work for me ?

I still get a black screen with a blinking cursor on my x201.

 

I put H. Sierra on a new USB Stick.. mounted the USB EFI Partition...

Copied the EFI folder from your EFI-to reach Installer to the USB EFI...

The remaining files and folders from "EFI-to reach installer" i copied to the non-EFI 

partition of the USB.

 

No luck on boot as it never even reach the clover menu before boot.

Is your method using VGA or the laptop's LCD???

 

Maybe you can share any special BIOS setting with me...

 

Thanks

 

bd4utonite2 

Link to comment
Share on other sites

  • Administrators

Gents, this is a Sierra-related thread. If you wish to discuss High Sierra -and since it differs quite a lot from previous versions with regards to installation-, please create a new thread. This for the benefits of other folks who would be interested in discussing High Sierra on this laptop.

  • Like 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...