Jump to content

Precision M6500 Sierra


griftopia
 Share

Recommended Posts

I have made some progress. My USB was build with 10.12.5 + Enoch.

 

What I did...

  1. DSDT patched with Rehabman's patches using MacISL (I applied one at a time which seemed to make sense)
  2. FakeSMC 2017-0606 patched for Nvidia GPU 10de,061f. Main kext and sensor kexts being used.
  3. Kexts in /L/E (Kernel Booter still Yes but I know sound + bt will only work from /L/E and they do
  4. EHCx -> EHXX applied to DSDT which is how I was able to boot and install
  5. Applied hibernate mode fix (set to 0, set hibernate file to /dev/null and removed sleepvarimage)
  6. CPU is Clarksfield. I used my best judgement selecting SMBIOS. 6,2 is generic i5/i7. Other options were Sandy/Ivy Bridge so thought shouldn't pick those options.
  7. Weird issue. Ethernet downloads become corrupt sometimes, e.g. iTunes update, 10.12.6 update. I downloaded on another machine on wifi and then copied over 10.12.6 and then installed. Unsure if something can be tweaked.

 

How it is working...

  1. Full QE/CI working.
  2. Sleep does not work, period :-( Just pretends and then wakes back up
  3. Shutdown works! This was a surprise
  4. WebCam works :-D
  5. HW Monitor showing 149% battery. Huh? Not entirely sure it is working but temperatures look reasonable while mostly late 50s, early 60s.
  6. USB ports on the left don't work. They are USB3. The right one is USB2 which still works.
  7. Using AzureWave NB290 Broadcom Wifi + BT Combo. BT works using kext. Wifi does not work, but that I think is BIOS issue which says "unknown device". I have latest BIOS A10, but maybe BIOS hack available and will hunt for it.

 

This laptop is going to be a desktop replacement. I can live without Wifi since I can use Ethernet Port (I have docking station and hope that'll work too). If I can just get help to fix my Sleep and USB3 ports, would really appreciate it. Also another problem is that once laptop attempts to sleep and then cannot, I lose my webcam :-(

 

post-90049-0-85962700-1504447957_thumb.png

Extra.zip

M6500_ioreg.zip

  • Like 1
Link to comment
Share on other sites

I was trying to see if I could patch FakeSMC to get wifi working but kept messing it up. Not sure if there is guide to do this so S/L/E kexts don't have to be patched. 

 

Anyways, for now I've patched the device ids and I have both wifi and bt working (I removed the Dell bluetooth kext that I had kept by accident, while it was not harming anything). 

 

So now I just need my sleep and USB ports to work. 

Link to comment
Share on other sites

Guys. can some one help me? I can live without the USB ports on the right, and incorrect battery percentage, and I can always get different wifi/bt cards, but I have to be able to get the laptop to be useful for what I need it for. I

 

Right now I have removed USBInjectAll kext. When I do that I lose Camera and BT and Wifi. So using Ethernet port. 

 

I'm hoping its just some DSDT patch I'm missing, but I've tried everything I can think off. Laptop simply will not sleep. Anything that will help enable the remaining usb internal and external ports without killing sleep?

 

For now, I've simply removed the offending ports under EH02 that are preventing sleep including camera. I'm going to focus on why at random I lose wifi (i get not installed error ???)

 

:-(

Link to comment
Share on other sites

@Griftopia

I too have a M6500 with only difference in the graphics (ati firepro), and have installed up to el capitan using clover.
I am trying with enoch (heard about better imessage compatibility) but i can’t boot the installer. Sticks at waiting for root device.

Can you please list all the patches you applied to your dsdt, the way you created the usb and the options you installed enoch with?

Thanks...

 

PS

It took ALOT of reading and experimenting to make my graphics finally work, and i gave up after another ALOT of efforts to make sleep work. Not many have this laptop, and you are the third i found trying with osx. So dont expect much help from the community.

But in my case all usb ports worked (can’t say about Sierra).

The ethernet kext that floats around is problematic above Yosemite (i think this is why you had corrupted downloads, i had problems too).

Wifi worked fine for me with a compatible Atheros card.

But it looks like we have to figure the rest ourselves.

  • Like 1
Link to comment
Share on other sites

Asxetos, I've loaned the machine to an extended family member right now. So need few days to come back with DSDT. Thanks.

 

PD - My plan is to do an inplace upgrade to Clover first. Which means try to get a USB with Clover to boot the laptop, then install Clover on top of Enoch, then try inplace High Sierra upgrade.

 

Unless I grow in confidence on High Sierra from scratch. I'm working on another laptop right now with which I might try a scratch High Sierra install, with dual boot.

Link to comment
Share on other sites

@Asxetos, FWIW attaching my DSDT if you still needed it.

 

PS - I have successfully loaded 10.13 using Clover USB but for the life me cannot get Clover to install and activate on the HD. The entire point of going to Clover was to get Sleep + Device issues working correctly. I see no difference in functionality right now since I can't seem to get Enoch disabled (subject of another thread I've started)

DSDT.aml.zip

Link to comment
Share on other sites

 Share

×
×
  • Create New...