Jump to content
Bosancero

Dell Latitude E5530 & Sierra

Recommended Posts

I have an DELL E5530 and as a newbie, i have (somehow) installed MAC OS Sierra 10.12.3 on my Notebook. Thereby I found on youtube a guide how to create a bootable USB Stick from windows (as I don't have a second MAC) and later I found somewhere in the web a better EFI folder which I have used to normally boot and install Sierra. I am using CLOVER and here my E5530 specifications:

Intel i5-3230M CPU
8 GB RAM
BIOS-Version A11
High Definition Audio-Device
Intel® HD Graphics 4000   (1920x1080, Full HD)
Broadcom NetXtreme-Gigabit-Ethernet
Dell Wireless 1504 802.11b/g/n (2,4 GHz)

Surely there are a lot of hackintosh forums and descriptions (mostly for other Models/HW) on the web, but as a newbie, I spent a lot of days to become a functioning system, also performed min. 5 installations => It still doesn't work. Here are my problems:

  1. Under Settings / Network a "Ethernet" device is listed (for the wired connection, LAN). But is has a difficult MAC address 00:00:00:00:00:00... I can fix this with "ifconfig en0 ether <usefull MAC address>" within rc.local. Thereby DHCP does not work and is cyclically connect and disconnect whole the time. So I set the IP/Subnet Mask/Router/DNS Server manually and the Notebook in this way becommes connected to my router and the Ethernet device becomes status "Connected" ==> The problem is that it only looks great but the Notebook is still not connected (why/how ever)! Pinging the router or such other usefull IP does not work. I don't know what to do/try next.
  2. My WLAN does not work. Under Settings / Network there is no WLAN listed.
  3. I have no sound.

Is there anyone of you having Sierra installed properly supporting HW like for my DELL E5530 who can send me the relevant EFI folder (for the EFI partition) and describe me in few steps a postinstall situation?

Additional Info:

ls -1 /Volumes/Hackintosh/Library/Extensions/
ACS6x.kext
ATTOCelerityFC8.kext
ATTOExpressSASHBA2.kext
ATTOExpressSASRAID2.kext
ArcMSR.kext
CalDigitHDProDrv.kext
HighPointIOP.kext
HighPointRR.kext
PromiseSTEX.kext
SoftRAID.kext

I have attached my actual EFI folder (from the EFI partition).

Any help is wellcome :mrgreen:

EFI_E5530.zip

Share this post


Link to post
Share on other sites

See post installation in Clover guide here

New bootpack for E5530_A12 just uploaded in post # 2 of guide.

 

For Ethernet, I read some had success by manually changing the speed to 100BaseTX

Share this post


Link to post
Share on other sites

Jake Lo, thx for the info. Your hint solved my sound problem so my Notebook has sound now :-P

 

But the LAN (en0) still has problems. The MAC Address is still 00:00:00:00:00:00 and I have to set it manually after each reboot (ifconfig en0 ether <usefull MAC address>). Adding it to /etc/rc.local is not handled during start-up, whyever...

 

The ethernet speed is according ifconfig output automatically set to "media: autoselect (100baseTX <full-duplex>)". I have tried to set it manually and ifconfig shows "media: 100baseTX <full-duplex>". But at the end, I can not imagine different behaviour after settin the speed manually.

 

The final problem is that the Ethernet connection status is pending between "Connected" and "Not connected".

When it becomes connected, according ifconfig I see:

en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	options=3<RXCSUM,TXCSUM>
	ether 00:80:48:ba:d1:24 
	inet6 fe80::14ad:2dfd:6309:9e9f%en0 prefixlen 64 secured scopeid 0x4 
	inet 192.168.1.5 netmask 0xffffff00 broadcast 192.168.1.255
	nd6 options=201<PERFORMNUD,DAD>
	media: 100baseTX <full-duplex>
	status: active

When the Ethernet connection status is "Connected" and everything seems ok, there is no activ internet, no pages can be opened :? This behaviour is given in case of DHCP and when manually setting the parametert for the Ethernet connection.

 

Any ideas (or similar situations) how to handle/solve this problem(s)?

Share this post


Link to post
Share on other sites

try looking for a newer or better replacement for the network kext BCM5722D.kext seems to be for snow - maverick I see your using fakepcid maybe try the injector for network.

Share this post


Link to post
Share on other sites

I use BCM5722D.kext v2.3.6 and according this post it works for other users:

https://osxlatitude.com/index.php?/topic/9484-e5420-el-sierra-only-partially-working/?p=69330

 

Thereby I also listed the PCI devices and found BCM5761 GigEthernet card with id 14e4:1681, and this ID is listed in my used BCM5722D.kext v2.3.6.

==> It still does not work for me :(

 

Also disabling the Legacy Option ROMs option in BIOS does not help (so I enabled it again)!

 

What else to look for?

 

And what do you mean with "I see your using fakepcid maybe try the injector for network.". I am not so familar with a lot of hackintosh stuff...

 

Thx

Share this post


Link to post
Share on other sites

Thx for your answers :)

 

I have replaced my EFI CLOVER stuff with the files from the new Bootpack for E5530_A12 from post # 2 of guide here (like suggested by Jake Lo in post #2 here, see my post #3 above). So kexts FakePCIID.kext and FakePCIID_XHCIMux.kext are part of the "Others" folder. Is something wrong with them?

 

I does not understand what https://github.com/RehabMan/OS-X-Fake-PCI-ID has to do with kexts FakePCIID.kext and FakePCIID_XHCIMux.kext from my "Others" folder. Or do you post the Link just to make a hint to the description? What do you mean I should do/change/update?

Share this post


Link to post
Share on other sites

No, it does not help :( in this case the en0 device does not exist.

 

I have deleted FakePCIID_BCM57XX_as_BCM57765.kext and copied back BCM5722D.kext to the /kexts/Other folder and the en0 device exist now but the problems still exist (refer to my post #3 above).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×