Jump to content

[SOLVED] E7470 + Wi-Fi (DW1560)


andradejose
 Share

Recommended Posts

Hello everyone.

 

I want to thank everyone who has contributed on putting together all this guides to help the OSXLatitude community, I understand all the work and time that goes into It and it's very appreciated.

I have been able to successfully install HighSierra using the guides but have run into trouble getting my Wi-Fi card working. Everything else seems to be working fine. FYI, in the BIOS the WiFI card is enabled but not recognized in the OSX. Bluetooth is working fine.

 

I used the following: 

EFIv4119 + E7x70v1.17.5

Replaced the config file with the supplied High Sierra one.

Added interlgraphicsDVMTFixup and LiLu to kexts/other in the laptop's EFI partition.

Installed Clover v42.43

Run the ssdtPRGen.sh scrip and placed the generated .aml file as indicated in the guide but it displayed a warning.

 

I have attached some screenshots of everything I think can be of use for your help.

 

Thank you in advance for your help.

 

 

post-113763-0-03650800-1508169539_thumb.png

post-113763-0-30405800-1508169557_thumb.png

post-113763-0-44953500-1508169565_thumb.png

post-113763-0-81251900-1508169577_thumb.png

post-113763-0-69666600-1508169591_thumb.png

post-113763-0-28742100-1508169605_thumb.png

post-113763-0-41684200-1508169626_thumb.png

Link to comment
Share on other sites

  • Moderators

I assume you have BrcmPatchRAM2 & BrcmFirmwareRepo in /L*/E*?

 

Boot to Clover GUI, hit the F4 key, continue on booting OSX

Mount the EFI partition, navigate to /EFI/Clover/ACPI/Origin

If you don't see SSDT-14-DptfTabl.aml, then you should use the DSDT/SSDT from the alternate bootpack instead.

If you do, then try disabling Legacy Option ROMs in the BIOS.

Link to comment
Share on other sites

Thanks for your quick reply. I have BrcmPatchRAM2 & BrcmFirmwareRepo in /L*/E* and they load properly when repairing permissions.

I don't see SSDT-14-DptfTabl.aml (picture attached). Does it matter which alternate boot pack DSDT/SSDT I choose? My BIOS is 1.16.4. Would it be alright if I just replace the ACPI folder alone?

 

Bronxteck: I installed lilu plugin kext, run permission but it does not show as a loaded ket. 

post-113763-0-85082300-1508176975_thumb.png

post-113763-0-53676300-1508176993_thumb.png

Link to comment
Share on other sites

  • Moderators

Send me the Origin folder and I'll patch them for you or you could upgrade your BIOS to 1.17.5 and use the alternate v1.17.5.

You can just replace the ACPI folder, but you'll also have to modify the Config file under SSDT SortedOrder since the SSDT numbering are different.

Link to comment
Share on other sites

Jake, I REPLACED your patched DSDT/SSDT in EFI/Clover/ACPI/origin along with the config.plist file but still no luck.

FYI, Legacy Option ROMs in the BIOS has been always disabled. I enabled it after the patch but my laptop won't boot. I had to revert it back to disabled.

Also, does it matter that I am booting Clover using "FileVault Preeboter from Preboot" instead of "Macintosh" HD? 

I have attached my new origin folder.

post-113763-0-88495400-1508181880_thumb.png

post-113763-0-00807900-1508182762_thumb.png

Link to comment
Share on other sites

Jake, forgive my ignorance 8-) .

I'm a newbie when it comes to IT stuff. My Wi-Fi is finally showing up and working perfectly.

Thank you very much for your advises, patches and your time.

Just out of curiosity, how do you generate the patched files you uploaded?

Link to comment
Share on other sites

 Share

×
×
  • Create New...