Jump to content

[Short GUIDE] Install High Sierra on Lenovo X201 [i5 520M]


Recommended Posts

I have the same model as yours but somehow it is hard for me to get clover to work.

I created a clover USB with the Bootdisk Utility and copied your EFI-to reach files to the USB (needed to overwrite, when I delete them and use yours I get blinking cursor, aswell as when I keep the files from the BU tool, so I need to paste and overwrite your files), as soon as I boot the clover USB i dont have another USB showing up with the Mac OS on it, the problem is, I dont have a mac to create a Mac OS usb, only have the dmg file, which I tried to convert to img, but didnt work either. Any other tips?

Link to comment
Share on other sites

I have an x201i Intel i3 and I had trouble using the files attached and graphics would always end up scrambled,  one thing I did was to just use Clovers Default config.plist and Kext's that came w/ it. Install Clover to USB (I used VMWare for that) and go with that config, but also use the settings: 'InjectIntel 0x12345678' & Boot Arg: 'npci=0x2000'. Nothing else (thats just for me tho. YMMV). still having trouble getting graphics to work to full acceleration (Chrome/Safari looks like s**t) but I'll figure that out. Everything else works really well.


Just thought I'd add my 2 cents in. This took me 2 days to get set up properly & works out well I reckon.

Edited by Phoenix Lemalu
So it makes sense...
Link to comment
Share on other sites

First I had already installed windows 10 on my x201. I want to install mac OS Sierra.

Download OS Sierra.dmg file from Apple web page.

1.       format USB as per your instructions and download CloverISO-4428.tar.lzma.  open Clover folder using 7-Zip until I see the folders (EFI, Library, Usr, [BOOT]). I drag drop first three folders (EFI, Library, Usr) to formatted USB and download CloverLegacyInstaller.zip, open CloverLegacyInstaller.zip using 7-Zip and drag drop cloverlegacyinstaller.exe to USB. Run clover installer in USB and pop up window show “Clover has been successfully installed”.

2.       Download the “TransMac”. Mount another USB run and TransMac as administrator. I format USB using TransMac as “Disk format for Mac”. After format right click on formatted USB and click on “Restore with Disc Image file” (find in download folder “Mac OS Sierra.dmg”) after selection the subject file, TransMac will take 8 to 10 Minutes for creating a bootable USB of Mac OS Sierra. When it is done, I dismount the USB and shutdown the machine. Again mount both USB and start the machine, on start press F12 for boot menu and click on boot from USB (Clover bootable) after one second Clover start and show all partition of HDD, but other USB (Mac OS Sierra 10.12.1) was not shown. Pictures are attached.

 Any other useful tip. Thanks









Link to comment
Share on other sites

Reaching the installer and installing went quiet smooth.


I only placed the DSDT into EFI/CLOVER/ACPI/patched and edited the config.plist after the post installation. Under ACPI I ticked "Generates PStates" and "Generate CStates" like I did in my previous installation.



Sound -> VoodooHDA

Trackpad -> VoodooPS2Controller

Battery Indicator -> ACPIBatteryManager

LAN & WLAN -> IntelMausiEthernet and replaced WIFI card

QE/CI -> AppleIntelHDGraphicsFB (Guide) 


Is it possible to patch the gfx on the fly with clover like it did in the installation guide for Yosemite, page 5?




Link to comment
Share on other sites

hi calabash,


do you have it working well with sleep etc.? i'm asking as i tried to get sierra running on two x201 and failed - got them basically running well including graphics, but backlight control (hotkeys respond but do not change the brightness and the slider in the monitor preferences does not change anything neither) and sleeping do not work properly: it starts to got to sleep normally and the sleep light goes on, but there are still disk accesses and the machine stays warm, so i assume it continues to run anyway. when i wake it up from this state it comes back immediately. another strange thing is that on one of the two x201 the fan never turns on, so that the machine overheats after a while. if you have it fully working on your end, it would be nice if you could post your EFI folder and maybe the dsdt patch steps you did. i did follow your old guide, but with updated kexts, clover and i rebuilt the dsdt from my machine from scratch following your nicely detailed readme in your old dsdt attachment.


a lot of thanks in advance and best wishes - hexdump

Link to comment
Share on other sites

Hi hexdump,


unfortunately sleep functionality is not working proper on my x201. It falls to sleep but it never gets back. I have to reboot the machine.

Hotkeys for brightness are working fine.

Temperature sensor indicates most of the time between 48 and 60 and the fan is always running at half turn.

Sry that I can not provide you a full working DSDT.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...