Jump to content

HP Slimline Core i3-7100 with Intel HD630


nareto
 Share

Recommended Posts

Hi everyone

 

After I have tried hard digging info from the web's thread, I am done!and I really need your help. I bought a HP Slimline which comes with Core i3-7100 CPU. it has an Intel HD630. It's a small PC.

 

My problem is I cannot enable QECI on the PC. I tried:

  • FakeID> IntelGFX 0x19168086
  • ig-platform-id 0x19160000
  • FAKECPUID 0506e3
  • FakePCIID+ FakePCIID Intelgraphics S/L/E
  • intelfixup + lilu L/E

Still have no luck. then I tried

  • FakeID> IntelGFX 0x59128086
  • ig-platform-id 0x59120000
  • FAKECPUID 0506e3

it was the same

Link to comment
Share on other sites

  • Administrators

at boot try disable all your graphics related patches above using clover GUI option menu and only leave inject intel on. that should allow clover to auto detect the graphics. you can probably leave LILU and intel graphics fixup but you might want to add also the intel DVMT kext but move them from L/E to clover /kext /other folder

Link to comment
Share on other sites

here are what I did.

Update OS to 10.12.6

FakeID> IntelGFX 0x19168086 . (TRIED 0x59128086 it didn't work. it caused kernel panic)
ig-platform-id  BLANK 
FAKECPUID BLANK
FakePCIID+ FakePCIID Intelgraphics Move from S/L/E to L/E
intelfixup + lilu L/E DELETED from L/E

 

Kext rebuilt . Result was the same.

 

FakeID> IntelGFX  BLANK
ig-platform-id  0x59120000 
FAKECPUID BLANK
 

the Result , it booted to kernel panic.

 

 

 

It 's still the same. what should i do next? please

Link to comment
Share on other sites

  • Moderators

If you're on 10.12.6 and higher, you can use ig-platform-id 0x59120000, fakeID IntelGFX = 0x59128086

If you're running anything below, then use  ig-platform-id 0x19120000, fakeID IntelGFX = 0x19128086, FakeCPUID = 0x0506E3

 

In your Config, you're injecting 0x19320001 which is incorrect.

Link to comment
Share on other sites

I will reinstall 10.12.6 again.

From what I found I installed 10.12.5 and upgrade to 10.12.6. Even I changed ig-platform-id 0x59120000, fakeID IntelGFX = 0x59128086. It gave the same result. I only booted it by using 0x19320001 or 0x19120000 with FakeCPUID = 0x0506E3 (as you saw in my config.)

Last night I did again. I used ig-platform-id 0x59120000, fakeID IntelGFX = 0x59128086 but it booted kernel panic.

When I checked in System report> graphics /display. it said "kext not loaded".

Link to comment
Share on other sites

 Share

×
×
  • Create New...